summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2012-05-31 15:51:15 +0300
committerPanu Matilainen <pmatilai@redhat.com>2012-05-31 16:46:40 +0300
commitbf088dbeb5fbc67cae647ec13d02fdabc1a4f64c (patch)
treef76c1f5deab52bf4ae8fc2fb82e9f467d96137b1 /configure.ac
parent38932d1d175b8ff8a509d2d9995ffb3eb576ff3a (diff)
downloadlibrpm-tizen-bf088dbeb5fbc67cae647ec13d02fdabc1a4f64c.tar.gz
librpm-tizen-bf088dbeb5fbc67cae647ec13d02fdabc1a4f64c.tar.bz2
librpm-tizen-bf088dbeb5fbc67cae647ec13d02fdabc1a4f64c.zip
Bury our glob() implementation entirely inside rpmglob.c (RhBug:819680)
- Lump glob.h and glob.c into rpmglob.c in all their g(l)ory libc decorations and make everything static to stop overriding system library symbols with our own glob().
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 622affed8..dd90d3466 100644
--- a/configure.ac
+++ b/configure.ac
@@ -347,8 +347,6 @@ AC_CHECK_HEADERS(sys/utsname.h)
AC_CHECK_HEADERS(sys/systemcfg.h)
AC_CHECK_HEADERS(sys/param.h)
-AC_CHECK_HEADERS(glob.h)
-
dnl statfs portability fiddles.
dnl
dnl We should really emulate/steal sections of the statfs and struct statfs
@@ -489,15 +487,6 @@ AC_CHECK_FUNCS(
[mkstemp getcwd basename dirname realpath setenv unsetenv regcomp lchown],
[], [AC_MSG_ERROR([function required by rpm])])
-dnl XXX Glob *is* broken on linux with libc5, solaris and possibly aix when
-dnl %files gets something like
-dnl /usr/*/locale/*/LC_MESSAGES/*.mo
-dnl (Note: more than one asterisk in glob pattern.)
-dnl
-dnl XXX Glob is "fixed" in glibc-2.3.3-61, but the cost is that
-dnl dangling symlinks are no longer globbed. Always use the internal glob.
-AC_DEFINE(USE_GNU_GLOB, 1, [Use the included glob.c?])
-AC_LIBOBJ(glob)
AC_LIBOBJ(fnmatch)
dnl check if python is requested