summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2008-04-03 09:59:46 +0300
committerPanu Matilainen <pmatilai@redhat.com>2008-04-03 12:59:13 +0300
commitbabade159482170bbcb710970277a90e994695fe (patch)
tree25c5ac38e46aadf3d02e9728ed858742460d24d5 /configure.ac
parent85571b25e97eed423a9931377aa40bb3fc42fb76 (diff)
downloadlibrpm-tizen-babade159482170bbcb710970277a90e994695fe.tar.gz
librpm-tizen-babade159482170bbcb710970277a90e994695fe.tar.bz2
librpm-tizen-babade159482170bbcb710970277a90e994695fe.zip
Enable stack protector by default if gcc supports it
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bcd8f80ad..46ac4addb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,7 +29,7 @@ if test "$GCC" = yes; then
CFLAGS="$CFLAGS -fPIC -DPIC -D_REENTRANT -Wall -Wpointer-arith -Wmissing-prototypes -Wno-char-subscripts"
# XXX disabled for now due to noise from NSPR headers
# CFLAGS="$CFLAGS -Wstrict-prototypes"
- cflags_to_try="-fno-strict-aliasing"
+ cflags_to_try="-fno-strict-aliasing -fstack-protector"
AC_MSG_CHECKING([supported compiler flags])
old_cflags=$CFLAGS
echo