summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2012-11-29 12:35:13 +0200
committerPanu Matilainen <pmatilai@redhat.com>2012-11-30 09:44:38 +0200
commit8d709ae8c5197e706f2520bc45d9e2f4721e6b86 (patch)
tree1058aa10047e2e96d69745236ee5a8e3a37cacfb /configure.ac
parent2d30d264e52d9fae66628e33ae05d18f13d86705 (diff)
downloadlibrpm-tizen-8d709ae8c5197e706f2520bc45d9e2f4721e6b86.tar.gz
librpm-tizen-8d709ae8c5197e706f2520bc45d9e2f4721e6b86.tar.bz2
librpm-tizen-8d709ae8c5197e706f2520bc45d9e2f4721e6b86.zip
Get rid of long since deprecated VFY_VerifyDigest() uses
- VFY_VerifyDigest() has been deprecated since NSS >= 3.12 and for a good reason too: with VFY_VerifyDigest() caller needs to painfully enumerate every possible supported enc + hash combination, only for NSS to revert the process. Use the saner VFY_VerifyDigestDirect() interface instead and test for its presence in configure. - This means we now require NSS >= 3.12 but as that's already 4.5 years old and included in ancient beasts like RHEL-4, this doesn't seem exactly unreasonable requirement. And then there's always beecrypt... (cherry picked from commit 9b995a7674adba08248fac79ae8b23ecbecc13de)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1578cdbbe..a10a02839 100644
--- a/configure.ac
+++ b/configure.ac
@@ -283,14 +283,14 @@ if test "$with_beecrypt" != yes ; then
AC_CHECK_HEADERS([nspr.h nss.h sechash.h], [], [
AC_MSG_ERROR([missing required NSPR / NSS header])
])
-AC_CHECK_LIB(nss3, NSS_NoDB_Init, [
+AC_CHECK_LIB(nss3, VFY_VerifyDigestDirect, [
WITH_NSS_LIB=-lnss3
AC_CHECK_LIB(nss3, NSS_InitContext, [
AC_DEFINE(HAVE_NSS_INITCONTEXT, 1, [Define to 1 if NSS has NSS_InitContext])
AC_SUBST(HAVE_NSS_INITCONTEXT, [1])
])
], [
- AC_MSG_ERROR([missing required NSS library 'nss3'])
+ AC_MSG_ERROR([required NSS library 'nss3' missing or too old])
])
fi
AC_SUBST(WITH_NSS_INCLUDE)