summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2010-09-03 16:09:47 +0300
committerPanu Matilainen <pmatilai@redhat.com>2010-09-03 16:16:57 +0300
commitdfbaa77152ccf98524c4f27afe85d32e6f690522 (patch)
tree3e28230126ed40fbb063edce847a668a12eb6521 /Makefile.am
parentb195048bbb27a1aae4aa3938c3b1f79e0a26ae88 (diff)
downloadlibrpm-tizen-dfbaa77152ccf98524c4f27afe85d32e6f690522.tar.gz
librpm-tizen-dfbaa77152ccf98524c4f27afe85d32e6f690522.tar.bz2
librpm-tizen-dfbaa77152ccf98524c4f27afe85d32e6f690522.zip
Add a brand new rpmkeys utility for keyring operations
- Keyring operations (adding/viewing/removing keys and verifying packages against a given keyring) are different from main rpm operations in that they only need access to the rpm keyring, and no write access anywhere else in the system. At the moment the rpm keyring happens to be the rpmdb but that's just an implementation detail that is likely to change sooner or later. Besides paving way to separating the rpm keyring from the rpmdb, splitting this to a small, separate utility allows limiting its required access from SELinux POV etc. - For now, this only implements what's already in rpm: --import and --checksig, remaining operations like listing and manipulating keyring contents is left as an exercise for another day...
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2077f00ad..1398e0f38 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,7 +78,7 @@ pkginclude_HEADERS += build/rpmspec.h
rpmbindir = `echo $(bindir) | $(SED) -e s,usr/bin,bin,`
rpmbin_PROGRAMS = rpm
-bin_PROGRAMS = rpm2cpio rpmbuild rpmsign
+bin_PROGRAMS = rpm2cpio rpmbuild rpmkeys rpmsign
rpmlibexec_PROGRAMS =
rpmconfig_SCRIPTS = find-provides find-requires mkinstalldirs \
@@ -98,6 +98,12 @@ rpm_LDADD = libcliutils.la
rpm_LDADD += build/librpmbuild.la lib/librpm.la rpmio/librpmio.la
rpm_LDADD += @WITH_NSS_LIB@ @WITH_POPT_LIB@ @WITH_ZLIB_LIB@
+rpmkeys_SOURCES = rpmkeys.c debug.h system.h
+rpmkeys_CPPFLAGS = $(AM_CPPFLAGS)
+rpmkeys_LDADD = libcliutils.la
+rpmkeys_LDADD += lib/librpm.la rpmio/librpmio.la
+rpmkeys_LDADD += @WITH_NSS_LIB@ @WITH_POPT_LIB@ @WITH_ZLIB_LIB@
+
rpmsign_SOURCES = rpmsign.c debug.h system.h
rpmsign_CPPFLAGS = $(AM_CPPFLAGS)
rpmsign_LDADD = libcliutils.la