summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2011-03-25 14:39:36 +0200
committerPanu Matilainen <pmatilai@redhat.com>2011-03-25 14:48:49 +0200
commit2a8d03669732f68f02fa7b21ec87ee3f65d11e5b (patch)
treeb3dbe6c68bb0b1ee7290fe17a37dcc51a49acb2c /Makefile.am
parent07ec480c180e4005a629242b8f9f8ab640e3e950 (diff)
downloadlibrpm-tizen-2a8d03669732f68f02fa7b21ec87ee3f65d11e5b.tar.gz
librpm-tizen-2a8d03669732f68f02fa7b21ec87ee3f65d11e5b.tar.bz2
librpm-tizen-2a8d03669732f68f02fa7b21ec87ee3f65d11e5b.zip
Push platform config out of main rpm macros file
- canon arch & color stuff is now calculated per each known arch in installplatform, and just a single place where arch name mangling is done
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 053236d77..a93d66b7b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -228,7 +228,10 @@ install-exec-hook:
@LN_S@ ../../bin/rpm $(DESTDIR)$(bindir)/rpmverify
install-data-local:
- DESTDIR="$(DESTDIR)" pkglibdir="$(rpmconfigdir)" $(SHELL) $(top_srcdir)/installplatform rpmrc macros platform
+ DESTDIR="$(DESTDIR)" pkglibdir="$(rpmconfigdir)" \
+ $(SHELL) $(top_srcdir)/installplatform \
+ rpmrc platform \
+ $(RPMCANONVENDOR) $(RPMCANONOS) $(RPMCANONGNU)
@$(MKDIR_P) $(DESTDIR)$(localstatedir)/tmp
# XXX to appease distcheck we need to remove "stuff" here...