diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -1,4 +1,4 @@ -#!/usr/bin/python +#!/usr/bin/python3 # vim: set fileencoding=utf-8 : # Copyright (C) 2006-2011 Guido Günther <agx@sigxcpu.org> # @@ -29,7 +29,7 @@ def fetch_version(): try: popen = subprocess.Popen('dpkg-parsechangelog', stdout=subprocess.PIPE) out, ret = popen.communicate() - for line in out.split('\n'): + for line in out.decode().split('\n'): if line.startswith('Version:'): version = line.split(' ')[1].strip() break @@ -49,7 +49,7 @@ def readme(): setup(name = "gbp", version = fetch_version(), - author = u'Guido Günther', + author = 'Guido Günther', author_email = 'agx@sigxcpu.org', url = 'https://honk.sigxcpu.org/piki/projects/git-buildpackage/', description = 'Suite to help with Debian packages in Git repositories', |