summaryrefslogtreecommitdiff
path: root/tests/test_rpm_data/specs/gbp-test-updates.spec
diff options
context:
space:
mode:
authorSoonKyu Park <sk7.park@samsung.com>2016-07-25 20:53:31 +0900
committerSoonKyu Park <sk7.park@samsung.com>2016-07-25 20:53:31 +0900
commit77958da8a32b9f39356684e05842579a74c4a46f (patch)
treeb4babcbfce543e21abfa2fb09049d546cb049481 /tests/test_rpm_data/specs/gbp-test-updates.spec
parent31a52b28de3581b2859fd020a0d221d54d8e57f7 (diff)
parent06e10c8b1f4f355e884d52a61b7762e733975d55 (diff)
downloadgit-buildpackage-77958da8a32b9f39356684e05842579a74c4a46f.tar.gz
git-buildpackage-77958da8a32b9f39356684e05842579a74c4a46f.tar.bz2
git-buildpackage-77958da8a32b9f39356684e05842579a74c4a46f.zip
Handle conflicts from git merge masterdevel_psk_20160727
Change-Id: I9dfa02fb546a04f97aade855615ad2843790a2c1
Diffstat (limited to 'tests/test_rpm_data/specs/gbp-test-updates.spec')
-rw-r--r--tests/test_rpm_data/specs/gbp-test-updates.spec49
1 files changed, 49 insertions, 0 deletions
diff --git a/tests/test_rpm_data/specs/gbp-test-updates.spec b/tests/test_rpm_data/specs/gbp-test-updates.spec
new file mode 100644
index 00000000..dc8ffbf9
--- /dev/null
+++ b/tests/test_rpm_data/specs/gbp-test-updates.spec
@@ -0,0 +1,49 @@
+#
+# Spec file for testing deleting/adding/updating tags and macros
+#
+
+# Gbp-Undefined-Tag: foobar
+
+# Test that we accept different cases
+Name: my_name
+Version: 0
+Release: 1
+Summary: my_summary
+License: my_license
+Distribution: my_distribution
+Vendor: my_vendor
+Group: my_group
+Packager: my_packager
+Url: my_url
+Vcs: my_vcs
+Source: my_source
+Patch: my_%patch_fn_base
+Patch0: my_%{patch_fn_base}0
+Nosource: 0
+Nopatch: 0
+BuildRoot: my_buildroot
+Provides: my_provides
+Requires: my_requires
+Conflicts: my_conflicts
+Obsoletes: my_obsoletes
+BuildConflicts: my_buildconflicts
+BuildRequires: my_buildrequires
+AutoReqProv: No
+AutoReq: No
+AutoProv: No
+DistTag: my_disttag
+BugUrl: my_bugurl
+Collections: my_collections
+
+%description
+Package for testing GBP.
+
+%prep
+%setup -n my_prefix
+
+%patch -b my_patch
+%patch -P0 -b my_patch0
+
+%build
+
+%install