diff options
author | Guido Günther <agx@sigxcpu.org> | 2011-11-02 10:35:58 +0100 |
---|---|---|
committer | Guido Günther <agx@sigxcpu.org> | 2011-11-06 16:02:51 +0100 |
commit | b484a97e09f4fc94680b748cab81bb6386c44679 (patch) | |
tree | e4264cecffa1488337cba4a4e942e7cb71b54a42 /setup.py | |
parent | 61f044ba09d8076b49d4303d7ac1d11ffc2175f4 (diff) | |
download | git-buildpackage-b484a97e09f4fc94680b748cab81bb6386c44679.tar.gz git-buildpackage-b484a97e09f4fc94680b748cab81bb6386c44679.tar.bz2 git-buildpackage-b484a97e09f4fc94680b748cab81bb6386c44679.zip |
Use setuptools to run the tests
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 10 |
1 files changed, 6 insertions, 4 deletions
@@ -1,5 +1,6 @@ #!/usr/bin/python -# Copyright (C) 2006-2011 Guido Guenther <agx@sigxcpu.org> +# vim: set fileencoding=utf-8 : +# Copyright (C) 2006-2011 Guido Günther <agx@sigxcpu.org> # # This program is free software; you can redistribute it and/or modify # it under the terms of the GNU General Public License as published by @@ -16,10 +17,10 @@ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA # END OF COPYRIGHT # -from distutils.core import setup +from setuptools import setup -setup(name = "git_build_package", - author = 'Guido Guenther', +setup(name = "gbp", + author = u'Guido Günther', author_email = 'agx@sigxcpu.org', scripts = [ 'bin/git-buildpackage', 'bin/git-import-dsc', @@ -33,4 +34,5 @@ setup(name = "git_build_package", 'bin/git-pbuilder'], packages = [ 'gbp', 'gbp.scripts' ], data_files = [("/etc/git-buildpackage/", ["gbp.conf"]),], + setup_requires=['nose>=1.0', 'coverage>=3.4'], ) |