diff options
author | Guido Günther <agx@sigxcpu.org> | 2014-10-17 18:24:01 +0200 |
---|---|---|
committer | Guido Günther <agx@sigxcpu.org> | 2014-10-17 18:41:05 +0200 |
commit | e08d64d9d01aff2e398906788150b9fd3029e571 (patch) | |
tree | 0c41a455392fcba0e64f08445465abf7dbc21724 /setup.py | |
parent | 22a698736486f1097e034ae9c5c432f39fdaa239 (diff) | |
download | git-buildpackage-e08d64d9d01aff2e398906788150b9fd3029e571.tar.gz git-buildpackage-e08d64d9d01aff2e398906788150b9fd3029e571.tar.bz2 git-buildpackage-e08d64d9d01aff2e398906788150b9fd3029e571.zip |
Complete setup.py for pypi
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 15 |
1 files changed, 15 insertions, 0 deletions
@@ -42,10 +42,25 @@ def fetch_version(): return version + +def readme(): + with open('README') as file: + return file.read() + setup(name = "gbp", version = fetch_version(), author = u'Guido Günther', author_email = 'agx@sigxcpu.org', + url = 'https://honk.sigxcpu.org/piki/projects/git-buildpackage/', + description = 'Suite to help with Debian packages in Git repositories', + license = 'GPLv2+', + long_description = readme(), + classifiers = [ + 'Environment :: Console', + 'Programming Language :: Python :: 2', + 'Topic :: Software Development :: Version Control :: Git', + 'Operating System :: POSIX :: Linux', + ], scripts = [ 'bin/git-buildpackage', 'bin/git-import-dsc', 'bin/git-import-orig', |