diff options
author | Guido Günther <agx@sigxcpu.org> | 2009-08-15 18:58:18 +0200 |
---|---|---|
committer | Guido Günther <agx@sigxcpu.org> | 2009-08-15 19:14:25 +0200 |
commit | 080b1eb0f59091bf5a3ebd180b68839706615fb5 (patch) | |
tree | 8f34e96b5fb7cfde8e0362a0df1b6b24a723f7eb /git-dch | |
parent | d6dae624d35719556257043ce2212cd40511848f (diff) | |
download | git-buildpackage-080b1eb0f59091bf5a3ebd180b68839706615fb5.tar.gz git-buildpackage-080b1eb0f59091bf5a3ebd180b68839706615fb5.tar.bz2 git-buildpackage-080b1eb0f59091bf5a3ebd180b68839706615fb5.zip |
make parameters for GitRepository.commits() optional
Diffstat (limited to 'git-dch')
-rwxr-xr-x | git-dch | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -251,6 +251,7 @@ def guess_snapshot_commit(cp): return sr.group('commit') + def main(argv): ret = 0 changelog = 'debian/changelog' @@ -335,7 +336,7 @@ def main(argv): if args: print "Only looking for changes on '%s'" % " ".join(args) - commits = repo.commits(since, until, " ".join(args), options.git_log.split(" ")) + commits = repo.commits(since=since, until=until, paths=" ".join(args), options=options.git_log.split(" ")) # add a new changelog section if: if cp['Distribution'] != "UNRELEASED" and not found_snapshot_header and commits: |