summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2006-12-22 15:11:58 +0100
committerGuido Guenther <agx@bogon.sigxcpu.org>2006-12-22 15:11:58 +0100
commit2f3c8a58d8b7d75045244413b3a3db507c8d5b82 (patch)
tree2c1db18fecead41bc1ca5b29d2c6577bc18bfff9 /debian/rules
parent69e776a291872d0b20f5a55527b68ea09996b920 (diff)
downloadgit-buildpackage-2f3c8a58d8b7d75045244413b3a3db507c8d5b82.tar.gz
git-buildpackage-2f3c8a58d8b7d75045244413b3a3db507c8d5b82.tar.bz2
git-buildpackage-2f3c8a58d8b7d75045244413b3a3db507c8d5b82.zip
add some more documentation
some of the layout is based on what darcs-buildpackage does
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 8 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 6ea935f3..4cea6597 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,17 +9,23 @@ include /usr/share/cdbs/1/class/python-distutils.mk
COMMANDS=git-buildpackage git-import-dsc git-import-orig
MANPAGES=$(patsubst %,docs/%.1,$(COMMANDS))
+MANUAL=docs/manual-html
PYCHECKS=$(patsubst %,%.py,$(COMMANDS))
PYCHECK_LEVEL=Error
docs/%.1: docs/man.%.sgml
docbook-to-man $< > $@
+$(MANUAL): docs/manual.sgml docs/chapters/*.sgml docs/manpages/*.sgml
+ docbook-2-html -s gtk $<
+
%.py: %
ln -s $< $@
PYTHONPATH=. pychecker -e $(PYCHECK_LEVEL) -q $<
-build/git-buildpackage:: $(MANPAGES) $(PYCHECKS)
+build/git-buildpackage:: $(MANPAGES) $(MANUAL) $(PYCHECKS)
clean::
- -rm docs/*.1 git-*.py
+ -rm docs/*.1 git-*.py
+ -rm -rf docs/manual-html/
+