summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
authorEd Bartosh <eduard.bartosh@intel.com>2012-05-24 16:16:12 +0300
committerMarkus Lehtonen <markus.lehtonen@linux.intel.com>2014-06-05 14:20:05 +0300
commitbb0241a66d6f2d46bf990bec48fc7728df2ef8b4 (patch)
treedb048e35722a4960142a40ee1e003e8c07554e58 /debian/control
parent9f1a9e6a421f7c1d7543764b7e43d254df5b6205 (diff)
downloadgit-buildpackage-bb0241a66d6f2d46bf990bec48fc7728df2ef8b4.tar.gz
git-buildpackage-bb0241a66d6f2d46bf990bec48fc7728df2ef8b4.tar.bz2
git-buildpackage-bb0241a66d6f2d46bf990bec48fc7728df2ef8b4.zip
debian packaging: split Debian package into subpackages
Split Debian package into three packages, following the introduction of RPM tools. Now the Debian packaging resembles the default RPM packaging: - git-buildpackage-common contains the common code for Deb and RPM tools - git-buildpackage contains the Debian-specific modules/tools - git-buildpackage-rpm contains the RPM-specific modules/tools Signed-off-by: Zhang Qiang <qiang.z.zhang@intel.com> Signed-off-by: Ed Bartosh <eduard.bartosh@intel.com> Signed-off-by: Markus Lehtonen <markus.lehtonen@linux.intel.com>
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control39
1 files changed, 32 insertions, 7 deletions
diff --git a/debian/control b/debian/control
index c29d6ebc..7964b5c3 100644
--- a/debian/control
+++ b/debian/control
@@ -32,20 +32,28 @@ Vcs-Browser: https://honk.sigxcpu.org/gitweb/?p=git-buildpackage.git
Homepage: https://honk.sigxcpu.org/piki/projects/git-buildpackage/
X-Python-Version: >= 2.6
-Package: git-buildpackage
+
+Package: git-buildpackage-common
Architecture: all
Depends: ${python:Depends},
${shlibs:Depends},
${misc:Depends},
- devscripts (>= 2.13.5~),
git (>= 1:1.7.9.1-1~),
man-db,
- python-pkg-resources,
-# For rpm
- python-rpm,
- rpm2cpio
-Recommends: pristine-tar (>= 0.5), cowbuilder
+ python-pkg-resources
+Recommends: pristine-tar (>= 0.5)
Suggests: python-notify, unzip
+Description: Suite to help with packaging in Git repositories
+ This package contains the common API and scripts for Debian and rpm packaging
+
+Package: git-buildpackage
+Architecture: all
+Depends: ${python:Depends},
+ ${shlibs:Depends},
+ ${misc:Depends},
+ devscripts (>= 2.13.5~),
+ git-buildpackage-common (= ${binary:Version})
+Recommends: cowbuilder
Description: Suite to help with Debian packages in Git repositories
This package contains the following tools:
* gbp import-{dsc,dscs}: import existing Debian source packages into a git
@@ -57,3 +65,20 @@ Description: Suite to help with Debian packages in Git repositories
* gbp {pull,clone}: clone and pull from remote repos
* gbp pq: manage debian/patches easily
* gbp create-remote-repo: create remote repositories
+
+Package: git-buildpackage-rpm
+Architecture: all
+Depends: ${python:Depends},
+ ${shlibs:Depends},
+ ${misc:Depends},
+ python-rpm,
+ rpm2cpio,
+ git-buildpackage-common (= ${binary:Version})
+Description: Suite to help with rpm packages in Git repositories
+ This package contains the following tools:
+ * git-import-srpm: import existing rpm source packages into a git
+ repository
+ * git-import-orig-rpm: import a new upstream version into the git repository
+ * git-buildpackage-rpm: build a package out of a git repository, check for local
+ modifications and tag appropriately
+ * gbp-pq-rpm: manage separate development and packaging branches