diff options
author | Guido Günther <agx@sigxcpu.org> | 2009-12-23 23:54:40 +0100 |
---|---|---|
committer | Guido Günther <agx@sigxcpu.org> | 2009-12-23 23:55:22 +0100 |
commit | cf45595d9bea1ec95f25c33ce5b63d24235ad7f5 (patch) | |
tree | c2db263e0690bee43bb3873a1e4ecf6bef24b9cb | |
parent | d4366123fef2903f2ce4367edae10a1895a5662b (diff) | |
download | git-buildpackage-cf45595d9bea1ec95f25c33ce5b63d24235ad7f5.tar.gz git-buildpackage-cf45595d9bea1ec95f25c33ce5b63d24235ad7f5.tar.bz2 git-buildpackage-cf45595d9bea1ec95f25c33ce5b63d24235ad7f5.zip |
Don't hardcode pristine-tar branch
-rwxr-xr-x | gbp-clone | 6 | ||||
-rwxr-xr-x | gbp-pull | 8 |
2 files changed, 7 insertions, 7 deletions
@@ -24,13 +24,13 @@ import sys import os, os.path from gbp.config import (GbpOptionParser, GbpOptionGroup) from gbp.git import (GitRepositoryError, GitRepository) -from gbp.command_wrappers import (GitClone, Command, CommandExecFailed, GitBranch) +from gbp.command_wrappers import (GitClone, Command, CommandExecFailed, + GitBranch, PristineTar) from gbp.errors import GbpError def main(argv): retval = 0 - pristine_tar_branch = 'pristine-tar' parser = GbpOptionParser(command=os.path.basename(argv[0]), prefix='', usage='%prog [options] repository - clone a remote repository') @@ -73,7 +73,7 @@ def main(argv): repo = GitRepository(os.path.curdir) if options.pristine_tar: - branches += [ pristine_tar_branch ] + branches += [ PristineTar.branch ] for branch in branches: remote = 'origin/%s' % branch @@ -22,7 +22,8 @@ import sys import os, os.path -from gbp.command_wrappers import (GitFetch, GitMerge, Command, CommandExecFailed) +from gbp.command_wrappers import (GitFetch, GitMerge, Command, + CommandExecFailed, PristineTar) from gbp.config import (GbpOptionParser, GbpOptionGroup) from gbp.errors import GbpError from gbp.git import (GitRepositoryError, GitRepository) @@ -46,7 +47,6 @@ def fast_forward_branch(branch, repo, options): def main(argv): changelog = 'debian/changelog' retval = 0 - pristine_tar = 'pristine-tar' parser = GbpOptionParser(command=os.path.basename(argv[0]), prefix='', usage='%prog [options] - safely update a repository from remote') @@ -81,8 +81,8 @@ def main(argv): if repo.has_branch(branch): branches += [ branch ] - if repo.has_branch(pristine_tar) and options.pristine_tar: - branches += [ pristine_tar ] + if repo.has_branch(PristineTar.branch) and options.pristine_tar: + branches += [ PristineTar.branch ] (ret, out) = repo.is_clean() if not ret: |