summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJinkun Jang <jinkun.jang@samsung.com>2013-03-12 15:18:04 +0900
committerJinkun Jang <jinkun.jang@samsung.com>2013-03-12 15:18:04 +0900
commit9342bc8215bde3d8f936593900d429ec0184621e (patch)
tree38f87f56c4c5ea354200540778f20dd7fa10f3ba /src/Makefile.am
parentbfd95772edacf96422314ea6b6ad1f17054e4a85 (diff)
downloadtar-9342bc8215bde3d8f936593900d429ec0184621e.tar.gz
tar-9342bc8215bde3d8f936593900d429ec0184621e.tar.bz2
tar-9342bc8215bde3d8f936593900d429ec0184621e.zip
Tizen 2.1 base
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..61f6cbd
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,46 @@
+# Makefile for GNU tar sources.
+
+# Copyright (C) 1994, 1995, 1996, 1997, 1999, 2000, 2001, 2003, 2006
+# Free Software Foundation, Inc.
+
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+## 02110-1301, USA.
+
+bin_PROGRAMS = tar
+
+noinst_HEADERS = arith.h common.h tar.h
+tar_SOURCES = \
+ buffer.c\
+ compare.c\
+ create.c\
+ delete.c\
+ extract.c\
+ xheader.c\
+ incremen.c\
+ list.c\
+ misc.c\
+ names.c\
+ sparse.c\
+ system.c\
+ tar.c\
+ transform.c\
+ update.c\
+ utf8.c
+
+INCLUDES = -I$(top_srcdir)/lib -I../ -I../lib
+
+LDADD = ../lib/libtar.a $(LIBINTL) $(LIBICONV)
+
+tar_LDADD = $(LDADD) $(LIB_CLOCK_GETTIME)