summaryrefslogtreecommitdiff
path: root/packaging/sharutils.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/sharutils.spec')
-rwxr-xr-x[-rw-r--r--]packaging/sharutils.spec60
1 files changed, 29 insertions, 31 deletions
diff --git a/packaging/sharutils.spec b/packaging/sharutils.spec
index 7c33657..28a23b0 100644..100755
--- a/packaging/sharutils.spec
+++ b/packaging/sharutils.spec
@@ -1,14 +1,14 @@
-#
+#
# Do not Edit! Generated by:
# spectacle version 0.13~pre
-#
+#
# >> macros
# << macros
Name: sharutils
Summary: The GNU shar utilities for packaging and unpackaging shell archives
Version: 4.7
-Release: 2
+Release: 4
Group: Applications/Archiving
License: GPL
URL: http://www.gnu.org/software/sharutils/
@@ -34,52 +34,50 @@ shar files.
Install sharutils if you send binary files through e-mail.
-
-
%prep
%setup -q -n %{name}-%{version}
-# >> setup
-# << setup
%build
cp %{SOURCE1001} .
-# >> build pre
-# << build pre
-%configure --disable-static
+%configure \
+ --disable-static \
+ --disable-nls \
+ --disable-man
# Call make instruction with smp support
make %{?jobs:-j%jobs}
-# >> build post
-# << build post
%install
rm -rf %{buildroot}
-# >> install pre
-# << install pre
%make_install
-# >> install post
rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
chmod 644 AUTHORS ChangeLog COPYING NEWS README THANKS TODO
-# << install post
-%find_lang %{name}
-
-%clean
-rm -rf %{buildroot}
-
-
+mkdir -p $RPM_BUILD_ROOT%{_datadir}/license
+for keyword in LICENSE COPYING COPYRIGHT;
+do
+ for file in `find %{_builddir} -name $keyword`;
+ do
+ cat $file >> $RPM_BUILD_ROOT%{_datadir}/license/%{name};
+ echo "";
+ done;
+done
+%remove_docs
+%clean
+rm -rf %{buildroot}
-%files -f %{name}.lang
+%files
%manifest sharutils.manifest
%defattr(-,root,root,-)
-# >> files
-%doc AUTHORS COPYING NEWS README THANKS TODO
-%{_bindir}/*
-%doc %{_infodir}/*info*
-%doc %{_mandir}/*/*
-# << files
-
-
+%{_datadir}/license/%{name}
+%exclude /usr/bin/compress-dummy
+%exclude /usr/bin/mail-files
+%exclude /usr/bin/mailshar
+%exclude /usr/bin/remsync
+%exclude /usr/bin/shar
+%exclude /usr/bin/unshar
+/usr/bin/uudecode
+/usr/bin/uuencode