summaryrefslogtreecommitdiff
path: root/luaext/Makefile.am
diff options
context:
space:
mode:
authorJinkun Jang <jinkun.jang@samsung.com>2013-03-12 15:17:20 +0900
committerJinkun Jang <jinkun.jang@samsung.com>2013-03-12 15:17:20 +0900
commit7df2385c2f6c93f96e00bc87f2086066cae89ecc (patch)
tree79d5c20a494622eb084de831a2a51530cd421e33 /luaext/Makefile.am
parentb7a3bffb8e0341b7e4ef69def268bca3a7f279ff (diff)
downloadrpm-submit/tizen_2.2/20130710.072219.tar.gz
rpm-submit/tizen_2.2/20130710.072219.tar.bz2
rpm-submit/tizen_2.2/20130710.072219.zip
Diffstat (limited to 'luaext/Makefile.am')
-rw-r--r--luaext/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/luaext/Makefile.am b/luaext/Makefile.am
new file mode 100644
index 0000000..65e1555
--- /dev/null
+++ b/luaext/Makefile.am
@@ -0,0 +1,19 @@
+noinst_LTLIBRARIES = libluaext.la
+
+EXTRA_DIST = \
+ modemuncher.c \
+ userconfig.c \
+ linit.lua
+
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_builddir)/include -I.
+
+libluaext_la_CPPFLAGS = $(AM_CPPFLAGS) -DWITH_POSIX @LUA_CFLAGS@
+libluaext_la_LIBADD = @LUA_LIBS@
+libluaext_la_SOURCES = \
+ lposix.h \
+ lposix.c \
+ lrexlib.h \
+ lrexlib.c
+
+linit.lch: linit.lua
+ bin2c linit.lua > linit.lch