summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..c7c6034
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,23 @@
+# This -*- perl -*- script makes the Makefile
+
+BEGIN { require 5.004 }
+
+use strict;
+use warnings;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'TimeDate',
+ AUTHOR => 'Graham Barr <gbarr@pobox.com>',
+ VERSION => '1.20',
+ (eval { ExtUtils::MakeMaker->VERSION(6.21) } ? (LICENSE => 'perl') : ()),
+ ( eval { ExtUtils::MakeMaker->VERSION(6.46) } ? (
+ META_MERGE => {
+ resources => { ##
+ repository => 'http://github.com/gbarr/perl-TimeDate',
+ },
+ }
+ )
+ : ()
+ ),
+);