summaryrefslogtreecommitdiff
path: root/packaging/fakeroot.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/fakeroot.spec')
-rw-r--r--packaging/fakeroot.spec35
1 files changed, 29 insertions, 6 deletions
diff --git a/packaging/fakeroot.spec b/packaging/fakeroot.spec
index 0d3953b..4a09340 100644
--- a/packaging/fakeroot.spec
+++ b/packaging/fakeroot.spec
@@ -1,3 +1,4 @@
+
Name: fakeroot
Summary: Gives a fake root environment
Version: 1.12.4
@@ -5,15 +6,15 @@ Release: 19
Group: Development/Tools
License: GPL+
URL: http://fakeroot.alioth.debian.org/
-Source0: http://ftp.debian.org/debian/pool/main/f/fakeroot/%{name}-%{version}.tar.gz
-Source1001: packaging/fakeroot.manifest
+Source0: http://ftp.debian.org/debian/pool/main/f/fakeroot/%{name}_%{version}.tar.gz
Requires: util-linux
Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
BuildRequires: gcc-c++
-BuildRequires: util-linux-ng
+BuildRequires: util-linux
BuildRequires: sharutils
+BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
fakeroot runs a command in an environment wherein it appears to have
@@ -26,14 +27,18 @@ had the user really been root.
%prep
-%setup -q
+%setup -q -n %{name}-%{version}
%build
-cp %{SOURCE1001} .
for file in ./doc/*/*.1; do
iconv -f latin1 -t utf8 < $file > $file.new
mv -f $file.new $file
done
+
+
+
+
+
# all build scripts in origin specfile as the following:
for type in sysv tcp; do
mkdir obj-$type
@@ -54,6 +59,11 @@ cd ..
done
%install
+rm -rf %{buildroot}
+# Please write install script under ">> install post"
+
+# all install scripts in origin specfile as the following:
+rm -rf %{buildroot}
for type in sysv tcp; do
make -C obj-$type install libdir=%{_libdir}/libfakeroot DESTDIR=%{buildroot}
chmod 644 %{buildroot}%{_libdir}/libfakeroot/libfakeroot-0.so
@@ -67,6 +77,18 @@ ln -s faked-tcp %{buildroot}%{_bindir}/faked
ln -s fakeroot-tcp %{buildroot}%{_bindir}/fakeroot
ln -s libfakeroot-tcp.so %{buildroot}%{_libdir}/libfakeroot/libfakeroot-0.so
+%check
+for type in sysv tcp; do
+ echo 'Bypassing check '$type
+# make -C obj-$type check
+done
+
+
+
+%clean
+rm -rf %{buildroot}
+
+
%post -p /sbin/ldconfig
@@ -74,7 +96,8 @@ ln -s libfakeroot-tcp.so %{buildroot}%{_libdir}/libfakeroot/libfakeroot-0.so
%files
-%manifest fakeroot.manifest
+%defattr(-,root,root,-)
+%doc AUTHORS BUGS COPYING DEBUG debian/changelog doc/README.saving
%{_bindir}/faked-*
%{_bindir}/faked
%{_bindir}/fakeroot-*