summaryrefslogtreecommitdiff
path: root/packaging/ed.spec
diff options
context:
space:
mode:
authorJeongho Hwang <jbera.hwang@samsung.com>2012-09-19 14:52:42 +0900
committerJeongho Hwang <jbera.hwang@samsung.com>2012-09-19 14:52:42 +0900
commit6946646754d606c72ece70c585e52b7b13495994 (patch)
tree8709ad87750384e4d727d2ef9c6783ec32ade7b5 /packaging/ed.spec
parent3366690e172a06e0b95718b8a5436004ce6116f8 (diff)
downloaded-tizen_2.3.1.tar.gz
ed-tizen_2.3.1.tar.bz2
ed-tizen_2.3.1.zip
Signed-off-by: Jeongho Hwang <jbera.hwang@samsung.com>
Diffstat (limited to 'packaging/ed.spec')
-rw-r--r--packaging/ed.spec59
1 files changed, 59 insertions, 0 deletions
diff --git a/packaging/ed.spec b/packaging/ed.spec
new file mode 100644
index 0000000..5094ecf
--- /dev/null
+++ b/packaging/ed.spec
@@ -0,0 +1,59 @@
+#specfile originally created for Fedora, modified for Moblin Linux
+Summary: The GNU line editor
+Name: ed
+Version: 1.4
+Release: 1
+License: GPLv3+
+Group: Applications/Text
+Source: ftp://ftp.gnu.org/gnu/ed/%{name}-%{version}.tar.gz
+URL: http://www.gnu.org/software/ed/
+Requires(post): /sbin/install-info
+Requires(preun): /sbin/install-info
+Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+%description
+Ed is a line-oriented text editor, used to create, display, and modify
+text files (both interactively and via shell scripts). For most
+purposes, ed has been replaced in normal usage by full-screen editors
+(emacs and vi, for example).
+
+Ed was the original UNIX editor, and may be used by some programs. In
+general, however, you probably don't need to install it and you probably
+won't use it.
+
+%prep
+%setup -q
+rm -f stamp-h.in
+
+%build
+%configure --exec-prefix=/
+make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
+make install DESTDIR=$RPM_BUILD_ROOT \
+ bindir=/bin mandir=%{_mandir}/man1
+
+rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
+gzip -9qnf $RPM_BUILD_ROOT%{_infodir}/*
+install -p -m0644 doc/ed.1 $RPM_BUILD_ROOT%{_mandir}/man1
+
+%post
+[ -e %{_infodir}/ed.info.gz ] && /sbin/install-info %{_infodir}/ed.info.gz %{_infodir}/dir --entry="* ed: (ed). The GNU Line Editor." || :
+
+%preun
+if [ $1 = 0 ] ; then
+ [ -e %{_infodir}/ed.info.gz ] && /sbin/install-info --delete %{_infodir}/ed.info.gz %{_infodir}/dir --entry="* ed: (ed). The GNU Line Editor." || :
+fi
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root)
+%doc ChangeLog NEWS README TODO AUTHORS COPYING
+/bin/*
+%doc %{_infodir}/ed.info.gz
+%doc %{_mandir}/*/*
+