summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 00000000..b59e945a
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,30 @@
+# Makefile.am for hello/man.
+#
+# Copyright 2004, 2005, 2006, 2007, 2008, 2009, 2010
+# Free Software Foundation, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+man_MANS = hello.1
+EXTRA_DIST = $(man_MANS)
+MAINTAINERCLEANFILES = $(man_MANS)
+
+# The man pages depend on the --help strings and the version number.
+common_mandeps = $(top_srcdir)/configure.ac
+
+# Depend on the source, not the binary; we don't need to regenerate the
+# binary when any source file changes, only the main one.
+# Use -o so that the `missing' program can infer the output file.
+hello.1: $(top_srcdir)/src/hello.c $(common_mandeps)
+ $(HELP2MAN) --name="friendly greeting program" ../src/hello -o $@