summaryrefslogtreecommitdiff
path: root/meta-qt5
diff options
context:
space:
mode:
authorAbhijit Potnis <abhijit_potnis@mentor.com>2013-08-20 18:19:14 +0530
committerPatrick Ohly <patrick.ohly@intel.com>2015-01-09 08:44:59 -0800
commitb0f9ba8cc0773d2f08dfe58fa332a39214b5fc7e (patch)
tree37bf919d8a38fd1ff5dd7ed76bde9ee1e2a3243e /meta-qt5
parent848e3ebfe6cacb979508c1eed952320a7b247226 (diff)
downloadtizen-distro-b0f9ba8cc0773d2f08dfe58fa332a39214b5fc7e.tar.gz
tizen-distro-b0f9ba8cc0773d2f08dfe58fa332a39214b5fc7e.tar.bz2
tizen-distro-b0f9ba8cc0773d2f08dfe58fa332a39214b5fc7e.zip
qtwebkit-examples: Add module
(From meta-qt5 rev: 2868f1a1838ab6a893fd01a05e61d582640a056d) Signed-off-by: Abhijit Potnis <abhijit_potnis@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Patrick Ohly <patrick.ohly@intel.com>
Diffstat (limited to 'meta-qt5')
-rw-r--r--meta-qt5/conf/distro/include/qt5-versions.inc1
-rw-r--r--meta-qt5/recipes-qt/qt5/qtwebkit-examples.inc7
-rw-r--r--meta-qt5/recipes-qt/qt5/qtwebkit-examples_5.0.2.bb8
-rw-r--r--meta-qt5/recipes-qt/qt5/qtwebkit-examples_5.1.0.bb5
-rw-r--r--meta-qt5/recipes-qt/qt5/qtwebkit-examples_git.bb4
5 files changed, 25 insertions, 0 deletions
diff --git a/meta-qt5/conf/distro/include/qt5-versions.inc b/meta-qt5/conf/distro/include/qt5-versions.inc
index 432da9f7f9..b9959ac4c7 100644
--- a/meta-qt5/conf/distro/include/qt5-versions.inc
+++ b/meta-qt5/conf/distro/include/qt5-versions.inc
@@ -16,6 +16,7 @@ PREFERRED_VERSION_qtsensors = "${QT5_VERSION}"
PREFERRED_VERSION_qtscript = "${QT5_VERSION}"
PREFERRED_VERSION_qtsvg = "${QT5_VERSION}"
PREFERRED_VERSION_qtwebkit = "${QT5_VERSION}"
+PREFERRED_VERSION_qtwebkit-examples = "${QT5_VERSION}"
PREFERRED_VERSION_qtxmlpatterns = "${QT5_VERSION}"
# append % only if it isn't included already
diff --git a/meta-qt5/recipes-qt/qt5/qtwebkit-examples.inc b/meta-qt5/recipes-qt/qt5/qtwebkit-examples.inc
new file mode 100644
index 0000000000..e8fa3e72c1
--- /dev/null
+++ b/meta-qt5/recipes-qt/qt5/qtwebkit-examples.inc
@@ -0,0 +1,7 @@
+require qt5.inc
+
+LICENSE = "BSD & LGPLv2+"
+LIC_FILES_CHKSUM = "file://examples/webkitwidgets/scroller/wheel/main.cpp;endline=112;md5=6f92d041824c63426993c8ce3ae0eb77 \
+ file://examples/webkitwidgets/imageanalyzer/imageanalyzer.cpp;endline=223;md5=13ffb472fefe4bdf6464954a22251f35"
+
+DEPENDS += "qtwebkit"
diff --git a/meta-qt5/recipes-qt/qt5/qtwebkit-examples_5.0.2.bb b/meta-qt5/recipes-qt/qt5/qtwebkit-examples_5.0.2.bb
new file mode 100644
index 0000000000..42a2264bf0
--- /dev/null
+++ b/meta-qt5/recipes-qt/qt5/qtwebkit-examples_5.0.2.bb
@@ -0,0 +1,8 @@
+require qt5-${PV}.inc
+require ${PN}.inc
+
+# was renamed to just qtwebkit-examples in 5.1
+QT_MODULE = "qtwebkit-examples-and-demos"
+
+SRC_URI[md5sum] = "9c48df80ba9bb3587b4d6ec35daf840a"
+SRC_URI[sha256sum] = "10981ae3a6775387badce33542733d63895c5a62b3b33e0973d782ec1b9174e6"
diff --git a/meta-qt5/recipes-qt/qt5/qtwebkit-examples_5.1.0.bb b/meta-qt5/recipes-qt/qt5/qtwebkit-examples_5.1.0.bb
new file mode 100644
index 0000000000..1e671b6b55
--- /dev/null
+++ b/meta-qt5/recipes-qt/qt5/qtwebkit-examples_5.1.0.bb
@@ -0,0 +1,5 @@
+require qt5-${PV}.inc
+require ${PN}.inc
+
+SRC_URI[md5sum] = "a27360f16e4ca31e3d1098d1b2feba73"
+SRC_URI[sha256sum] = "f8078a87df729103e6009432e5b784531842997197827f67db8a34f1715f8921"
diff --git a/meta-qt5/recipes-qt/qt5/qtwebkit-examples_git.bb b/meta-qt5/recipes-qt/qt5/qtwebkit-examples_git.bb
new file mode 100644
index 0000000000..67c2091d89
--- /dev/null
+++ b/meta-qt5/recipes-qt/qt5/qtwebkit-examples_git.bb
@@ -0,0 +1,4 @@
+require qt5-git.inc
+require ${PN}.inc
+
+SRCREV = "08118e862731b5ce91368d326a04b4a565e7f483"