summaryrefslogtreecommitdiff
path: root/recipes-tizen
diff options
context:
space:
mode:
authorRonan Le Martret <ronan@fridu.net>2014-05-16 12:06:43 +0200
committerRonan Le Martret <ronan@fridu.net>2014-05-16 12:16:47 +0200
commit91159a797aca16c97bc7ced0ca03d5f57c011464 (patch)
tree257d73fc4c1c64db98cc162f4bcbbda643210ec9 /recipes-tizen
parentb39c7fd8e0be23fa77ca6439d94a5c55c598b500 (diff)
downloadmeta-tizen-91159a797aca16c97bc7ced0ca03d5f57c011464.tar.gz
meta-tizen-91159a797aca16c97bc7ced0ca03d5f57c011464.tar.bz2
meta-tizen-91159a797aca16c97bc7ced0ca03d5f57c011464.zip
Add libslp-location
Change-Id: I56b91de35e80b4fa52b45e3bb631308e09c9a5d7 Signed-off-by: Ronan Le Martret <ronan@fridu.net>
Diffstat (limited to 'recipes-tizen')
-rw-r--r--recipes-tizen/libslp-location/libslp-location-extraconf.inc0
-rw-r--r--recipes-tizen/libslp-location/libslp-location.inc133
-rw-r--r--recipes-tizen/libslp-location/libslp-location_git.bb10
-rw-r--r--recipes-tizen/location-manager/location-manager.inc1
4 files changed, 144 insertions, 0 deletions
diff --git a/recipes-tizen/libslp-location/libslp-location-extraconf.inc b/recipes-tizen/libslp-location/libslp-location-extraconf.inc
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/recipes-tizen/libslp-location/libslp-location-extraconf.inc
diff --git a/recipes-tizen/libslp-location/libslp-location.inc b/recipes-tizen/libslp-location/libslp-location.inc
new file mode 100644
index 00000000..f1d8630c
--- /dev/null
+++ b/recipes-tizen/libslp-location/libslp-location.inc
@@ -0,0 +1,133 @@
+DESCRIPTION = "Location Based Service"
+HOMEPAGE = "http://nohomepage.org"
+SECTION = "Location/Libraries"
+LICENSE = "Apache-2.0"
+
+SRC_URI = ""
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep
+
+PROVIDES = ""
+
+#PROVIDES by libslp-location-dev
+
+
+#PROVIDES by libslp-location
+
+
+RDEPENDS = ""
+#RDEPENDS of libslp-location-dev (${PN}-dev)
+RDEPENDS_${PN}-dev += "libslp-location"
+
+#RDEPENDS of libslp-location (${PN})
+RDEPENDS_${PN} += "eglibc"
+RDEPENDS_${PN} += "vconf"
+
+
+DEPENDS = ""
+#DEPENDS of libslp-location
+DEPENDS += "dbus"
+DEPENDS += "dlog"
+DEPENDS += "glib-2.0"
+DEPENDS += "json-glib"
+DEPENDS += "vconf"
+
+do_prep() {
+ cd ${S}
+ chmod -Rf a+rX,u+w,g-w,o-w ${S}
+ #setup -q -n libslp-location-0.5.3
+ cp ${S}/packaging/libslp-location.manifest .
+
+
+
+}
+do_patch_append() {
+ bb.build.exec_func('do_prep', d)
+}
+
+do_configure() {
+}
+
+do_compile() {
+ cd ${S}
+ LANG=C
+ export LANG
+ unset DISPLAY
+ CFLAGS="-O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables" ; export CFLAGS ;
+ CXXFLAGS="${CXXFLAGS:--O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables}" ; export CXXFLAGS ;
+ FFLAGS="${FFLAGS:--O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -I%_fmoddir}" ; export FFLAGS ;
+ LD_AS_NEEDED=1; export LD_AS_NEEDED ;
+
+
+ ./autogen.sh
+
+ CFLAGS="${CFLAGS:--O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables}" ; export CFLAGS ;
+ CXXFLAGS="${CXXFLAGS:--O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables}" ; export CXXFLAGS ;
+ FFLAGS="${FFLAGS:--O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -I%_fmoddir}" ; export FFLAGS ;
+ autotools_do_configure --build=${TARGET_SYS} --host=${HOST_SYS} \
+ --target=x86_64-tizen-linux \
+ --program-prefix= \
+ --prefix=${prefix} \
+ --exec-prefix=${prefix} \
+ --bindir=${prefix}/bin \
+ --sbindir=${prefix}/sbin \
+ --sysconfdir=${sysconfdir} \
+ --datadir=${prefix}/share \
+ --includedir=${prefix}/include \
+ --libdir=${prefix}/lib \
+ --libexecdir=${prefix}/libexec \
+ --localstatedir=${localstatedir} \
+ --sharedstatedir=${prefix}/com \
+ --mandir=${mandir} \
+ --infodir=${infodir} --enable-dlog --enable-debug
+
+ make -j16
+
+
+
+
+}
+
+do_install() {
+ echo export RPM_BUILD_ROOT=${D}
+ cd ${S}
+ LANG=C
+ export LANG
+ unset DISPLAY
+ rm -rf ${D}
+ mkdir -p ${D}
+
+
+ oe_runmake \
+ DESTDIR=${D} \
+ INSTALL_ROOT=${D} \
+ BINDIR=${prefix}/bin \
+ install
+ rm -f ${D}${infodir}/dir
+ find ${D} -regex ".*\.la$" | xargs rm -f --
+ find ${D} -regex ".*\.a$" | xargs rm -f --
+
+
+
+}
+
+
+libslp-location-dev_files = ""
+libslp-location-dev_files += "libslp-location.manifest"
+libslp-location-dev_files += "${prefix}/include/location/*.h"
+libslp-location-dev_files += "${prefix}/lib/pkgconfig/*.pc"
+
+libslp-location_files = ""
+libslp-location_files += "libslp-location.manifest"
+libslp-location_files += "${prefix}/lib/lib*.so*"
+
+FILES_${PN}-dev = "${libslp-location-dev_files}"
+FILES_${PN} = "${libslp-location_files}"
+
+PKG_libslp-location-dev= "libslp-location-dev"
+PKG_libslp-location= "libslp-location"
+
+require libslp-location-extraconf.inc
+
diff --git a/recipes-tizen/libslp-location/libslp-location_git.bb b/recipes-tizen/libslp-location/libslp-location_git.bb
new file mode 100644
index 00000000..82e727f0
--- /dev/null
+++ b/recipes-tizen/libslp-location/libslp-location_git.bb
@@ -0,0 +1,10 @@
+require libslp-location.inc
+
+PRIORITY = "10"
+
+LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI += "git://review.tizen.org/platform/core/location/libslp-location;tag=165868e3ca2d034e4eec9d285e6531c1cc018738;nobranch=1"
+
+BBCLASSEXTEND = "native"
+
diff --git a/recipes-tizen/location-manager/location-manager.inc b/recipes-tizen/location-manager/location-manager.inc
index 5c53dcde..b4656341 100644
--- a/recipes-tizen/location-manager/location-manager.inc
+++ b/recipes-tizen/location-manager/location-manager.inc
@@ -28,6 +28,7 @@ DEPENDS_append_class-native = " cmake-native"
DEPENDS_append_class-target = " cmake-native"
DEPENDS += "common"
DEPENDS += "dlog"
+DEPENDS += "libslp-location"
do_prep() {
cd ${S}