summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Chernooky <vitaly.chernooky@globallogic.com>2015-03-06 15:19:08 +0200
committerVitaly Chernooky <vitaly.chernooky@globallogic.com>2015-03-06 15:21:00 +0200
commit72e2194a8c3731f81409100634f3f10a4c9212b3 (patch)
tree301cdaed4f2a522238fe77ab926eb23cde9d9715
parentee77c37500572f9b63e569f3ad0ca3ad35d70507 (diff)
downloadmeta-tizen-72e2194a8c3731f81409100634f3f10a4c9212b3.tar.gz
meta-tizen-72e2194a8c3731f81409100634f3f10a4c9212b3.tar.bz2
meta-tizen-72e2194a8c3731f81409100634f3f10a4c9212b3.zip
[HACK]mesa: Intel cards is disabled in steps to be compatible with TI DRA7XX
This changes no more than hack and subject to disscussion Change-Id: I5405a56da66756d9dff0e3ea78c09b75a85eb2f7 Signed-off-by: Vitaly Chernooky <vitaly.chernooky@globallogic.com>
-rw-r--r--meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa.inc4
-rw-r--r--meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa_%.bbappend8
2 files changed, 6 insertions, 6 deletions
diff --git a/meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa.inc b/meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa.inc
index 1857f3c2..129735c7 100644
--- a/meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa.inc
@@ -35,8 +35,8 @@ PACKAGECONFIG[xvmc] = "--enable-xvmc,--disable-xvmc,libxvmc"
PACKAGECONFIG[wayland] = ",,wayland"
DRIDRIVERS = "swrast"
-DRIDRIVERS_append_x86 = ",radeon,r200,nouveau,i965,i915"
-DRIDRIVERS_append_x86-64 = ",radeon,r200,nouveau,i965,i915"
+DRIDRIVERS_append_x86 = ",radeon,r200,nouveau"
+DRIDRIVERS_append_x86-64 = ",radeon,r200,nouveau"
PACKAGECONFIG[dri] = "--enable-dri --with-dri-drivers=${DRIDRIVERS}, --disable-dri, dri2proto libdrm"
PACKAGECONFIG[dri3] = "--enable-dri3, --disable-dri3, dri3proto presentproto libxshmfence"
diff --git a/meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa_%.bbappend b/meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa_%.bbappend
index b8e7d681..a467d28b 100644
--- a/meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa_%.bbappend
@@ -12,12 +12,12 @@ PACKAGECONFIG_append = " gallium-gbm"
PACKAGECONFIG_append = " gallium-llvm"
DRIDRIVERSTIZEN = "swrast"
-DRIDRIVERSTIZEN_append_x86 = ",i965,i915"
-DRIDRIVERSTIZEN_append_x86-64 = ",i965,i915"
+DRIDRIVERSTIZEN_append_x86 = ""
+DRIDRIVERSTIZEN_append_x86-64 = ""
PACKAGECONFIG[dri] = "--enable-dri --with-dri-drivers=${DRIDRIVERSTIZEN}, --disable-dri, dri2proto libdrm"
-GALLIUMDRIVERSTIZEN_append = ",i915"
+GALLIUMDRIVERSTIZEN_append = ""
GALLIUMDRIVERSTIZEN = "swrast"
GALLIUMDRIVERSTIZEN_LLVM33 = ""
@@ -26,4 +26,4 @@ GALLIUMDRIVERSTIZEN_LLVM = "svga,"
GALLIUMDRIVERSTIZEN_append_x86 = "${@bb.utils.contains('PACKAGECONFIG', 'gallium-llvm', ',${GALLIUMDRIVERSTIZEN_LLVM}', '', d)}"
GALLIUMDRIVERSTIZEN_append_x86-64 = "${@bb.utils.contains('PACKAGECONFIG', 'gallium-llvm', ',${GALLIUMDRIVERSTIZEN_LLVM}', '', d)}"
# keep --with-gallium-drivers separate, because when only one of gallium versions is enabled, other 2 were adding --without-gallium-drivers
-PACKAGECONFIG[gallium] = "--with-gallium-drivers=${GALLIUMDRIVERSTIZEN}, --without-gallium-drivers" \ No newline at end of file
+PACKAGECONFIG[gallium] = "--with-gallium-drivers=${GALLIUMDRIVERSTIZEN}, --without-gallium-drivers"