summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2015-01-22 06:13:01 -0800
committerPatrick Ohly <patrick.ohly@intel.com>2015-01-22 06:19:32 -0800
commit5e2f67146d2f06b7171d532b420233e9f119c5f9 (patch)
tree530d2881e8ee92b1cfc518a5dcb5e9ebbcb3928e
parenta2f016c18fe631229364308f156b56e0942bbba0 (diff)
downloadmeta-tizen-5e2f67146d2f06b7171d532b420233e9f119c5f9.tar.gz
meta-tizen-5e2f67146d2f06b7171d532b420233e9f119c5f9.tar.bz2
meta-tizen-5e2f67146d2f06b7171d532b420233e9f119c5f9.zip
desktop-file-utils: avoid host pollution
Building fails when Emacs is installed on the host. The reason is that the .spec file assumes that Emacs is not installed and installing the lisp files needs to be done manually after the desktop-file-utils "make install". The actual failure then is: ... | test ! -f /data/yocto/build/tizen-distro/ivi/x86_64/tmp-glibc/work/core2-64-oe-linux/desktop-file-utils/0.20-r0/image/usr/share/emacs/site-lisp/desktop-entry-mode.el | ERROR: Function failed: do_install (log file is located at /data/yocto/build/tizen-distro/ivi/x86_64/tmp-glibc/work/core2-64-oe-linux/desktop-file-utils/0.20-r0/temp/log.do_install.14197) ERROR: Task 6589 (/data/yocto/tizen-distro/meta-tizen/meta-tizen-common-base/recipes-core/desktop-file-utils/desktop-file-utils_git.bb,do_install) failed with exit code '1' To avoid the check for Emacs, pre-set the autoconf variable. Change-Id: Ib96451edf8b5ce13f9e957668b4406bd3e64209d Signed-off-by: Patrick Ohly <patrick.ohly@intel.com>
-rw-r--r--meta-tizen-common-base/recipes-core/desktop-file-utils/desktop-file-utils-extraconf.inc7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-tizen-common-base/recipes-core/desktop-file-utils/desktop-file-utils-extraconf.inc b/meta-tizen-common-base/recipes-core/desktop-file-utils/desktop-file-utils-extraconf.inc
index e69de29b..de023aff 100644
--- a/meta-tizen-common-base/recipes-core/desktop-file-utils/desktop-file-utils-extraconf.inc
+++ b/meta-tizen-common-base/recipes-core/desktop-file-utils/desktop-file-utils-extraconf.inc
@@ -0,0 +1,7 @@
+# The Tizen .spec assumes that Emacs is not installed and therefore
+# the lisp files don't get installed. When emacs is installed on the
+# host, the .spec derived build rules fail. To remove the host
+# environment dependency, disable the check for emacs as done before
+# in http://patchwork.openembedded.org/patch/40467/
+
+CACHED_CONFIGUREVARS += "ac_cv_prog_EMACS=no"