summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2014-12-19 14:36:52 +0100
committerPatrick Ohly <patrick.ohly@intel.com>2015-01-15 14:10:10 +0100
commit135b39e64c963f932d8b6bf29b117877787a3d6d (patch)
tree8a440eec5d442eff33bd6977530bdf678da4c61e
parentf75505b1b56e70a328c37b43b4d0c11c9c364368 (diff)
downloadmeta-tizen-135b39e64c963f932d8b6bf29b117877787a3d6d.tar.gz
meta-tizen-135b39e64c963f932d8b6bf29b117877787a3d6d.tar.bz2
meta-tizen-135b39e64c963f932d8b6bf29b117877787a3d6d.zip
poppler: fix dev dependencies and add libpoppler-cpp
Upstream .bb does not add all separate libs to the -dev package. Compared to Tizen, libpoppler-cpp.so.* was not split out. Inheriting libpkg with the fulll list of desired extra lib packages fixes both. Change-Id: Id027d2d9b7d7c378b0f83e0927ec6e11f609f5c1
-rw-r--r--meta-tizen-adaptation/meta-oe/recipes-support/poppler/poppler_%.bbappend8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-tizen-adaptation/meta-oe/recipes-support/poppler/poppler_%.bbappend b/meta-tizen-adaptation/meta-oe/recipes-support/poppler/poppler_%.bbappend
index abe32afc..4b181d68 100644
--- a/meta-tizen-adaptation/meta-oe/recipes-support/poppler/poppler_%.bbappend
+++ b/meta-tizen-adaptation/meta-oe/recipes-support/poppler/poppler_%.bbappend
@@ -1,5 +1,11 @@
SECTION = "System/Libraries"
-SRPM_IS_LIB = "lib${PN} lib${PN}-glib lib${PN}-cpp"
# Upstream bug: poppler autotools uses iconv.m4.
DEPENDS += "virtual/libintl"
+
+# Create separate lib packages. The base .bb already does that
+# for lib${PN} and lib${PN}-glib, but not lib${PN}-cpp (which
+# we want in Tizen), and it gets the -dev dependencies wrong.
+# libpkg fixes that for us. It also sets SRPM_IS_LIB.
+PKG_LIBS = "lib${PN}-cpp lib${PN}-glib lib${PN}"
+inherit libpkg