summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2015-01-22 10:26:39 -0800
committerPatrick Ohly <patrick.ohly@intel.com>2015-01-22 10:26:39 -0800
commit8729807cf92f6845b0be8439c563bd6955afe6c3 (patch)
tree6d12545b0b7de390bf51209882d63148fb671cc8
parentede2019a184d3ae1fbe778f814679c88c60be426 (diff)
downloadmeta-tizen-sandbox/pohly/converter.tar.gz
meta-tizen-sandbox/pohly/converter.tar.bz2
meta-tizen-sandbox/pohly/converter.zip
-rw-r--r--meta-tizen-adaptation/meta/recipes-core/expat/expat_%.bbappend11
-rw-r--r--meta-tizen-adaptation/meta/recipes-devtools/pkgconfig/pkgconfig_%.bbappend17
-rw-r--r--meta-tizen-adaptation/meta/recipes-graphics/cairo/cairo_%.bbappend3
-rw-r--r--meta-tizen-adaptation/meta/recipes-graphics/cogl/cogl-1.0_%.bbappend17
-rw-r--r--meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa_%.bbappend16
-rw-r--r--meta-tizen-adaptation/meta/recipes-graphics/wayland/wayland_%.bbappend12
-rw-r--r--meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend41
-rw-r--r--meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_%.bbappend5
-rw-r--r--meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend5
-rw-r--r--meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0_%.bbappend5
-rw-r--r--meta-tizen-adaptation/meta/recipes-support/gnutls/gnutls_%.bbappend7
-rw-r--r--meta-tizen-adaptation/meta/recipes-support/icu/icu_%.bbappend8
-rw-r--r--meta-tizen-common-base/classes/libpkg.bbclass4
-rw-r--r--meta-tizen-common-base/classes/tizensrpm.bbclass41
-rw-r--r--meta-tizen-common-base/recipes-core/desktop-file-utils/desktop-file-utils-extraconf.inc7
-rw-r--r--meta-tizen-ivi/recipes-graphics/wayland/wayland_%.bbappend5
16 files changed, 183 insertions, 21 deletions
diff --git a/meta-tizen-adaptation/meta/recipes-core/expat/expat_%.bbappend b/meta-tizen-adaptation/meta/recipes-core/expat/expat_%.bbappend
index 9da70afb..c167314b 100644
--- a/meta-tizen-adaptation/meta/recipes-core/expat/expat_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-core/expat/expat_%.bbappend
@@ -2,11 +2,8 @@ SECTION = "System/Libraries"
SRPM_IS_LIB = "libexpat"
# Split out library because that's how Tizen traditionally did it.
-PACKAGES =+ "libexpat"
-RDEPENDS_expat-dev_append = "libexpat (= ${EXTENDPKGV})"
-# Can't remove the main expat dependency from expat-dev because _remove
-# cannot handle more than single words.
+inherit libpkg
-SUMMARY_libexpat = "XML Parser library"
-DESCRIPTION_libexpat = "This package contains the libexpat library."
-FILES_libexpat = "${libdir}/*.so.*"
+# Do not generate separate expat-bin, in Tizen the binaries are in the
+# main package which would be empty otherwise.
+PACKAGES_remove = "${PN}-bin"
diff --git a/meta-tizen-adaptation/meta/recipes-devtools/pkgconfig/pkgconfig_%.bbappend b/meta-tizen-adaptation/meta/recipes-devtools/pkgconfig/pkgconfig_%.bbappend
index ae1bca54..cc432e42 100644
--- a/meta-tizen-adaptation/meta/recipes-devtools/pkgconfig/pkgconfig_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-devtools/pkgconfig/pkgconfig_%.bbappend
@@ -1 +1,18 @@
SECTION = "Development/Building"
+
+# pkg-config needs a working version of itself to compile.
+# Yocto solves that via cross-compiling. In the .spec file
+# we rely on some other bootstrapping.
+DEPENDS_append_srpm = " pkg-config-bootstrap"
+
+# Must provide this alias for Tizen .spec files.
+# We have to avoid triggering the tizensrpm.bbclass rewrite rules for
+# "pkgconfig". This adds the desired "Provides: pkgconfig = ..." to
+# the .spec file, but then rpmbuild does not add it to the resulting
+# .rpm. Perhaps because of "Name: pkgconfig".
+#
+# Bottom line is that we have to replace all packages depending on
+# "pkgconfig" with converted recipes.
+#
+# RPROVIDES_${PN}_append_srpm = " really-pkgconfig (= ${EXTENDPKGV})"
+# SRPM_RENAME += "really-pkgconfig=pkgconfig"
diff --git a/meta-tizen-adaptation/meta/recipes-graphics/cairo/cairo_%.bbappend b/meta-tizen-adaptation/meta/recipes-graphics/cairo/cairo_%.bbappend
index 136e0240..6b1318c8 100644
--- a/meta-tizen-adaptation/meta/recipes-graphics/cairo/cairo_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-graphics/cairo/cairo_%.bbappend
@@ -3,3 +3,6 @@ SRPM_IS_LIB = "${PN}-gobject ${PN}-script-interpreter lib${PN}"
PACKAGECONFIG_append = " egl "
PACKAGECONFIG_append = " glesv2 "
+
+# Upstream bug (?!): -dev package does not install all libs.
+RDEPENDS_${PN}-dev += "${PN}-gobject (= ${EXTENDPKGV})"
diff --git a/meta-tizen-adaptation/meta/recipes-graphics/cogl/cogl-1.0_%.bbappend b/meta-tizen-adaptation/meta/recipes-graphics/cogl/cogl-1.0_%.bbappend
index 6dee7d4e..b020a6e8 100644
--- a/meta-tizen-adaptation/meta/recipes-graphics/cogl/cogl-1.0_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-graphics/cogl/cogl-1.0_%.bbappend
@@ -1,2 +1,17 @@
SECTION = "Graphics & UI Framework/Libraries"
-SRPM_IS_LIB = "lib${PN} lib${PN}-gles2 lib${PN}-pango lib${PN}-path"
+SRPM_IS_LIB = "libcogl libcogl-gles2 libcogl-pango libcogl-path"
+
+# Don't generate an empty cogl-1.0 .rpm because it was replaced
+# by libcogl, which provides "cogl-1.0". Also creating cogl-1.0
+# would prevent installing cogl-1.0-dev because of the ambiguous
+# dependency on "cogl-1.0".
+#PACKAGES_remove = "${PN}"
+
+# cogl-1.0 is empty, but does get created when building with a
+# converted .spec. When that happens, the dependency on cogl-1.0 is
+# ambiguous. Better create libcogl via renaming when converting
+# to spec.
+PACKAGES_remove_srpm = "libcogl"
+SRPM_RENAME += "cogl-1.0=libcogl"
+
+
diff --git a/meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa_%.bbappend b/meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa_%.bbappend
index b8e7d681..a71d5a62 100644
--- a/meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,4 +1,5 @@
SECTION = "Graphics & UI Framework/Hardware Adaptation"
+SRPM_IS_LIB = "libegl-mesa libgbm libglapi libgl-mesa libgles1-mesa libgles2-mesa"
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI += "file://0001-intel:-FixinitialMakeCurrentfordrawablesofmultiscreens.patch"
@@ -26,4 +27,17 @@ GALLIUMDRIVERSTIZEN_LLVM = "svga,"
GALLIUMDRIVERSTIZEN_append_x86 = "${@bb.utils.contains('PACKAGECONFIG', 'gallium-llvm', ',${GALLIUMDRIVERSTIZEN_LLVM}', '', d)}"
GALLIUMDRIVERSTIZEN_append_x86-64 = "${@bb.utils.contains('PACKAGECONFIG', 'gallium-llvm', ',${GALLIUMDRIVERSTIZEN_LLVM}', '', d)}"
# keep --with-gallium-drivers separate, because when only one of gallium versions is enabled, other 2 were adding --without-gallium-drivers
-PACKAGECONFIG[gallium] = "--with-gallium-drivers=${GALLIUMDRIVERSTIZEN}, --without-gallium-drivers" \ No newline at end of file
+PACKAGECONFIG[gallium] = "--with-gallium-drivers=${GALLIUMDRIVERSTIZEN}, --without-gallium-drivers"
+
+# Tizen splits out the XML module from the core python package.
+DEPENDS_append_srpm = " python-xml-native"
+
+# TODO: do not include i915 in --with-gallium-drivers when configured for ARM.
+# It depends on intel-drm, which is not available on ARM.
+
+# Upstream bug: add missing dependencies.
+RDEPENDS_libegl-mesa-dev += "libegl-mesa"
+RDEPENDS_libgles1-mesa-dev += "libgles1-mesa"
+RDEPENDS_libgles2-mesa-dev += "libgles2-mesa"
+RDEPENDS_libgles3-mesa-dev += "libgles3-mesa"
+RDEPENDS_libgl-mesa-dev += "libgl-mesa"
diff --git a/meta-tizen-adaptation/meta/recipes-graphics/wayland/wayland_%.bbappend b/meta-tizen-adaptation/meta/recipes-graphics/wayland/wayland_%.bbappend
index e2eafb35..e8cc87f2 100644
--- a/meta-tizen-adaptation/meta/recipes-graphics/wayland/wayland_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-graphics/wayland/wayland_%.bbappend
@@ -1,7 +1,11 @@
SECTION = "Graphics & UI Framework/Wayland Window System"
+SRPM_IS_LIB = "libwayland"
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+# Disabling building of the scanner is a cross-compile trick.
+# Enabling it for native compilation adds a dependency on expat.
+EXTRA_OECONF_remove_srpm = "--disable-scanner"
+DEPENDS_append_srpm = " expat"
-SRC_URI += "file://0001-Added-APIstosupportmultiseatinwayland.patch"
-
-EXTRA_OECONF += "--enable-multiseat" \ No newline at end of file
+# Split out libs as done in Tizen traditionally.
+PKG_LIBS = "libwayland-client libwayland-cursor libwayland-server"
+inherit libpkg
diff --git a/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend b/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
index 9795e50a..c863c78c 100644
--- a/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
@@ -1 +1,42 @@
SECTION = "Multimedia/Service"
+
+# When converting, split out libraries as done in Tizen traditionally.
+# Also necessary because the original recipe relies on dynamic package
+# creation after compilation, which does not work when converting
+# to source rpm. When not converting, continue to use that mechanism.
+PKG_LIBS = ""
+PKG_LIBS_srpm = "\
+libgstaudio \
+libgstallocators \
+libgstapp \
+libgstfft \
+libgstpbutils \
+libgstriff \
+libgstrtp \
+libgstrtsp \
+libgstsdp \
+libgsttag \
+libgstvideo \
+"
+
+# Need to match library names with LIBV suffix. libpkg cannot do that
+# for us.
+FILES_libgstaudio_srpm = "${libdir}/libgstaudio-${LIBV}.so.*"
+FILES_libgstallocators_srpm = "${libdir}/libgstallocators-${LIBV}.so.*"
+FILES_libgstapp_srpm = "${libdir}/libgstapp-${LIBV}.so.*"
+FILES_libgstfft_srpm = "${libdir}/libgstfft-${LIBV}.so.*"
+FILES_libgstpbutils_srpm = "${libdir}/libgstpbutils-${LIBV}.so.*"
+FILES_libgstriff_srpm = "${libdir}/libgstriff-${LIBV}.so.*"
+FILES_libgstrtp_srpm = "${libdir}/libgstrtp-${LIBV}.so.*"
+FILES_libgstrtsp_srpm = "${libdir}/libgstrtsp-${LIBV}.so.*"
+FILES_libgstsdp_srpm = "${libdir}/libgstsdp-${LIBV}.so.*"
+FILES_libgsttag_srpm = "\
+${libdir}/libgsttag-${LIBV}.so.* \
+${datadir}/gst-plugins-base/${LIBV}/license-translations.dict \
+"
+FILES_libgstvideo_srpm = "${libdir}/libgstvideo-${LIBV}.so.*"
+
+inherit libpkg
+
+# Not sure why this is not matched by the original recipe...
+FILES_${PN}_srpm += "${libdir}/gstreamer-${LIBV}"
diff --git a/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_%.bbappend b/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_%.bbappend
index 9795e50a..9d0e48a0 100644
--- a/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_%.bbappend
@@ -1 +1,6 @@
SECTION = "Multimedia/Service"
+
+# Instead of copying a long PACKAGECONFIG ??= assignment,
+# disable only the taglib feature because "taglib" is not
+# part of Tizen.
+PACKAGECONFIG_remove = "taglib"
diff --git a/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend b/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend
index 9795e50a..b022858b 100644
--- a/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_%.bbappend
@@ -1 +1,6 @@
SECTION = "Multimedia/Service"
+
+# Instead of copying a (not so long) PACKAGECONFIG ??= assignment,
+# disable only the mpeg2dec feature because the necessary lib is not
+# part of Tizen.
+PACKAGECONFIG_remove = "mpeg2dec"
diff --git a/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0_%.bbappend b/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0_%.bbappend
index 4b2b293d..6eaf0c9a 100644
--- a/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-multimedia/gstreamer/gstreamer1.0_%.bbappend
@@ -1,6 +1,7 @@
SECTION = "Multimedia/Service"
-SRPM_IS_LIB = "gstreamer1"
+SRPM_IS_LIB = "${PN}"
EXTRA_OECONF += "--disable-examples --disable-tests"
-
+# Split out library because that's how Tizen traditionally did it.
+inherit libpkg
diff --git a/meta-tizen-adaptation/meta/recipes-support/gnutls/gnutls_%.bbappend b/meta-tizen-adaptation/meta/recipes-support/gnutls/gnutls_%.bbappend
index f993dc9d..e7b22115 100644
--- a/meta-tizen-adaptation/meta/recipes-support/gnutls/gnutls_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-support/gnutls/gnutls_%.bbappend
@@ -15,3 +15,10 @@ ${libdir}/libgnutls-openssl.so \
${includedir}/libgnutls/openssl.h \
"
RDEPENDS_gnutls-openssl-dev = "gnutls-openssl"
+
+# Missing in upstream. Checked for during configure:
+# checking for __gmpz_cmp in -lgmp... no
+# configure: error:
+# ***
+# *** gmp was not found.
+DEPENDS += "gmp"
diff --git a/meta-tizen-adaptation/meta/recipes-support/icu/icu_%.bbappend b/meta-tizen-adaptation/meta/recipes-support/icu/icu_%.bbappend
index 330b67c9..e713914e 100644
--- a/meta-tizen-adaptation/meta/recipes-support/icu/icu_%.bbappend
+++ b/meta-tizen-adaptation/meta/recipes-support/icu/icu_%.bbappend
@@ -1 +1,9 @@
SECTION = "System/Libraries"
+SRPM_IS_LIB = "libicu libicule libicutu libicudata libicui18n libicuio libiculx libicuuc"
+
+# Remove upstream cross-compiling trick when converting.
+EXTRA_OECONF_remove_srpm = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
+
+# TODO: instead of changing the license (which is incorrect!), either
+# get Tizen to accept ICU as license or suppress the rpmlint check.
+SPDXLICENSEMAP[ICU] = "BSD-3-Clause"
diff --git a/meta-tizen-common-base/classes/libpkg.bbclass b/meta-tizen-common-base/classes/libpkg.bbclass
index 5e679473..988b53f6 100644
--- a/meta-tizen-common-base/classes/libpkg.bbclass
+++ b/meta-tizen-common-base/classes/libpkg.bbclass
@@ -58,7 +58,9 @@ def generate_libs(d):
libs = d.getVar('PKG_LIBS', True)
pn = d.getVar('PN', True)
- if libs:
+ if libs == '':
+ pass
+ elif libs:
libs = libs.split()
# Reverse so that they get prepended in the original order to PACKAGES.
libs.reverse()
diff --git a/meta-tizen-common-base/classes/tizensrpm.bbclass b/meta-tizen-common-base/classes/tizensrpm.bbclass
index 034e2e64..afbdca22 100644
--- a/meta-tizen-common-base/classes/tizensrpm.bbclass
+++ b/meta-tizen-common-base/classes/tizensrpm.bbclass
@@ -115,6 +115,7 @@ SRPM_RENAME += "\
((?:lib)?)sqlite3(.*)=\1sqlite\2 \
alsa-lib-dev=libasound-dev \
atk=libatk \
+bluez5(.*)=bluez\1 \
bjam=boost-jam \
boost=libboost \
cairo=libcairo \
@@ -129,21 +130,26 @@ gdbm=libgdbm \
glib-2.0=glib2 \
gmp=libgmp \
gnutls-xx(.*)=libgnutlsxx\1 gnutls(.*)=libgnutls\1 \
+gstreamer1.0(.*)=gstreamer\1 gstreamer-plugins-(.*)=gst-plugins-\1 \
harfbuzz=libharfbuzz \
icu=libicu \
json-glib=libjson-glib \
kmod-dev=libkmod-dev \
libcheck(.*)=check\1 \
+libegl(.*)-mesa(.*)=mesa-libEGL\1\2 \
+libgles(.*)-mesa(.*)=mesa-libGLESv\1\2 \
+libglapi(.*)=mesa-libglapi\1 \
+libgl-mesa(.*)=mesa-libGL\1 \
liblcms=liblcms2 lcms-dev=liblcms2-dev lcms=lcms2 \
libjpeg-turbo=libjpeg libjpeg-turbo-dev=libjpeg-dev \
libnl=libnl3 libnl-(.*)=libnl3-\1 \
libpam(.*)=pam\1 \
libpcre-dev=pcre-dev pcregrep=pcre \
+libsm(.*)=libSM\1 \
libsndfile1(.*)=libsndfile\1 \
libsqlite-dev=sqlite-dev \
libusb1(.*)=libusb\1 \
-libx11(.*)=libX11\1 \
-libxft(.*)=libXft\1 \
+libx(11|au|composite|damage|dmcp|ext|fixes|ft|i|randr|render|v|xf86vm)(.*)=libX\1\2 \
libxml-parser-perl(.*)=perl-XML-Parser\1 \
llvm3.3(.*)=llvm\1 \
mpfr=libmpfr \
@@ -257,8 +263,8 @@ virtual/egl=pkgconfig(egl) \
virtual/libgl=pkgconfig(gl) \
virtual/libgles2=pkgconfig(glesv2) \
virtual/libiconv=glibc-dev \
-virtual/libintl=gettext-dev \
-virtual/libx11=libx11-dev \
+virtual/libintl=glibc-dev \
+virtual/libx11=pkgconfig(x11) \
virtual/mesa=mesa-dev \
"
@@ -267,6 +273,9 @@ virtual/mesa=mesa-dev \
# util-linux is needed, so require everything.
SRPM_REWRITE_DEPENDS_append = " util-linux=libblkid-dev,libmount-dev,pkgconfig(uuid)"
+# Dependency not unique in Tizen.
+SRPM_REWRITE_DEPENDS_append = " pulseaudio=pulseaudio-module-dev,libpulse-dev"
+
# Avoid hard dependency on specific packages via the corresponding
# pkgconfig(<.pc name>) or perl(<package>).
#
@@ -288,6 +297,7 @@ audio-session-manager=pkgconfig(audio-session-mgr) \
aul=pkgconfig(aul) \
badge=pkgconfig(badge) \
bluetooth-frwk=pkgconfig(bluetooth-api) \
+bluez=pkgconfig(bluez) \
bluez4=pkgconfig(bluez) \
bluez5=pkgconfig(bluez) \
bundle=pkgconfig(bundle) \
@@ -338,11 +348,13 @@ ethumb=pkgconfig(ethumb) \
evas=pkgconfig(evas) \
evolution-data-server=pkgconfig(libebook-contacts-1.2) \
expat=pkgconfig(expat) \
+fixesproto=pkgconfig(fixesproto) \
fontconfig=pkgconfig(fontconfig) \
freetype=pkgconfig(freetype2) \
fribidi=pkgconfig(fribidi) \
gconf=pkgconfig(gconf-2.0) \
gcr=pkgconfig(gcr-base-3) \
+glproto=pkgconfig(glproto) \
gnutls=pkgconfig(gnutls) \
gsignond=pkgconfig(gsignond) \
gssdp=pkgconfig(gssdp-1.0) \
@@ -356,6 +368,7 @@ heynoti=pkgconfig(heynoti) \
ibus=pkgconfig(ibus-1.0) \
icu=pkgconfig(icu-i18n) \
iniparser=pkgconfig(iniparser) \
+inputproto=pkgconfig(inputproto) \
json-c=pkgconfig(json) \
json-glib=pkgconfig(json-glib-1.0) \
kmod=pkgconfig(libkmod) \
@@ -399,6 +412,7 @@ libsf-common=pkgconfig(sf_common) \
libslp-db-util=pkgconfig(db-util) \
libslp-location=pkgconfig(location) \
libslp-memo=pkgconfig(memo) \
+libsm=pkgconfig(sm) \
libsndfile1=pkgconfig(sndfile) \
libsoup-2.4=pkgconfig(libsoup-2.4) \
libsvi=pkgconfig(feedback),pkgconfig(svi) \
@@ -410,9 +424,20 @@ libusb=pkgconfig(libusb-1.0) \
libwbxml2=pkgconfig(libwbxml2) \
libwebsockets=pkgconfig(libwebsockets) \
libwifi-direct=pkgconfig(wifi-direct) \
+libxau=pkgconfig(xau) \
+libxcomposite=pkgconfig(xcomposite) \
+compositeproto=pkgconfig(compositeproto) \
+libxdamage=pkgconfig(xdamage) \
+libxdmcp=pkgconfig(xdmcp) \
+libxext=pkgconfig(xext) \
+libxfixes=pkgconfig(xfixes) \
libxkbcommon=pkgconfig(xkbcommon) \
+libxi=pkgconfig(xi) \
libxml2=pkgconfig(libxml-2.0) \
+libxrandr=pkgconfig(xrandr) \
+libxrender=pkgconfig(xrender) \
libxslt=pkgconfig(libxslt) \
+libxf86vm=pkgconfig(xf86vm) \
lua=pkgconfig(lua) \
media-server=pkgconfig(libmedia-utils) \
message-port=pkgconfig(message-port) \
@@ -427,11 +452,11 @@ p11-kit=pkgconfig(p11-kit-1) \
pciutils=pkgconfig(libpci) \
pims-ipc=pkgconfig(pims-ipc) \
pixman=pkgconfig(pixman-1) \
-pkgconfig=pkgconfig(pkg-config) \
poppler=pkgconfig(poppler-glib) \
popt=pkgconfig(popt) \
privacy-manager-server=pkgconfig(privacy-manager-client) \
python=pkgconfig(python-2.7) \
+randrproto=pkgconfig(randrproto) \
sbc=pkgconfig(sbc) \
secure-storage=pkgconfig(secure-storage) \
security-server=pkgconfig(security-server) \
@@ -448,8 +473,14 @@ tizen-platform-config=pkgconfig(libtzplatform-config) \
tizen-platform-wrapper=pkgconfig(tizen-platform-wrapper) \
udev=pkgconfig(udev) \
usbutils=pkgconfig(usbutils) \
+util-macros=pkgconfig(xorg-macros) \
vconf-internal-keys=pkgconfig(vconf-internal-keys) \
weston=pkgconfig(weston) \
+xext=pkgconfig(xext) \
+xextproto=pkgconfig(xextproto) \
+xf86driproto=pkgconfig(xf86driproto) \
+xf86vidmodeproto=pkgconfig(xf86vidmodeproto) \
+xproto=pkgconfig(xproto) \
xdgmime=pkgconfig(xdgmime) \
xmlsec1=pkgconfig(xmlsec1) \
zeromq=pkgconfig(libzmq) \
diff --git a/meta-tizen-common-base/recipes-core/desktop-file-utils/desktop-file-utils-extraconf.inc b/meta-tizen-common-base/recipes-core/desktop-file-utils/desktop-file-utils-extraconf.inc
index e69de29b..de023aff 100644
--- a/meta-tizen-common-base/recipes-core/desktop-file-utils/desktop-file-utils-extraconf.inc
+++ b/meta-tizen-common-base/recipes-core/desktop-file-utils/desktop-file-utils-extraconf.inc
@@ -0,0 +1,7 @@
+# The Tizen .spec assumes that Emacs is not installed and therefore
+# the lisp files don't get installed. When emacs is installed on the
+# host, the .spec derived build rules fail. To remove the host
+# environment dependency, disable the check for emacs as done before
+# in http://patchwork.openembedded.org/patch/40467/
+
+CACHED_CONFIGUREVARS += "ac_cv_prog_EMACS=no"
diff --git a/meta-tizen-ivi/recipes-graphics/wayland/wayland_%.bbappend b/meta-tizen-ivi/recipes-graphics/wayland/wayland_%.bbappend
new file mode 100644
index 00000000..245cc766
--- /dev/null
+++ b/meta-tizen-ivi/recipes-graphics/wayland/wayland_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://0001-Added-APIstosupportmultiseatinwayland.patch"
+
+EXTRA_OECONF += "--enable-multiseat"