summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXavier Roche <xavier.roche@open.eurogiciel.org>2015-03-02 11:58:11 +0100
committerXavier Roche <xavier.roche@open.eurogiciel.org>2015-03-02 11:58:11 +0100
commit62901c5d68a4ba8031d51a102b40b412537c2e95 (patch)
tree9f4daf9c10b7ce94365a4e694dc8c6fdda245571
parentd94149e479399ef03c0e7733f5380624e6f0e75c (diff)
downloadmeta-tizen-62901c5d68a4ba8031d51a102b40b412537c2e95.tar.gz
meta-tizen-62901c5d68a4ba8031d51a102b40b412537c2e95.tar.bz2
meta-tizen-62901c5d68a4ba8031d51a102b40b412537c2e95.zip
Fix build issues
Signed-off-by: Xavier Roche <xavier.roche@open.eurogiciel.org>
-rw-r--r--meta-tizen-common-base/recipes-application-framework/aul/aul.inc1
-rw-r--r--meta-tizen-common-base/recipes-application-framework/capi-system-sensor/capi-system-sensor.inc2
-rw-r--r--meta-tizen-common-base/recipes-application-framework/sensord/files/0002-Fix-libinstalldir.patch245
-rw-r--r--meta-tizen-common-base/recipes-application-framework/sensord/sensord-extraconf.inc1
-rw-r--r--meta-tizen-common-base/recipes-application-framework/sensord/sensord.inc15
-rw-r--r--meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton-extraconf.inc1
-rw-r--r--meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton.inc8
-rw-r--r--meta-tizen-common-base/recipes-application-framework/vconf-internal-keys/vconf-internal-keys.inc2
-rw-r--r--meta-tizen-common-base/recipes-core/sensor/sensor.inc3
-rw-r--r--meta-tizen-common-base/recipes-image/images/tizen-core-image-minimal.bb1
-rw-r--r--meta-tizen-common-base/recipes-security/buxton/buxton-extraconf.inc32
-rw-r--r--meta-tizen-common-demo/recipes-image/packagegroups/packagegroups-tizen-crosswalk.bb1
-rw-r--r--meta-tizen-ivi/meta-tizen-common-base/recipes-multimedia/avsystem/avsystem.inc13
13 files changed, 300 insertions, 25 deletions
diff --git a/meta-tizen-common-base/recipes-application-framework/aul/aul.inc b/meta-tizen-common-base/recipes-application-framework/aul/aul.inc
index 1b1ece7b..78f17b54 100644
--- a/meta-tizen-common-base/recipes-application-framework/aul/aul.inc
+++ b/meta-tizen-common-base/recipes-application-framework/aul/aul.inc
@@ -28,6 +28,7 @@ RDEPENDS = ""
#RDEPENDS of aul (${PN})
RDEPENDS_${PN} += "glibc"
RDEPENDS_${PN} += "systemd"
+RDEPENDS_${PN} += "elfutils"
#RDEPENDS of aul-dev (${PN}-dev)
RDEPENDS_${PN}-dev += "aul"
diff --git a/meta-tizen-common-base/recipes-application-framework/capi-system-sensor/capi-system-sensor.inc b/meta-tizen-common-base/recipes-application-framework/capi-system-sensor/capi-system-sensor.inc
index a28322a7..bc7cc898 100644
--- a/meta-tizen-common-base/recipes-application-framework/capi-system-sensor/capi-system-sensor.inc
+++ b/meta-tizen-common-base/recipes-application-framework/capi-system-sensor/capi-system-sensor.inc
@@ -8,7 +8,7 @@ SRC_URI = ""
S = "${WORKDIR}/git"
-inherit manifest autotools-brokensep
+inherit manifest cmake
BBCLASSEXTEND = ""
PROVIDES = ""
diff --git a/meta-tizen-common-base/recipes-application-framework/sensord/files/0002-Fix-libinstalldir.patch b/meta-tizen-common-base/recipes-application-framework/sensord/files/0002-Fix-libinstalldir.patch
new file mode 100644
index 00000000..c26ec857
--- /dev/null
+++ b/meta-tizen-common-base/recipes-application-framework/sensord/files/0002-Fix-libinstalldir.patch
@@ -0,0 +1,245 @@
+From ecdcc3fd5d7da81497b7fd33d74ca1e0fb9dc188 Mon Sep 17 00:00:00 2001
+From: Xavier Roche <xavrock.os@gmail.com>
+Date: Tue, 24 Feb 2015 15:48:42 +0100
+Subject: [PATCH] Fix lib install dir
+
+Signed-off-by: Xavier Roche <xavrock.os@gmail.com>
+---
+ CMakeLists.txt | 4 ++--
+ src/accel/CMakeLists.txt | 4 ++--
+ src/auto_rotation/CMakeLists.txt | 2 +-
+ src/geo/CMakeLists.txt | 4 ++--
+ src/gravity/CMakeLists.txt | 2 +-
+ src/gyro/CMakeLists.txt | 4 ++--
+ src/libsensord/CMakeLists.txt | 4 ++--
+ src/light/CMakeLists.txt | 4 ++--
+ src/linear_accel/CMakeLists.txt | 2 +-
+ src/orientation/CMakeLists.txt | 2 +-
+ src/pressure/CMakeLists.txt | 4 ++--
+ src/proxi/CMakeLists.txt | 4 ++--
+ src/rotation_vector/rv/CMakeLists.txt | 2 +-
+ src/rotation_vector/rv_raw/CMakeLists.txt | 4 ++--
+ src/sensor_fusion/CMakeLists.txt | 2 +-
+ src/shared/CMakeLists.txt | 8 ++++----
+ src/temperature/CMakeLists.txt | 4 ++--
+ 17 files changed, 30 insertions(+), 30 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ad539ca..5cd0bea 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -5,7 +5,7 @@ include(GNUInstallDirs)
+ # Setup For pkgconfig File
+ SET(PREFIX ${CMAKE_INSTALL_PREFIX})
+ SET(EXEC_PREFIX "${PREFIX}/bin")
+-SET(LIBDIR "${PREFIX}/${CMAKE_INSTALL_LIBDIR}")
++SET(LIBDIR "${PREFIX}/lib")
+ SET(INCLUDEDIR "${PREFIX}/${CMAKE_INSTALL_INCLUDEDIR}")
+ SET(VERSION 1.0)
+
+@@ -16,7 +16,7 @@ MESSAGE("FLAGS: ${CMAKE_CXX_FLAGS}")
+ MESSAGE("FLAGS: ${CMAKE_EXE_LINKER_FLAGS}")
+
+ add_definitions(-DUSE_DLOG_LOG)
+-add_definitions(-DLIBDIR="${CMAKE_INSTALL_LIBDIR}")
++add_definitions(-DLIBDIR="${LIBDIR}")
+
+ # Internal Debugging Options
+ #add_definitions(-Wall -g -D_DEBUG)
+diff --git a/src/accel/CMakeLists.txt b/src/accel/CMakeLists.txt
+index a37c89c..2f98f37 100755
+--- a/src/accel/CMakeLists.txt
++++ b/src/accel/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${accel_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${accel_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/auto_rotation/CMakeLists.txt b/src/auto_rotation/CMakeLists.txt
+index a0076b2..121c265 100644
+--- a/src/auto_rotation/CMakeLists.txt
++++ b/src/auto_rotation/CMakeLists.txt
+@@ -25,4 +25,4 @@ add_library(${SENSOR_NAME} SHARED
+
+ target_link_libraries(${SENSOR_NAME} ${auto_rot_pkgs_LDFLAGS} "-lm")
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/geo/CMakeLists.txt b/src/geo/CMakeLists.txt
+index c6d4aa1..0c593c5 100755
+--- a/src/geo/CMakeLists.txt
++++ b/src/geo/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${geo_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${geo_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/gravity/CMakeLists.txt b/src/gravity/CMakeLists.txt
+index e66964e..69ae097 100755
+--- a/src/gravity/CMakeLists.txt
++++ b/src/gravity/CMakeLists.txt
+@@ -23,4 +23,4 @@ add_library(${SENSOR_NAME} SHARED
+
+ target_link_libraries(${SENSOR_NAME} ${gravity_pkgs_LDFLAGS} "-lm")
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/gyro/CMakeLists.txt b/src/gyro/CMakeLists.txt
+index 228fac9..f2ce149 100755
+--- a/src/gyro/CMakeLists.txt
++++ b/src/gyro/CMakeLists.txt
+@@ -28,5 +28,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${gyro_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${gyro_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/libsensord/CMakeLists.txt b/src/libsensord/CMakeLists.txt
+index 5b57251..f507c93 100755
+--- a/src/libsensord/CMakeLists.txt
++++ b/src/libsensord/CMakeLists.txt
+@@ -34,7 +34,7 @@ SET_TARGET_PROPERTIES(${PROJECT_NAME} PROPERTIES SOVERSION ${VERSION_MAJOR})
+ SET_TARGET_PROPERTIES(${PROJECT_NAME} PROPERTIES VERSION ${VERSION})
+
+ configure_file(${PROJECT_NAME}.pc.in ${CMAKE_CURRENT_SOURCE_DIR}/${PROJECT_NAME}.pc @ONLY)
+-install(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT RuntimeLibraries)
++install(TARGETS ${PROJECT_NAME} DESTINATION ${LIBDIR} COMPONENT RuntimeLibraries)
+ install(FILES sensor.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+ install(FILES sensor_internal_deprecated.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+ install(FILES sensor_internal.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+@@ -59,4 +59,4 @@ install(FILES sensor_rv.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+ install(FILES sensor_temperature.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+ install(FILES sensor_motion.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+ install(FILES sensor_deprecated.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/sensor/)
+-install(FILES ${PROJECT_NAME}.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
++install(FILES ${PROJECT_NAME}.pc DESTINATION ${LIBDIR}/pkgconfig)
+diff --git a/src/light/CMakeLists.txt b/src/light/CMakeLists.txt
+index 099ff82..759cba7 100755
+--- a/src/light/CMakeLists.txt
++++ b/src/light/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${light_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${light_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/linear_accel/CMakeLists.txt b/src/linear_accel/CMakeLists.txt
+index 986fb11..52a573a 100755
+--- a/src/linear_accel/CMakeLists.txt
++++ b/src/linear_accel/CMakeLists.txt
+@@ -24,4 +24,4 @@ add_library(${SENSOR_NAME} SHARED
+
+ target_link_libraries(${SENSOR_NAME} ${linear_accel_pkgs_LDFLAGS} "-lm")
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/orientation/CMakeLists.txt b/src/orientation/CMakeLists.txt
+index 6f02e9a..e7ef28a 100755
+--- a/src/orientation/CMakeLists.txt
++++ b/src/orientation/CMakeLists.txt
+@@ -24,4 +24,4 @@ add_library(${SENSOR_NAME} SHARED
+
+ target_link_libraries(${SENSOR_NAME} ${orientation_pkgs_LDFLAGS} "-lm")
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/pressure/CMakeLists.txt b/src/pressure/CMakeLists.txt
+index e61aca4..9eb8df8 100755
+--- a/src/pressure/CMakeLists.txt
++++ b/src/pressure/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${pressure_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${pressure_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/proxi/CMakeLists.txt b/src/proxi/CMakeLists.txt
+index 7cd4517..e05cc43 100755
+--- a/src/proxi/CMakeLists.txt
++++ b/src/proxi/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${proxi_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${proxi_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/rotation_vector/rv/CMakeLists.txt b/src/rotation_vector/rv/CMakeLists.txt
+index d26d4f9..6e0e386 100755
+--- a/src/rotation_vector/rv/CMakeLists.txt
++++ b/src/rotation_vector/rv/CMakeLists.txt
+@@ -24,4 +24,4 @@ add_library(${SENSOR_NAME} SHARED
+
+ target_link_libraries(${SENSOR_NAME} ${rv_pkgs_LDFLAGS} "-lm")
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/rotation_vector/rv_raw/CMakeLists.txt b/src/rotation_vector/rv_raw/CMakeLists.txt
+index 223b8c8..e83a639 100755
+--- a/src/rotation_vector/rv_raw/CMakeLists.txt
++++ b/src/rotation_vector/rv_raw/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${rv_raw_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${rv_raw_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/sensor_fusion/CMakeLists.txt b/src/sensor_fusion/CMakeLists.txt
+index c38f410..526b396 100755
+--- a/src/sensor_fusion/CMakeLists.txt
++++ b/src/sensor_fusion/CMakeLists.txt
+@@ -35,4 +35,4 @@ add_library(${SENSOR_FUSION_NAME} SHARED
+
+ target_link_libraries(${SENSOR_FUSION_NAME} ${rpkgs_LDFLAGS} ${GLES_LDFLAGS} "-lm")
+
+-install(TARGETS ${SENSOR_FUSION_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_FUSION_NAME} DESTINATION ${LIBDIR}/sensord)
+diff --git a/src/shared/CMakeLists.txt b/src/shared/CMakeLists.txt
+index f400944..3b37bb6 100755
+--- a/src/shared/CMakeLists.txt
++++ b/src/shared/CMakeLists.txt
+@@ -51,10 +51,10 @@ target_link_libraries(sensord-share ${shared_pkgs_LDFLAGS} "-lrt -ldl -pthread")
+ configure_file(sensord-server.pc.in ${CMAKE_CURRENT_SOURCE_DIR}/sensord-server.pc @ONLY)
+ configure_file(${PROJECT_NAME}.pc.in ${CMAKE_CURRENT_SOURCE_DIR}/${PROJECT_NAME}.pc @ONLY)
+
+-install(TARGETS sensord-server DESTINATION ${CMAKE_INSTALL_LIBDIR})
+-install(TARGETS sensord-share DESTINATION ${CMAKE_INSTALL_LIBDIR})
+-install(FILES sensord-server.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+-install(FILES ${PROJECT_NAME}.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
++install(TARGETS sensord-server DESTINATION ${LIBDIR})
++install(TARGETS sensord-share DESTINATION ${LIBDIR})
++install(FILES sensord-server.pc DESTINATION ${LIBDIR}/pkgconfig)
++install(FILES ${PROJECT_NAME}.pc DESTINATION ${LIBDIR}/pkgconfig)
+ install(FILES
+ crw_lock.h
+ worker_thread.h
+diff --git a/src/temperature/CMakeLists.txt b/src/temperature/CMakeLists.txt
+index 87dab53..26e03c9 100755
+--- a/src/temperature/CMakeLists.txt
++++ b/src/temperature/CMakeLists.txt
+@@ -29,5 +29,5 @@ add_library(${SENSOR_HAL_NAME} SHARED
+ target_link_libraries(${SENSOR_NAME} ${temp_pkgs_LDFLAGS} "-lm")
+ target_link_libraries(${SENSOR_HAL_NAME} ${temp_pkgs_LDFLAGS})
+
+-install(TARGETS ${SENSOR_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
+-install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}/sensord)
++install(TARGETS ${SENSOR_NAME} DESTINATION ${LIBDIR}/sensord)
++install(TARGETS ${SENSOR_HAL_NAME} DESTINATION ${LIBDIR}/sensord)
+--
+1.9.1
+
diff --git a/meta-tizen-common-base/recipes-application-framework/sensord/sensord-extraconf.inc b/meta-tizen-common-base/recipes-application-framework/sensord/sensord-extraconf.inc
index 28e64b57..fa16d971 100644
--- a/meta-tizen-common-base/recipes-application-framework/sensord/sensord-extraconf.inc
+++ b/meta-tizen-common-base/recipes-application-framework/sensord/sensord-extraconf.inc
@@ -1,2 +1,3 @@
INSANE_SKIP_${PN} = "dev-so"
SRC_URI += "file://0001-remove-linkerflags.patch"
+SRC_URI += "file://0002-Fix-libinstalldir.patch"
diff --git a/meta-tizen-common-base/recipes-application-framework/sensord/sensord.inc b/meta-tizen-common-base/recipes-application-framework/sensord/sensord.inc
index 8d10f182..9d11c582 100644
--- a/meta-tizen-common-base/recipes-application-framework/sensord/sensord.inc
+++ b/meta-tizen-common-base/recipes-application-framework/sensord/sensord.inc
@@ -26,6 +26,7 @@ PROVIDES += "sensord-sensord"
#PROVIDES by libsensord
PROVIDES += "libsensord"
+PROVIDES += "sensor"
RDEPENDS = ""
@@ -55,6 +56,11 @@ do_prep() {
cd ${S}
chmod -Rf a+rX,u+w,g-w,o-w ${S}
#setup -q
+
+}
+
+do_configure() {
+ cd ${S}
cp ${S}/packaging/sensord.manifest .
cp ${S}/packaging/libsensord.manifest .
@@ -65,14 +71,6 @@ do_prep() {
-DLINEAR_ACCEL=ON -DRV=ON \
-DTEST_SUITE=OFF \
-DLIBDIR=${prefix}/lib -DINCLUDEDIR=${prefix}/include
-
-
-}
-do_patch_append() {
- bb.build.exec_func('do_prep', d)
-}
-
-do_configure() {
}
do_compile() {
@@ -103,6 +101,7 @@ do_install() {
DESTDIR=${D} \
INSTALL_ROOT=${D} \
BINDIR=${prefix}/bin \
+ LIBDIR=${prefix}/lib \
install
rm -f ${D}${infodir}/dir
find ${D} -regex ".*\.la$" | xargs rm -f --
diff --git a/meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton-extraconf.inc b/meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton-extraconf.inc
index a2ada317..5d32d0d9 100644
--- a/meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton-extraconf.inc
+++ b/meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton-extraconf.inc
@@ -5,3 +5,4 @@ DEPENDS_vconf-buxton_remove_class-native = "systemd-native"
DEPENDS_class-native += "systemd-native"
DEPENDS_class-native += "vconf-internal-keys-native"
DEPENDS_class-native += "buxton-native"
+
diff --git a/meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton.inc b/meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton.inc
index 544c5994..53f2b6e1 100644
--- a/meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton.inc
+++ b/meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton.inc
@@ -49,7 +49,7 @@ RDEPENDS_${PN} += "util-linux"
DEPENDS = ""
#DEPENDS of vconf-buxton
-DEPENDS += "vconf-internal-keys"
+DEPENDS += "vconf-internal-keys-dev"
DEPENDS += "buxton"
inherit tizen_cmake
inherit pkgconfig
@@ -114,9 +114,9 @@ do_install() {
rm -f ${D}${infodir}/dir
find ${D} -regex ".*\.la$" | xargs rm -f --
find ${D} -regex ".*\.a$" | xargs rm -f --
- mv ${S}/src/vconf-buxton-setup.service ${S}/src/vconf-setup.service
- mkdir -p ${D}${systemd_unitdir}/system/basic.target.wants
- ln -sf ${S}/src/vconf-setup.service ${D}${systemd_unitdir}/system/basic.target.wants/
+ cp ${S}/src/vconf-buxton-setup.service ${S}/src/vconf-setup.service
+ mkdir -p ${D}${systemd_unitdir}/system/basic.target.wants
+ cp ${S}/src/vconf-setup.service ${D}${systemd_unitdir}/system/basic.target.wants/
}
diff --git a/meta-tizen-common-base/recipes-application-framework/vconf-internal-keys/vconf-internal-keys.inc b/meta-tizen-common-base/recipes-application-framework/vconf-internal-keys/vconf-internal-keys.inc
index cff4255f..f7f5d0fb 100644
--- a/meta-tizen-common-base/recipes-application-framework/vconf-internal-keys/vconf-internal-keys.inc
+++ b/meta-tizen-common-base/recipes-application-framework/vconf-internal-keys/vconf-internal-keys.inc
@@ -14,6 +14,7 @@ BBCLASSEXTEND = ""
PROVIDES = ""
#PROVIDES by vconf-internal-keys
+PROVIDES += "vconf-internal-keys"
#PROVIDES by vconf-internal-keys-dev
@@ -102,6 +103,7 @@ MANIFESTFILES_${PN}-dev = "vconf-internal-keys.manifest"
FILES_${PN}-dev = "${vconf-internal-keys-dev_files}"
PKG_${PN}-dev= "${PN}-dev"
+PKG_${PN}-dev= "${PN}"
require vconf-internal-keys-extraconf.inc
diff --git a/meta-tizen-common-base/recipes-core/sensor/sensor.inc b/meta-tizen-common-base/recipes-core/sensor/sensor.inc
index b06799c5..d5b3273c 100644
--- a/meta-tizen-common-base/recipes-core/sensor/sensor.inc
+++ b/meta-tizen-common-base/recipes-core/sensor/sensor.inc
@@ -76,6 +76,8 @@ do_compile() {
}
+EXTRA_OECMAKE = "-DCMAKE_INSTALL_LIBDIR=${prefix}/lib"
+
do_install() {
export RPM_BUILD_ROOT=${D}
cd ${S}
@@ -90,6 +92,7 @@ do_install() {
DESTDIR=${D} \
INSTALL_ROOT=${D} \
BINDIR=${prefix}/bin \
+ LIBDIR=${prefix}/lib \
install
rm -f ${D}${infodir}/dir
find ${D} -regex ".*\.la$" | xargs rm -f --
diff --git a/meta-tizen-common-base/recipes-image/images/tizen-core-image-minimal.bb b/meta-tizen-common-base/recipes-image/images/tizen-core-image-minimal.bb
index 5ae75288..86f191ec 100644
--- a/meta-tizen-common-base/recipes-image/images/tizen-core-image-minimal.bb
+++ b/meta-tizen-common-base/recipes-image/images/tizen-core-image-minimal.bb
@@ -37,7 +37,6 @@ CORE_IMAGE_BASE_INSTALL += "libgles2-mesa"
CORE_IMAGE_BASE_INSTALL += "gum-utils"
CORE_IMAGE_BASE_INSTALL += "meta-common"
CORE_IMAGE_BASE_INSTALL += "pam"
-CORE_IMAGE_BASE_INSTALL += "user-session-units"
CORE_IMAGE_BASE_INSTALL += "default-ac-domains"
CORE_IMAGE_BASE_INSTALL += "rpm-security-plugin"
CORE_IMAGE_BASE_INSTALL += "config-image"
diff --git a/meta-tizen-common-base/recipes-security/buxton/buxton-extraconf.inc b/meta-tizen-common-base/recipes-security/buxton/buxton-extraconf.inc
index 48266995..23e92130 100644
--- a/meta-tizen-common-base/recipes-security/buxton/buxton-extraconf.inc
+++ b/meta-tizen-common-base/recipes-security/buxton/buxton-extraconf.inc
@@ -1,21 +1,41 @@
+SRC_URI_class-native = "git://review.tizen.org/platform/upstream/buxton;tag=30ff93b6f03098ab14626e2212776b05594cb212;nobranch=1"
SRC_URI_class-native += "file://0001-remove-buxtondgeneration.patch"
-DEPENDS_class-native = ""
-DEPENDS_class-native += "systemd-native "
-DEPENDS_class-native += "libcheck-native"
-DEPENDS_class-native += "attr-native"
-DEPENDS_class-native += "gdbm-native"
+DEPENDS_append_class-native = ""
+DEPENDS_append_class-native += "systemd-native "
+DEPENDS_append_class-native += "libcheck-native"
+DEPENDS_append_class-native += "attr-native"
+DEPENDS_append_class-native += "gdbm-native"
RDEPENDS_${PN}_class-native = ""
RDEPENDS_${PN}_class-native += "coreutils"
RDEPENDS_${PN}_class-native += "smack"
+
do_prep_class-native() {
cd ${S}
chmod -Rf a+rX,u+w,g-w,o-w ${S}
#setup -q
- cp ${S}/packaging/buxton.manifest .
}
+
+do_patch_prepend_class-native() {
+ bb.build.exec_func('do_fetch', d)
+}
+
+do_compile_class-native() {
+ cd ${S}
+ LANG=C
+ export LANG
+ unset DISPLAY
+ LD_AS_NEEDED=1; export LD_AS_NEEDED ;
+
+
+ autotools_do_configure
+ make ${PARALLEL_MAKE}
+
+
+
+}
diff --git a/meta-tizen-common-demo/recipes-image/packagegroups/packagegroups-tizen-crosswalk.bb b/meta-tizen-common-demo/recipes-image/packagegroups/packagegroups-tizen-crosswalk.bb
index 45ea8a39..cbfe78da 100644
--- a/meta-tizen-common-demo/recipes-image/packagegroups/packagegroups-tizen-crosswalk.bb
+++ b/meta-tizen-common-demo/recipes-image/packagegroups/packagegroups-tizen-crosswalk.bb
@@ -10,4 +10,5 @@ RDEPENDS_packagegroup-tizen-crosswalk = "\
crosswalk \
tizen-extensions-crosswalk \
wrt-widgets \
+ user-session-units \
"
diff --git a/meta-tizen-ivi/meta-tizen-common-base/recipes-multimedia/avsystem/avsystem.inc b/meta-tizen-ivi/meta-tizen-common-base/recipes-multimedia/avsystem/avsystem.inc
index 6a9020c0..1ebd4d7e 100644
--- a/meta-tizen-ivi/meta-tizen-common-base/recipes-multimedia/avsystem/avsystem.inc
+++ b/meta-tizen-ivi/meta-tizen-common-base/recipes-multimedia/avsystem/avsystem.inc
@@ -97,11 +97,14 @@ do_install() {
find ${D} -regex ".*\.la$" | xargs rm -f --
find ${D} -regex ".*\.a$" | xargs rm -f --
- mkdir -m 755 -p ${D}${systemd_unitdir}/system/multi-user.target.wants
- install -m 0644 ${S}/packaging/avsystem.service ${D}${systemd_unitdir}/system/avsystem.service
- ln -sf ../avsystem.service ${D}${systemd_unitdir}/system/multi-user.target.wants/avsystem.service
-
-
+ mkdir -m 755 -p ${D}/etc/rc.d/rc3.d/
+ ln -s ../init.d/snd_init ${D}/etc/rc.d/rc3.d/S15snd_init
+ mkdir -m 755 -p ${D}/etc/rc.d/rc4.d/
+ ln -s ../init.d/snd_init ${D}/etc/rc.d/rc4.d/S15snd_init
+
+ mkdir -m 755 -p ${D}/${prefix}/lib/systemd/system/multi-user.target.wants
+ install -m 0644 %SOURCE101 ${D}/${prefix}/lib/systemd/system/avsystem.service
+ ln -s ../avsystem.service ${D}/${prefix}/lib/systemd/system/multi-user.target.wants/avsystem.service
}