summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXavier Roche <xavrock.os@gmail.com>2015-02-24 10:57:16 +0100
committerXavier Roche <xavrock.os@gmail.com>2015-02-24 10:57:16 +0100
commitd94149e479399ef03c0e7733f5380624e6f0e75c (patch)
treec159c683daf3049ff6a9bbe916ac7ae5c5746a2b
parentd0e62050302ec31236c5bfdf9b9b680633da3852 (diff)
downloadmeta-tizen-d94149e479399ef03c0e7733f5380624e6f0e75c.tar.gz
meta-tizen-d94149e479399ef03c0e7733f5380624e6f0e75c.tar.bz2
meta-tizen-d94149e479399ef03c0e7733f5380624e6f0e75c.zip
Fix build issue
Signed-off-by: Xavier Roche <xavrock.os@gmail.com>
-rw-r--r--meta-tizen-common-base/recipes-application-framework/capi-system-device/capi-system-device-extraconf.inc2
-rw-r--r--meta-tizen-common-base/recipes-application-framework/capi-system-device/capi-system-device.inc4
-rw-r--r--meta-tizen-common-base/recipes-application-framework/capi-system-device/files/0001-fix-uncatchedenum.patch32
-rw-r--r--meta-tizen-common-base/recipes-application-framework/deviced/deviced.inc20
-rw-r--r--meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton-extraconf.inc2
-rw-r--r--meta-tizen-common-base/recipes-application-framework/vconf/files/remove-dlog-for-native.patch25
-rw-r--r--meta-tizen-common-base/recipes-application-framework/vconf/vconf-extraconf.inc_old25
-rw-r--r--meta-tizen-common-base/recipes-application-framework/vconf/vconf.inc_old181
-rw-r--r--meta-tizen-common-base/recipes-application-framework/vconf/vconf_git.bb_old10
-rw-r--r--meta-tizen-common-base/recipes-core/system-server/system-server-extraconf.inc_old0
-rw-r--r--meta-tizen-common-base/recipes-core/system-server/system-server.inc_old526
-rw-r--r--meta-tizen-common-base/recipes-core/system-server/system-server_git.bb_old10
-rw-r--r--meta-tizen-common-base/recipes-extended/pam/pam.inc1
-rw-r--r--meta-tizen-common-base/recipes-security/buxton/buxton-extraconf.inc19
-rw-r--r--meta-tizen-common-base/recipes-security/buxton/buxton.inc5
15 files changed, 33 insertions, 829 deletions
diff --git a/meta-tizen-common-base/recipes-application-framework/capi-system-device/capi-system-device-extraconf.inc b/meta-tizen-common-base/recipes-application-framework/capi-system-device/capi-system-device-extraconf.inc
index 848cced5..8b137891 100644
--- a/meta-tizen-common-base/recipes-application-framework/capi-system-device/capi-system-device-extraconf.inc
+++ b/meta-tizen-common-base/recipes-application-framework/capi-system-device/capi-system-device-extraconf.inc
@@ -1 +1 @@
-SRC_URI += "file://0001-fix-uncatchedenum.patch"
+
diff --git a/meta-tizen-common-base/recipes-application-framework/capi-system-device/capi-system-device.inc b/meta-tizen-common-base/recipes-application-framework/capi-system-device/capi-system-device.inc
index 25fcef50..2423bda0 100644
--- a/meta-tizen-common-base/recipes-application-framework/capi-system-device/capi-system-device.inc
+++ b/meta-tizen-common-base/recipes-application-framework/capi-system-device/capi-system-device.inc
@@ -8,7 +8,7 @@ SRC_URI = ""
S = "${WORKDIR}/git"
-inherit manifest autotools-brokensep
+inherit manifest cmake
BBCLASSEXTEND = ""
PROVIDES = ""
@@ -73,7 +73,7 @@ do_compile() {
-DBUILD_SHARED_LIBS:BOOL=ON \
-DCMAKE_TOOLCHAIN_FILE=${WORKDIR}/toolchain.cmake \
${EXTRA_OECMAKE} . -DFULLVER=0.1.0 -DMAJORVER=${MAJORVER}
- oe_runmake -j1 ## ${PARALLEL_MAKE}
+ oe_runmake ${PARALLEL_MAKE}
diff --git a/meta-tizen-common-base/recipes-application-framework/capi-system-device/files/0001-fix-uncatchedenum.patch b/meta-tizen-common-base/recipes-application-framework/capi-system-device/files/0001-fix-uncatchedenum.patch
deleted file mode 100644
index 770822a9..00000000
--- a/meta-tizen-common-base/recipes-application-framework/capi-system-device/files/0001-fix-uncatchedenum.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 2cac1aa62f6983f12fc74a29bf72bfb528ceb798 Mon Sep 17 00:00:00 2001
-From: Xavier Roche <xavrock.os@gmail.com>
-Date: Fri, 20 Feb 2015 14:34:42 +0100
-Subject: [PATCH] fix uncatched enum
-
-Signed-off-by: Xavier Roche <xavrock.os@gmail.com>
----
- src/power.c | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/src/power.c b/src/power.c
-index 8fc1831..c5d9390 100644
---- a/src/power.c
-+++ b/src/power.c
-@@ -59,6 +59,14 @@
- #define STR_LCD_DIM "lcddim"
- #define STR_LCD_ON "lcdon"
-
-+typedef enum
-+{
-+ POWER_LOCK_CPU, /**< CPU lock */
-+ POWER_LOCK_DISPLAY, /**< Display normal lock */
-+ POWER_LOCK_DISPLAY_DIM, /**< Display dim lock */
-+} power_lock_e;
-+
-+
- static char *get_state_str(display_state_e state)
- {
- switch (state) {
---
-1.9.1
-
diff --git a/meta-tizen-common-base/recipes-application-framework/deviced/deviced.inc b/meta-tizen-common-base/recipes-application-framework/deviced/deviced.inc
index 497f5305..6ebe75bf 100644
--- a/meta-tizen-common-base/recipes-application-framework/deviced/deviced.inc
+++ b/meta-tizen-common-base/recipes-application-framework/deviced/deviced.inc
@@ -135,14 +135,21 @@ DEPENDS += "sensord"
DEPENDS += "vconf"
DEPENDS += "dbus-glib"
DEPENDS += "capi-base-common"
+DEPENDS += "openssl"
+DEPENDS += "smack"
+DEPENDS += "libprivilege-control"
do_prep() {
cd ${S}
chmod -Rf a+rX,u+w,g-w,o-w ${S}
#setup -q
-
-
+}
+
+
+do_configure() {
+
+ cd ${S}
cmake \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DCMAKE_INSTALL_PREFIX:PATH=${prefix} \
@@ -153,7 +160,6 @@ do_prep() {
-DSHARE_INSTALL_PREFIX:PATH=${prefix}/share \
-DCMAKE_SKIP_RPATH:BOOL=ON \
-DBUILD_SHARED_LIBS:BOOL=ON \
- -DCMAKE_TOOLCHAIN_FILE=${WORKDIR}/toolchain.cmake \
-DTZ_SYS_ETC=${sysconfdir} \
-DCMAKE_INSTALL_PREFIX=${prefix} \
-DARCH=emulator \
@@ -161,14 +167,6 @@ do_prep() {
${EXTRA_OECMAKE} .
#eol
-
-}
-
-do_patch_append() {
- bb.build.exec_func('do_prep', d)
-}
-
-do_configure() {
}
do_compile() {
diff --git a/meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton-extraconf.inc b/meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton-extraconf.inc
index e2112ad5..a2ada317 100644
--- a/meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton-extraconf.inc
+++ b/meta-tizen-common-base/recipes-application-framework/vconf-buxton/vconf-buxton-extraconf.inc
@@ -3,5 +3,5 @@ RDEPENDS_${PN}_remove_class-native = "systemd-native"
DEPENDS_vconf-buxton_remove_class-native = "systemd-native"
DEPENDS_class-native += "systemd-native"
-DEPENDS_class-native += "vconf-internal-keys"
+DEPENDS_class-native += "vconf-internal-keys-native"
DEPENDS_class-native += "buxton-native"
diff --git a/meta-tizen-common-base/recipes-application-framework/vconf/files/remove-dlog-for-native.patch b/meta-tizen-common-base/recipes-application-framework/vconf/files/remove-dlog-for-native.patch
deleted file mode 100644
index b714d451..00000000
--- a/meta-tizen-common-base/recipes-application-framework/vconf/files/remove-dlog-for-native.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 28d168d..9dd6e52 100755
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -17,7 +17,7 @@ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
-
- INCLUDE(FindPkgConfig)
- pkg_check_modules(glib_pkg REQUIRED gobject-2.0)
--pkg_check_modules(pkgs REQUIRED glib-2.0 dlog libtzplatform-config vconf-internal-keys)
-+pkg_check_modules(pkgs REQUIRED glib-2.0 libtzplatform-config vconf-internal-keys)
-
- FOREACH(flag ${pkgs_CFLAGS})
- SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
-diff --git a/include/vconf-log.h b/include/vconf-log.h
-index fa53102..f70d1e1 100755
---- a/include/vconf-log.h
-+++ b/include/vconf-log.h
-@@ -26,7 +26,6 @@
- #include <unistd.h>
- #include <stdlib.h>
-
--#define VCONF_DLOG_OUT
-
- /************** Error ***************/
- #ifdef VCONF_SYSLOG_OUT
diff --git a/meta-tizen-common-base/recipes-application-framework/vconf/vconf-extraconf.inc_old b/meta-tizen-common-base/recipes-application-framework/vconf/vconf-extraconf.inc_old
deleted file mode 100644
index 48f533fb..00000000
--- a/meta-tizen-common-base/recipes-application-framework/vconf/vconf-extraconf.inc_old
+++ /dev/null
@@ -1,25 +0,0 @@
-SRC_URI_append_class-native = " file://remove-dlog-for-native.patch"
-
-RDEPENDS_${PN}_remove_class-native = "glibc-native"
-RDEPENDS_${PN}_remove_class-native = "systemd-native"
-DEPENDS_remove_class-native = "dlog-native"
-
-DEPENDS_class-target += "glib-2.0"
-DEPENDS_class-target += "vconf-native"
-DEPENDS_class-target += "vconf-internal-keys"
-DEPENDS_class-target += "dlog"
-
-do_install_append_class-native() {
- sed -i "s@source /etc/tizen-platform.conf@source ${sysconfdir}/tizen-platform.conf@g" ${D}${prefix}/bin/vconf-init
-}
-
-pkg_postinst_${PN}() {
- #!/bin/sh -e
-
- [ "x\$D" == "x" ] && ldconfig
- [ "x\$D" == "x" ] && systemctl daemon-reload
- chsmack -a 'User' $D${prefix}/kdb
- chsmack -a 'User' $D${prefix}/kdb/db
- chsmack -a 'User' $D${prefix}/kdb/db/.backup
-
-} \ No newline at end of file
diff --git a/meta-tizen-common-base/recipes-application-framework/vconf/vconf.inc_old b/meta-tizen-common-base/recipes-application-framework/vconf/vconf.inc_old
deleted file mode 100644
index b24726da..00000000
--- a/meta-tizen-common-base/recipes-application-framework/vconf/vconf.inc_old
+++ /dev/null
@@ -1,181 +0,0 @@
-DESCRIPTION = "Configuration system library"
-HOMEPAGE = "http://nohomepage.org"
-SECTION = "System/Libraries"
-LICENSE = "Apache-2.0"
-PV = "0.2.51"
-
-SRC_URI = ""
-
-S = "${WORKDIR}/git"
-
-inherit manifest autotools-brokensep
-
-BBCLASSEXTEND = ""
-PROVIDES = ""
-
-#PROVIDES by vconf-keys-dev
-PROVIDES += "vconf-keys-dev"
-
-
-#PROVIDES by vconf
-
-
-#PROVIDES by vconf-dev
-PROVIDES += "vconf-dev"
-
-
-RDEPENDS = ""
-#RDEPENDS of vconf-keys-dev (${PN}-keys-dev)
-RDEPENDS_${PN}-keys-dev += "vconf"
-RDEPENDS_${PN}-keys-dev += "vconf-internal-keys-dev"
-
-#RDEPENDS of vconf (${PN})
-RDEPENDS_${PN} += "glibc"
-RDEPENDS_${PN} += "systemd"
-
-#RDEPENDS of vconf-dev (${PN}-dev)
-RDEPENDS_${PN}-dev += "vconf"
-RDEPENDS_${PN}-dev += "glib-2.0"
-
-
-DEPENDS = ""
-#DEPENDS of vconf
-inherit tizen_cmake
-DEPENDS += "vconf-internal-keys"
-DEPENDS += "tizen-platform-config"
-inherit pkgconfig
-DEPENDS += "dlog"
-DEPENDS += "glib-2.0"
-
-do_prep() {
- cd ${S}
- chmod -Rf a+rX,u+w,g-w,o-w ${S}
- #setup -q -n vconf-0.2.51
- cp ${S}/packaging/vconf.manifest .
-
-
-}
-do_patch_append() {
- bb.build.exec_func('do_prep', d)
-}
-
-do_configure() {
-}
-
-do_compile() {
- cd ${S}
- LANG=C
- export LANG
- unset DISPLAY
- LD_AS_NEEDED=1; export LD_AS_NEEDED ;
-
-
- cmake \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
- -DCMAKE_INSTALL_PREFIX:PATH=${prefix} \
- -DCMAKE_INSTALL_LIBDIR:PATH=${prefix}/lib \
- -DINCLUDE_INSTALL_DIR:PATH=${prefix}/include \
- -DLIB_INSTALL_DIR:PATH=${prefix}/lib \
- -DSYSCONF_INSTALL_DIR:PATH=${sysconfdir} \
- -DSHARE_INSTALL_PREFIX:PATH=${prefix}/share \
- -DCMAKE_SKIP_RPATH:BOOL=ON \
- -DBUILD_SHARED_LIBS:BOOL=ON \
- -DCMAKE_TOOLCHAIN_FILE=${WORKDIR}/toolchain.cmake \
- ${EXTRA_OECMAKE} . \
- -DTZ_SYS_CONFIG=${prefix}/kdb
-
- make ${PARALLEL_MAKE}
-
-
-
-}
-
-do_install() {
- export RPM_BUILD_ROOT=${D}
- cd ${S}
- LANG=C
- export LANG
- unset DISPLAY
- rm -rf ${D}
- mkdir -p ${D}
-
-
- oe_runmake \
- DESTDIR=${D} \
- INSTALL_ROOT=${D} \
- BINDIR=${prefix}/bin \
- install
- rm -f ${D}${infodir}/dir
- find ${D} -regex ".*\.la$" | xargs rm -f --
- find ${D} -regex ".*\.a$" | xargs rm -f --
- mkdir -p ${D}${prefix}/kdb/db
- mkdir -p ${D}${prefix}/kdb/db/.backup
- mkdir -p ${D}${systemd_unitdir}/system/basic.target.wants
- mkdir -p ${D}${prefix}/lib/tmpfiles.d
- install -m0644 ${S}/packaging/vconf-setup.service ${D}${systemd_unitdir}/system/
- install -m0644 ${S}/packaging/vconf-setup.conf ${D}${prefix}/lib/tmpfiles.d/
- ln -sf ../vconf-setup.service ${D}${systemd_unitdir}/system/basic.target.wants/
-
-
-}
-
-pkg_postinst_${PN}() {
- #!/bin/sh -e
-
- [ "x$D" == "x" ] && ldconfig
- systemctl daemon-reload
- chsmack -a 'User' $D${prefix}/kdb
- chsmack -a 'User' $D${prefix}/kdb/db
- chsmack -a 'User' $D${prefix}/kdb/db/.backup
-
-}
-
-pkg_postrm_${PN}() {
- #!/bin/sh -e
-
- [ "x$D" == "x" ] && ldconfig
- systemctl daemon-reload
-
-}
-
-PACKAGES = "${PN}-dbg ${PN}-doc ${PN}-locale"
-PACKAGES += " vconf-keys-dev "
-PACKAGES += " vconf "
-PACKAGES += " vconf-dev "
-
-vconf-keys-dev_files = ""
-vconf-keys-dev_files += "${prefix}/include/vconf/vconf-keys.h"
-MANIFESTFILES_${PN}-keys-dev = "vconf.manifest"
-
-vconf_files = ""
-vconf_files += "${sysconfdir}/preconf.d/vconf-setup"
-vconf_files += "${prefix}/bin/vconftool"
-vconf_files += "${prefix}/bin/vconf-init"
-vconf_files += "${prefix}/kdb/kdb_first_boot"
-vconf_files += "${prefix}/lib/*.so.*"
-vconf_files += "%attr(777,root,users) ${prefix}/kdb/db"
-vconf_files += "%attr(777,root,root) ${prefix}/kdb/db/.backup"
-vconf_files += "${systemd_unitdir}/system/basic.target.wants/vconf-setup.service"
-vconf_files += "${systemd_unitdir}/system/vconf-setup.service"
-vconf_files += "${prefix}/lib/tmpfiles.d/vconf-setup.conf"
-MANIFESTFILES_${PN} = "vconf.manifest"
-DIRFILES_${PN} = ""
-DIRFILES_${PN} += "%attr(777,root,users) ${prefix}/kdb/db"
-DIRFILES_${PN} += "%attr(777,root,root) ${prefix}/kdb/db/.backup"
-
-vconf-dev_files = ""
-vconf-dev_files += "${prefix}/include/vconf/vconf.h"
-vconf-dev_files += "${prefix}/lib/pkgconfig/*.pc"
-vconf-dev_files += "${prefix}/lib/*.so"
-MANIFESTFILES_${PN}-dev = "vconf.manifest"
-
-FILES_${PN}-keys-dev = "${vconf-keys-dev_files}"
-FILES_${PN} = "${vconf_files}"
-FILES_${PN}-dev = "${vconf-dev_files}"
-
-PKG_vconf-keys-dev= "vconf-keys-dev"
-PKG_vconf= "vconf"
-PKG_vconf-dev= "vconf-dev"
-
-require vconf-extraconf.inc
-
diff --git a/meta-tizen-common-base/recipes-application-framework/vconf/vconf_git.bb_old b/meta-tizen-common-base/recipes-application-framework/vconf/vconf_git.bb_old
deleted file mode 100644
index afac77fc..00000000
--- a/meta-tizen-common-base/recipes-application-framework/vconf/vconf_git.bb_old
+++ /dev/null
@@ -1,10 +0,0 @@
-require vconf.inc
-
-PRIORITY = "10"
-
-LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
-SRC_URI += "git://review.tizen.org/platform/core/appfw/vconf;tag=837474017fea13e4c2aa5126666947ff5caa578f;nobranch=1"
-
-BBCLASSEXTEND += " native "
-
diff --git a/meta-tizen-common-base/recipes-core/system-server/system-server-extraconf.inc_old b/meta-tizen-common-base/recipes-core/system-server/system-server-extraconf.inc_old
deleted file mode 100644
index e69de29b..00000000
--- a/meta-tizen-common-base/recipes-core/system-server/system-server-extraconf.inc_old
+++ /dev/null
diff --git a/meta-tizen-common-base/recipes-core/system-server/system-server.inc_old b/meta-tizen-common-base/recipes-core/system-server/system-server.inc_old
deleted file mode 100644
index 3c05136d..00000000
--- a/meta-tizen-common-base/recipes-core/system-server/system-server.inc_old
+++ /dev/null
@@ -1,526 +0,0 @@
-DESCRIPTION = "System server"
-HOMEPAGE = "http://nohomepage.org"
-SECTION = "System/Service"
-LICENSE = "Apache-2.0"
-PV = "2.0.0"
-
-SRC_URI = ""
-
-S = "${WORKDIR}/git"
-
-inherit manifest autotools-brokensep
-
-BBCLASSEXTEND = ""
-PROVIDES = ""
-
-#PROVIDES by libdevman-dev
-PROVIDES += "libdevman-dev"
-
-
-#PROVIDES by libdeviced-dev
-PROVIDES += "libdeviced-dev"
-
-
-#PROVIDES by libdeviced
-PROVIDES += "libdeviced"
-
-
-#PROVIDES by sysman-dev
-PROVIDES += "sysman-dev"
-
-
-#PROVIDES by libhaptic
-PROVIDES += "libhaptic"
-
-
-#PROVIDES by libslp-pm-dev
-PROVIDES += "libslp-pm-dev"
-
-
-#PROVIDES by libslp-pm
-PROVIDES += "libslp-pm"
-
-
-#PROVIDES by system-server
-
-
-#PROVIDES by sysman-internal-dev
-PROVIDES += "sysman-internal-dev"
-
-
-#PROVIDES by libhaptic-dev
-PROVIDES += "libhaptic-dev"
-
-
-#PROVIDES by libhaptic-plugin-dev
-PROVIDES += "libhaptic-plugin-dev"
-
-
-#PROVIDES by libdevman-haptic-dev
-PROVIDES += "libdevman-haptic-dev"
-
-
-#PROVIDES by sysman
-PROVIDES += "sysman"
-
-
-#PROVIDES by libdevman
-PROVIDES += "libdevman"
-
-
-RDEPENDS = ""
-#RDEPENDS of libdevman-dev (libdevman-dev)
-RDEPENDS_libdevman-dev += "libdevman"
-
-#RDEPENDS of libhaptic (libhaptic)
-RDEPENDS_libhaptic += "system-server"
-
-#RDEPENDS of system-server (${PN})
-RDEPENDS_${PN} += "systemd"
-RDEPENDS_${PN} += "vconf"
-
-#RDEPENDS of libdeviced (libdeviced)
-RDEPENDS_libdeviced += "system-server"
-
-#RDEPENDS of sysman-dev (sysman-dev)
-RDEPENDS_sysman-dev += "sysman"
-
-#RDEPENDS of libslp-pm-dev (libslp-pm-dev)
-RDEPENDS_libslp-pm-dev += "libslp-pm"
-
-#RDEPENDS of libslp-pm (libslp-pm)
-RDEPENDS_libslp-pm += "system-server"
-
-#RDEPENDS of libdeviced-dev (libdeviced-dev)
-RDEPENDS_libdeviced-dev += "libdeviced"
-
-#RDEPENDS of sysman-internal-dev (sysman-internal-dev)
-RDEPENDS_sysman-internal-dev += "sysman"
-
-#RDEPENDS of libhaptic-dev (libhaptic-dev)
-RDEPENDS_libhaptic-dev += "libhaptic"
-
-#RDEPENDS of libhaptic-plugin-dev (libhaptic-plugin-dev)
-RDEPENDS_libhaptic-plugin-dev += "libhaptic"
-
-#RDEPENDS of libdevman-haptic-dev (libdevman-haptic-dev)
-RDEPENDS_libdevman-haptic-dev += "libdevman-dev"
-
-#RDEPENDS of sysman (sysman)
-RDEPENDS_sysman += "system-server"
-
-#RDEPENDS of libdevman (libdevman)
-RDEPENDS_libdevman += "system-server"
-
-
-DEPENDS = ""
-#DEPENDS of system-server
-DEPENDS += "smack"
-DEPENDS += "edbus"
-inherit tizen_cmake
-DEPENDS += "attr"
-#Replace "DEPENDS" on gettext by "inherit gettext"
-inherit gettext
-DEPENDS += "notification"
-DEPENDS += "tizen-platform-config"
-DEPENDS += "syspopup"
-inherit pkgconfig
-DEPENDS += "libtapi"
-DEPENDS += "usbutils"
-DEPENDS += "libdevice-node"
-DEPENDS += "systemd"
-DEPENDS += "dlog"
-DEPENDS += "heynoti"
-DEPENDS += "ecore"
-DEPENDS_append_class-native = " fdupes-native"
-DEPENDS_append_class-target = " fdupes-native"
-DEPENDS += "sensord"
-DEPENDS += "vconf"
-DEPENDS += "capi-base-common"
-
-do_prep() {
- cd ${S}
- chmod -Rf a+rX,u+w,g-w,o-w ${S}
- #setup -q
- cp ${S}/packaging/system-server.manifest .
- cp ${S}/packaging/deviced.manifest .
- cp ${S}/packaging/sysman.manifest .
- cp ${S}/packaging/libslp-pm.manifest .
- cp ${S}/packaging/haptic.manifest .
- cp ${S}/packaging/devman.manifest .
-
-
-}
-do_patch_append() {
- bb.build.exec_func('do_prep', d)
-}
-
-do_configure() {
-}
-
-do_compile() {
- cd ${S}
- LANG=C
- export LANG
- unset DISPLAY
- LD_AS_NEEDED=1; export LD_AS_NEEDED ;
-
-
- cmake \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
- -DCMAKE_INSTALL_PREFIX:PATH=${prefix} \
- -DCMAKE_INSTALL_LIBDIR:PATH=${prefix}/lib \
- -DINCLUDE_INSTALL_DIR:PATH=${prefix}/include \
- -DLIB_INSTALL_DIR:PATH=${prefix}/lib \
- -DSYSCONF_INSTALL_DIR:PATH=${sysconfdir} \
- -DSHARE_INSTALL_PREFIX:PATH=${prefix}/share \
- -DCMAKE_SKIP_RPATH:BOOL=ON \
- -DBUILD_SHARED_LIBS:BOOL=ON \
- -DCMAKE_TOOLCHAIN_FILE=${WORKDIR}/toolchain.cmake \
- ${EXTRA_OECMAKE} . \
- -DTZ_SYS_ETC=${sysconfdir} \
- -DSYSTEMD_DIR=${systemd_unitdir}/system
-
-
-
-}
-
-do_install() {
- export RPM_BUILD_ROOT=${D}
- cd ${S}
- LANG=C
- export LANG
- unset DISPLAY
- rm -rf ${D}
- mkdir -p ${D}
-
-
- oe_runmake \
- DESTDIR=${D} \
- INSTALL_ROOT=${D} \
- BINDIR=${prefix}/bin \
- install
- rm -f ${D}${infodir}/dir
- find ${D} -regex ".*\.la$" | xargs rm -f --
- find ${D} -regex ".*\.a$" | xargs rm -f --
-
-
- mkdir -p ${D}/${systemd_unitdir}/system/multi-user.target.wants
- ln -s ../system-server.service ${D}/${systemd_unitdir}/system/multi-user.target.wants/system-server.service
-
- mkdir -p ${D}/${systemd_unitdir}/system/sockets.target.wants
- ln -s ../system-server.socket ${D}/${systemd_unitdir}/system/sockets.target.wants/system-server.socket
-
-
- mkdir -p ${D}/${systemd_unitdir}/system/graphical.target.wants
- ln -s ../regpmon.service ${D}/${systemd_unitdir}/system/graphical.target.wants/regpmon.service
- install -m 0644 ${S}/packaging/regpmon.service ${D}${systemd_unitdir}/system/regpmon.service
-
-
- mkdir -p ${D}/${systemd_unitdir}/system/graphical.target.wants
- ln -s ../zbooting-done.service ${D}/${systemd_unitdir}/system/graphical.target.wants/zbooting-done.service
- install -m 0644 ${S}/packaging/zbooting-done.service ${D}${systemd_unitdir}/system/zbooting-done.service
-
-
- #fdupes ${D}
-
-
-
-}
-
-pkg_postinst_${PN}() {
- #!/bin/sh -e
-
- #memory type vconf key init
- users_gid=$(getent group $TZ_SYS_USER_GROUP | cut -f3 -d':')
- vconftool set -t int memory/sysman/usbhost_status -1 -i
- vconftool set -t int memory/sysman/mmc 0 -i
- vconftool set -t int memory/sysman/earjack_key 0 -i
- vconftool set -t int memory/sysman/added_usb_storage 0 -i
- vconftool set -t int memory/sysman/removed_usb_storage 0 -i
- vconftool set -t int memory/sysman/charger_status -1 -i
- vconftool set -t int memory/sysman/charge_now -1 -i
- vconftool set -t int memory/sysman/battery_status_low -1 -i
- vconftool set -t int memory/sysman/battery_capacity -1 -i
- vconftool set -t int memory/sysman/usb_status -1 -i
- vconftool set -t int memory/sysman/earjack -1 -i
- vconftool set -t int memory/sysman/low_memory 1 -i
- vconftool set -t int memory/sysman/sliding_keyboard -1 -i
- vconftool set -t int memory/sysman/mmc_mount -1 -i
- vconftool set -t int memory/sysman/mmc_unmount -1 -i
- vconftool set -t int memory/sysman/mmc_format -1 -i
- vconftool set -t int memory/sysman/mmc_format_progress 0 -i
- vconftool set -t int memory/sysman/mmc_err_status 0 -i
- vconftool set -t int memory/sysman/power_off 0 -g $users_gid -i -f
- vconftool set -t int memory/sysman/battery_level_status -1 -i
- vconftool set -t string memory/private/sysman/added_storage_uevent "" -i
- vconftool set -t string memory/private/sysman/removed_storage_uevent "" -g $users_gid -i
- vconftool set -t int memory/sysman/hdmi 0 -i
- vconftool set -t int memory/sysman/stime_changed 0 -i
- #db type vconf key init
- vconftool set -t int db/sysman/mmc_dev_changed 0 -i
- vconftool set -t int memory/pm/state 0 -i -g $users_gid
- vconftool set -t int memory/pm/battery_timetofull -1 -i
- vconftool set -t int memory/pm/battery_timetoempty -1 -i
- vconftool set -t int memory/pm/sip_status 0 -i -g $users_gid
- vconftool set -t int memory/pm/custom_brightness_status 0 -i -g $users_gid
- vconftool set -t bool memory/pm/brt_changed_lpm 0 -i
- vconftool set -t int memory/pm/current_brt 60 -i -g $users_gid
- heynotitool set system_wakeup
- heynotitool set pm_event
- heynotitool set power_off_start
- heynotitool set mmcblk_add
- heynotitool set mmcblk_remove
- heynotitool set device_charge_chgdet
- heynotitool set device_usb_host_add
- heynotitool set device_usb_host_remove
- heynotitool set device_pci_keyboard_add
- heynotitool set device_pci_keyboard_remove
- heynotitool set device_usb_chgdet
- heynotitool set device_ta_chgdet
- heynotitool set device_earjack_chgdet
- heynotitool set device_earkey_chgdet
- heynotitool set device_tvout_chgdet
- heynotitool set device_hdmi_chgdet
- heynotitool set device_keyboard_chgdet
- systemctl daemon-reload
- if [ "$1" = "1" ]; then
- systemctl restart system-server.service
- systemctl restart regpmon.service
- systemctl restart zbooting-done.service
- fi
- [ "x$D" == "x" ] && ldconfig
-
-}
-
-pkg_postinst_libslp-pm() {
- #!/bin/sh -e
-
- [ "x$D" == "x" ] && ldconfig
-}
-
-pkg_postinst_libhaptic() {
- #!/bin/sh -e
-
- [ "x$D" == "x" ] && ldconfig
-}
-
-pkg_postinst_sysman() {
- #!/bin/sh -e
-
- [ "x$D" == "x" ] && ldconfig
-}
-
-pkg_postinst_libdevman() {
- #!/bin/sh -e
-
- [ "x$D" == "x" ] && ldconfig
-}
-
-pkg_postinst_libdeviced() {
- #!/bin/sh -e
-
- [ "x$D" == "x" ] && ldconfig
-}
-
-pkg_prerm_${PN}() {
- #!/bin/sh -e
-
- if [ "$1" = "0" ]; then
- systemctl stop system-server.service
- systemctl stop regpmon.service
- systemctl stop zbooting-done.service
- fi
-
-}
-
-pkg_postrm_libhaptic() {
- #!/bin/sh -e
-
- [ "x$D" == "x" ] && ldconfig
-}
-
-pkg_postrm_${PN}() {
- #!/bin/sh -e
-
- systemctl daemon-reload
- [ "x$D" == "x" ] && ldconfig
-
-}
-
-pkg_postrm_libslp-pm() {
- #!/bin/sh -e
-
- [ "x$D" == "x" ] && ldconfig
-}
-
-pkg_postrm_libdeviced() {
- #!/bin/sh -e
-
- [ "x$D" == "x" ] && ldconfig
-}
-
-pkg_postrm_libdevman() {
- #!/bin/sh -e
-
- [ "x$D" == "x" ] && ldconfig
-}
-
-pkg_postrm_sysman() {
- #!/bin/sh -e
-
- [ "x$D" == "x" ] && ldconfig
-}
-
-PACKAGES = "${PN}-dbg ${PN}-doc ${PN}-locale"
-PACKAGES += " libdevman-dev "
-PACKAGES += " libhaptic "
-PACKAGES += " sysman-dev "
-PACKAGES += " libdeviced-dev "
-PACKAGES += " libslp-pm-dev "
-PACKAGES += " libdevman "
-PACKAGES += " libslp-pm "
-PACKAGES += " system-server "
-PACKAGES += " sysman-internal-dev "
-PACKAGES += " libhaptic-dev "
-PACKAGES += " libhaptic-plugin-dev "
-PACKAGES += " libdevman-haptic-dev "
-PACKAGES += " libdeviced "
-PACKAGES += " sysman "
-
-libdevman-dev_files = ""
-libdevman-dev_files += "${prefix}/include/devman/devman.h"
-libdevman-dev_files += "${prefix}/include/devman/devman_image.h"
-libdevman-dev_files += "${prefix}/include/devman/devman_managed.h"
-libdevman-dev_files += "${prefix}/include/devman/devman_haptic.h"
-libdevman-dev_files += "${prefix}/include/devman/devman_PG.h"
-libdevman-dev_files += "${prefix}/lib/pkgconfig/devman.pc"
-libdevman-dev_files += "${prefix}/lib/libdevman.so"
-
-libhaptic_files = ""
-libhaptic_files += "${prefix}/lib/libhaptic.so.*"
-MANIFESTFILES_libhaptic = "haptic.manifest"
-
-sysman-dev_files = ""
-sysman-dev_files += "${prefix}/include/sysman/sysman.h"
-sysman-dev_files += "${prefix}/include/sysman/sysman_managed.h"
-sysman-dev_files += "${prefix}/include/sysman/sysman_PG.h"
-sysman-dev_files += "${prefix}/lib/pkgconfig/sysman.pc"
-sysman-dev_files += "${prefix}/lib/libsysman.so"
-
-libdeviced-dev_files = ""
-libdeviced-dev_files += "${prefix}/include/deviced/dd-battery.h"
-libdeviced-dev_files += "${prefix}/include/deviced/dd-control.h"
-libdeviced-dev_files += "${prefix}/include/deviced/dd-deviced.h"
-libdeviced-dev_files += "${prefix}/include/deviced/dd-deviced-managed.h"
-libdeviced-dev_files += "${prefix}/include/deviced/dd-display.h"
-libdeviced-dev_files += "${prefix}/include/deviced/dd-haptic.h"
-libdeviced-dev_files += "${prefix}/include/deviced/dd-led.h"
-libdeviced-dev_files += "${prefix}/include/deviced/haptic-module.h"
-libdeviced-dev_files += "${prefix}/include/deviced/haptic-plugin-intf.h"
-libdeviced-dev_files += "${prefix}/lib/libdeviced.so"
-libdeviced-dev_files += "${prefix}/lib/pkgconfig/deviced.pc"
-
-libslp-pm-dev_files = ""
-libslp-pm-dev_files += "${prefix}/include/pmapi/pmapi.h"
-libslp-pm-dev_files += "${prefix}/include/pmapi/pmapi_managed.h"
-libslp-pm-dev_files += "${prefix}/include/pmapi/pm_PG.h"
-libslp-pm-dev_files += "${prefix}/lib/pkgconfig/pmapi.pc"
-libslp-pm-dev_files += "${prefix}/lib/libpmapi.so"
-
-libdevman_files = ""
-libdevman_files += "${prefix}/bin/display_wd"
-libdevman_files += "${prefix}/lib/libdevman.so.*"
-MANIFESTFILES_libdevman = "devman.manifest"
-
-libslp-pm_files = ""
-libslp-pm_files += "${prefix}/lib/libpmapi.so.*"
-MANIFESTFILES_libslp-pm = "libslp-pm.manifest"
-
-system-server_files = ""
-system-server_files += "${sysconfdir}/dbus-1/system.d/deviced.conf"
-system-server_files += "${prefix}/bin/system_server"
-system-server_files += "${prefix}/lib/system-server/shutdown.sh"
-system-server_files += "${prefix}/bin/restart"
-system-server_files += "${prefix}/bin/movi_format.sh"
-system-server_files += "${prefix}/bin/sys_event"
-system-server_files += "${prefix}/bin/pm_event"
-system-server_files += "${prefix}/bin/regpmon"
-system-server_files += "${prefix}/bin/set_pmon"
-system-server_files += "${prefix}/bin/sys_pci_noti"
-system-server_files += "${prefix}/bin/mmc-smack-label"
-system-server_files += "${prefix}/bin/device-daemon"
-system-server_files += "${prefix}/bin/fsck_msdosfs"
-system-server_files += "${systemd_unitdir}/system/multi-user.target.wants/system-server.service"
-system-server_files += "${systemd_unitdir}/system/graphical.target.wants/regpmon.service"
-system-server_files += "${systemd_unitdir}/system/sockets.target.wants/system-server.socket"
-system-server_files += "${systemd_unitdir}/system/system-server.service"
-system-server_files += "${systemd_unitdir}/system/system-server.socket"
-system-server_files += "${systemd_unitdir}/system/regpmon.service"
-system-server_files += "${systemd_unitdir}/system/graphical.target.wants/zbooting-done.service"
-system-server_files += "${systemd_unitdir}/system/zbooting-done.service"
-system-server_files += "${prefix}/share/system-server/sys_pci_noti/res/locale/*/LC_MESSAGES/*.mo"
-system-server_files += "${prefix}/share/license/fsck_msdosfs"
-CONFFILES_${PN} = ""
-CONFFILES_${PN} += "${sysconfdir}/dbus-1/system.d/deviced.conf"
-MANIFESTFILES_${PN} = "system-server.manifest"
-
-sysman-internal-dev_files = ""
-sysman-internal-dev_files += "${prefix}/include/sysman/sysman-internal.h"
-
-libhaptic-dev_files = ""
-libhaptic-dev_files += "${prefix}/include/haptic/haptic.h"
-libhaptic-dev_files += "${prefix}/lib/libhaptic.so"
-libhaptic-dev_files += "${prefix}/lib/pkgconfig/haptic.pc"
-
-libhaptic-plugin-dev_files = ""
-libhaptic-plugin-dev_files += "${prefix}/include/haptic/haptic_module.h"
-libhaptic-plugin-dev_files += "${prefix}/include/haptic/haptic_plugin_intf.h"
-libhaptic-plugin-dev_files += "${prefix}/include/haptic/haptic_PG.h"
-libhaptic-plugin-dev_files += "${prefix}/lib/pkgconfig/haptic-plugin.pc"
-
-libdevman-haptic-dev_files = ""
-libdevman-haptic-dev_files += "${prefix}/include/devman/devman_haptic_ext.h"
-libdevman-haptic-dev_files += "${prefix}/include/devman/devman_haptic_ext_core.h"
-libdevman-haptic-dev_files += "${prefix}/lib/pkgconfig/devman_haptic.pc"
-
-libdeviced_files = ""
-libdeviced_files += "${prefix}/lib/libdeviced.so.*"
-MANIFESTFILES_libdeviced = "deviced.manifest"
-
-sysman_files = ""
-sysman_files += "${prefix}/lib/libsysman.so.*"
-MANIFESTFILES_sysman = "sysman.manifest"
-
-FILES_libdevman-dev = "${libdevman-dev_files}"
-FILES_libhaptic = "${libhaptic_files}"
-FILES_sysman-dev = "${sysman-dev_files}"
-FILES_libdeviced-dev = "${libdeviced-dev_files}"
-FILES_libslp-pm-dev = "${libslp-pm-dev_files}"
-FILES_libdevman = "${libdevman_files}"
-FILES_libslp-pm = "${libslp-pm_files}"
-FILES_${PN} = "${system-server_files}"
-FILES_sysman-internal-dev = "${sysman-internal-dev_files}"
-FILES_libhaptic-dev = "${libhaptic-dev_files}"
-FILES_libhaptic-plugin-dev = "${libhaptic-plugin-dev_files}"
-FILES_libdevman-haptic-dev = "${libdevman-haptic-dev_files}"
-FILES_libdeviced = "${libdeviced_files}"
-FILES_sysman = "${sysman_files}"
-
-PKG_libdevman-dev= "libdevman-dev"
-PKG_libhaptic= "libhaptic"
-PKG_sysman-dev= "sysman-dev"
-PKG_libdeviced-dev= "libdeviced-dev"
-PKG_libslp-pm-dev= "libslp-pm-dev"
-PKG_libdevman= "libdevman"
-PKG_libslp-pm= "libslp-pm"
-PKG_system-server= "system-server"
-PKG_sysman-internal-dev= "sysman-internal-dev"
-PKG_libhaptic-dev= "libhaptic-dev"
-PKG_libhaptic-plugin-dev= "libhaptic-plugin-dev"
-PKG_libdevman-haptic-dev= "libdevman-haptic-dev"
-PKG_libdeviced= "libdeviced"
-PKG_sysman= "sysman"
-
-require system-server-extraconf.inc
-
diff --git a/meta-tizen-common-base/recipes-core/system-server/system-server_git.bb_old b/meta-tizen-common-base/recipes-core/system-server/system-server_git.bb_old
deleted file mode 100644
index fc3c3e7d..00000000
--- a/meta-tizen-common-base/recipes-core/system-server/system-server_git.bb_old
+++ /dev/null
@@ -1,10 +0,0 @@
-require system-server.inc
-
-PRIORITY = "10"
-
-LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
-SRC_URI += "git://review.tizen.org/platform/core/system/system-server;tag=9c78025072cb67f27da99d22bac34afb01ea0a23;nobranch=1"
-
-BBCLASSEXTEND += " native "
-
diff --git a/meta-tizen-common-base/recipes-extended/pam/pam.inc b/meta-tizen-common-base/recipes-extended/pam/pam.inc
index 2e6625b9..5cb68af0 100644
--- a/meta-tizen-common-base/recipes-extended/pam/pam.inc
+++ b/meta-tizen-common-base/recipes-extended/pam/pam.inc
@@ -53,6 +53,7 @@ DEPENDS_append_class-target = " automake-native"
DEPENDS += "smack"
DEPENDS_append_class-native = " libtool"
DEPENDS_append_class-target = " libtool-cross"
+DEPENDS_append_class-target = " flex"
DEPENDS += "net-tools"
DEPENDS_append_class-native = " bison-native"
DEPENDS_append_class-target = " bison-native"
diff --git a/meta-tizen-common-base/recipes-security/buxton/buxton-extraconf.inc b/meta-tizen-common-base/recipes-security/buxton/buxton-extraconf.inc
index d293a6f6..48266995 100644
--- a/meta-tizen-common-base/recipes-security/buxton/buxton-extraconf.inc
+++ b/meta-tizen-common-base/recipes-security/buxton/buxton-extraconf.inc
@@ -1,2 +1,21 @@
SRC_URI_class-native += "file://0001-remove-buxtondgeneration.patch"
+
+DEPENDS_class-native = ""
+DEPENDS_class-native += "systemd-native "
+DEPENDS_class-native += "libcheck-native"
+DEPENDS_class-native += "attr-native"
+DEPENDS_class-native += "gdbm-native"
+
+RDEPENDS_${PN}_class-native = ""
+RDEPENDS_${PN}_class-native += "coreutils"
+RDEPENDS_${PN}_class-native += "smack"
+
+do_prep_class-native() {
+ cd ${S}
+ chmod -Rf a+rX,u+w,g-w,o-w ${S}
+ #setup -q
+ cp ${S}/packaging/buxton.manifest .
+
+
+}
diff --git a/meta-tizen-common-base/recipes-security/buxton/buxton.inc b/meta-tizen-common-base/recipes-security/buxton/buxton.inc
index 3d1338d6..a72aded6 100644
--- a/meta-tizen-common-base/recipes-security/buxton/buxton.inc
+++ b/meta-tizen-common-base/recipes-security/buxton/buxton.inc
@@ -56,11 +56,6 @@ DEPENDS += "systemd"
DEPENDS += "attr"
DEPENDS += "gdbm"
-DEPENDS_class-native = ""
-DEPENDS_class-native += "systemd-native "
-DEPENDS_class-native += "libcheck-native"
-DEPENDS_class-native += "attr-native"
-DEPENDS_class-native += "gdbm-native"
do_prep() {
cd ${S}