summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonan Le Martret <ronan@fridu.net>2014-07-17 17:51:58 +0200
committerRonan Le Martret <ronan@fridu.net>2014-07-17 17:51:58 +0200
commit6988f99c5af30892fff08d9b30420a4b6d0d4204 (patch)
treeff7c7a9daaefcd0b5205f1e169ff8cea7217fce7
parent2bf52332f83f532e566e7c546a2cedf71d607cb5 (diff)
downloadmeta-tizen-6988f99c5af30892fff08d9b30420a4b6d0d4204.tar.gz
meta-tizen-6988f99c5af30892fff08d9b30420a4b6d0d4204.tar.bz2
meta-tizen-6988f99c5af30892fff08d9b30420a4b6d0d4204.zip
Add gallium support.
Change-Id: I65f464a9c2ad7ea34a3a617bf10fb42eadc3a8e4 Signed-off-by: Ronan Le Martret <ronan@fridu.net>
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend4
-rw-r--r--recipes-image/images/tizen-common-core-image-crosswalk-dev.bb2
-rw-r--r--recipes-image/images/tizen-common-core-image-minimal.bb15
3 files changed, 20 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 2e2121cd..93096f7b 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,4 +1,6 @@
PACKAGECONFIG_append = " gallium"
PACKAGECONFIG_append = " gallium-egl"
PACKAGECONFIG_append = " gallium-gbm"
-PACKAGECONFIG_append = " gallium-llvm" \ No newline at end of file
+PACKAGECONFIG_append = " gallium-llvm"
+
+GALLIUMDRIVERS_append = ",i915" \ No newline at end of file
diff --git a/recipes-image/images/tizen-common-core-image-crosswalk-dev.bb b/recipes-image/images/tizen-common-core-image-crosswalk-dev.bb
index b1ad8745..9f02c31d 100644
--- a/recipes-image/images/tizen-common-core-image-crosswalk-dev.bb
+++ b/recipes-image/images/tizen-common-core-image-crosswalk-dev.bb
@@ -14,3 +14,5 @@ CORE_IMAGE_EXTRA_INSTALL += "ldd"
CORE_IMAGE_EXTRA_INSTALL += "libcap"
CORE_IMAGE_EXTRA_INSTALL += "sudo"
CORE_IMAGE_EXTRA_INSTALL += "connman-client"
+CORE_IMAGE_EXTRA_INSTALL += "git"
+CORE_IMAGE_EXTRA_INSTALL += "python-json" \ No newline at end of file
diff --git a/recipes-image/images/tizen-common-core-image-minimal.bb b/recipes-image/images/tizen-common-core-image-minimal.bb
index ce3bdffb..94200748 100644
--- a/recipes-image/images/tizen-common-core-image-minimal.bb
+++ b/recipes-image/images/tizen-common-core-image-minimal.bb
@@ -16,7 +16,19 @@ DEPENDS += " tar-replacement-native "
CORE_IMAGE_BASE_INSTALL += "connman"
CORE_IMAGE_BASE_INSTALL += "weston-common"
+
CORE_IMAGE_BASE_INSTALL += "mesa-megadriver"
+CORE_IMAGE_BASE_INSTALL += "libegl-gallium"
+CORE_IMAGE_BASE_INSTALL += "libegl-mesa"
+CORE_IMAGE_BASE_INSTALL += "libgbm"
+CORE_IMAGE_BASE_INSTALL += "libgbm-gallium"
+CORE_IMAGE_BASE_INSTALL += "mesa-driver-pipe-nouveau"
+CORE_IMAGE_BASE_INSTALL += "mesa-driver-pipe-swrast"
+CORE_IMAGE_BASE_INSTALL += "mesa-driver-pipe-vmwgfx"
+CORE_IMAGE_BASE_INSTALL += "mesa-driver-pipe-i915"
+CORE_IMAGE_BASE_INSTALL += "libgles1-mesa"
+CORE_IMAGE_BASE_INSTALL += "libgles2-mesa"
+
CORE_IMAGE_BASE_INSTALL += "meta-common"
CORE_IMAGE_BASE_INSTALL += "pam"
CORE_IMAGE_BASE_INSTALL += "weston-common-tz-launcher"
@@ -29,5 +41,8 @@ CORE_IMAGE_BASE_INSTALL += "config-image"
CORE_IMAGE_BASE_INSTALL += "kernel-modules"
CORE_IMAGE_BASE_INSTALL += "less"
CORE_IMAGE_BASE_INSTALL += "bash"
+CORE_IMAGE_BASE_INSTALL += "psmisc"
+CORE_IMAGE_BASE_INSTALL += "coreutils"
+CORE_IMAGE_BASE_INSTALL += "procps"
export SYSROOT = "${IMAGE_ROOTFS}"