summaryrefslogtreecommitdiff
path: root/systemd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'systemd/CMakeLists.txt')
-rw-r--r--systemd/CMakeLists.txt17
1 files changed, 13 insertions, 4 deletions
diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
index 982fe1d..0b25467 100644
--- a/systemd/CMakeLists.txt
+++ b/systemd/CMakeLists.txt
@@ -1,4 +1,13 @@
-INSTALL(FILES
- ${PROJECT_SOURCE_DIR}/systemd/cert-checker.service
- DESTINATION
- ${SYSTEMD_UNIT_DIR})
+CONFIGURE_FILE(
+ ${SERVICE_NAME}.socket.in
+ ${SERVICE_NAME}.socket @ONLY)
+CONFIGURE_FILE(
+ ${SERVICE_NAME}.service.in
+ ${SERVICE_NAME}.service @ONLY)
+
+INSTALL(
+ FILES
+ ${SERVICE_NAME}.socket
+ ${SERVICE_NAME}.service
+ DESTINATION
+ ${SYSTEMD_UNIT_DIR})