summaryrefslogtreecommitdiff
path: root/src/ui/popup-bin/CMakeLists.txt
diff options
context:
space:
mode:
authorsangwan.kwon <sangwan.kwon@samsung.com>2016-07-18 09:35:50 +0900
committersangwan.kwon <sangwan.kwon@samsung.com>2016-07-22 14:59:37 +0900
commit99659ec45d64234927b2fca33ad58e0648e573ca (patch)
tree22fcd8780573c887ec626e2f610515242c42098e /src/ui/popup-bin/CMakeLists.txt
parentf744139cf01c9f6bc19968cd728965fb874c194a (diff)
downloadcert-checker-99659ec45d64234927b2fca33ad58e0648e573ca.tar.gz
cert-checker-99659ec45d64234927b2fca33ad58e0648e573ca.tar.bz2
cert-checker-99659ec45d64234927b2fca33ad58e0648e573ca.zip
Replace popup architecture to systemd service
[AS-IS] * popup used to pipe for IPC [TO-BE] * use to systemd service Change-Id: Ie203c8a4dbcb071fd3896e0c7af1bb8cd7280dbf Signed-off-by: sangwan.kwon <sangwan.kwon@samsung.com>
Diffstat (limited to 'src/ui/popup-bin/CMakeLists.txt')
-rw-r--r--src/ui/popup-bin/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/ui/popup-bin/CMakeLists.txt b/src/ui/popup-bin/CMakeLists.txt
index a9e7e14..6d434ae 100644
--- a/src/ui/popup-bin/CMakeLists.txt
+++ b/src/ui/popup-bin/CMakeLists.txt
@@ -22,13 +22,15 @@
PKG_CHECK_MODULES(CERT_CHECKER_POPUP_DEP
elementary
libtzplatform-config
+ capi-appfw-application
REQUIRED)
set(CERT_CHECKER_POPUP_SRC_DIR ${PROJECT_SOURCE_DIR}/src/ui/popup-bin)
set(CERT_CHECKER_POPUP_SOURCES
+ ${CERT_CHECKER_POPUP_SRC_DIR}/main.cpp
${CERT_CHECKER_POPUP_SRC_DIR}/popup.cpp
- ${CERT_CHECKER_UI_PATH}/popup-runner.cpp
+ ${CERT_CHECKER_POPUP_SRC_DIR}/popup-service.cpp
${CERT_CHECKER_SERVICE_PATH}/app.cpp
# dpl
${DPL_CORE_SRC_PATH}/assert.cpp