summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJanusz Kozerski <j.kozerski@samsung.com>2015-09-25 14:47:34 +0200
committerJanusz Kozerski <j.kozerski@samsung.com>2015-11-10 11:43:34 +0100
commit473de0fb27052aff62e4b391feb1b6447f83ec41 (patch)
treed8e7ddf77eb3e3424394fd0529b004a77dfd6b77 /CMakeLists.txt
parent7871c1f106e6c11503b4a2a6f7bbbd876d2ec1fc (diff)
downloadcert-checker-473de0fb27052aff62e4b391feb1b6447f83ec41.tar.gz
cert-checker-473de0fb27052aff62e4b391feb1b6447f83ec41.tar.bz2
cert-checker-473de0fb27052aff62e4b391feb1b6447f83ec41.zip
Add popup
Since Notification framework doesn't support system daemons, the cert-checker's internal popup should be provided. Add implementation of popup binary - /usr/bin/cert-checker-popup Cert-checker forks(), execs a popup binary, waits for popup termination, and then reads user response from pipe. Change-Id: Ie2e70f661feb1f262841d59a1b4c6a7ec49901f9
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6cbbc23..0f6baa2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,6 +59,8 @@ ENDIF (CMAKE_BUILD_TYPE MATCHES "DEBUG")
ADD_DEFINITIONS("-DPOPUP=1")
SET(TARGET_CERT_CHECKER "cert-checker")
+SET(TARGET_CERT_CHECKER_POPUP "cert-checker-popup")
+# Tests
SET(TARGET_CERT_CHECKER_TESTS "cert-checker-tests")
SET(TARGET_CERT_CHECKER_TESTS_LOGIC "cert-checker-tests-logic")
SET(TARGET_CERT_CHECKER_POPUP_TEST "cert-checker-popup-test")