summaryrefslogtreecommitdiff
path: root/packaging/python-netifaces.spec
diff options
context:
space:
mode:
authorJimmy Huang <jimmy.huang@linux.intel.com>2012-08-31 15:13:35 -0700
committerJimmy Huang <jimmy.huang@linux.intel.com>2012-08-31 15:13:35 -0700
commitcea9952198fadf9c92b9ce483a34b0dfbc426239 (patch)
treeb95bc67b9584fda652aa2f8c4353701bf5c3453e /packaging/python-netifaces.spec
downloadpython-netifaces-1.0.tar.gz
python-netifaces-1.0.tar.bz2
python-netifaces-1.0.zip
Signed-off-by: Jimmy Huang <jimmy.huang@linux.intel.com>
Diffstat (limited to 'packaging/python-netifaces.spec')
-rw-r--r--packaging/python-netifaces.spec37
1 files changed, 37 insertions, 0 deletions
diff --git a/packaging/python-netifaces.spec b/packaging/python-netifaces.spec
new file mode 100644
index 0000000..5caa207
--- /dev/null
+++ b/packaging/python-netifaces.spec
@@ -0,0 +1,37 @@
+Name: python-netifaces
+Version: 0.6
+Release: 1
+Group: System/Libraries
+License: MIT
+Url: http://alastairs-place.net/netifaces/
+Summary: Portable network interface information
+Source: http://alastairs-place.net/projects/netifaces/netifaces-%{version}.tar.gz
+BuildRequires: pkgconfig(python)
+BuildRequires: python-setuptools
+
+%description
+netifaces provides a (hopefully portable-ish) way for Python programmers to
+get access to a list of the network interfaces on the local machine, and to
+obtain the addresses of those network interfaces.
+
+The package has been tested on Mac OS X, Windows XP, Windows Vista, Linux and
+Solaris. On Windows, it is currently not able to retrieve IPv6 addresses,
+owing to shortcomings of the Windows API.
+
+It should work on other UNIX-like systems provided they implement either
+getifaddrs() or support the SIOCGIFxxx socket options, although the data
+provided by the socket options is normally less complete.
+
+%prep
+%setup -q -n netifaces-%{version}
+
+%build
+python setup.py build
+
+%install
+python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+
+%files
+%defattr(-,root,root,-)
+%doc README
+%{python_sitearch}/*