summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 28 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 22f236b..31cb70d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,14 +4,41 @@ ACLOCAL_AMFLAGS = -I m4
# also --enable-dbus-type=session here
AM_DISTCHECK_CONFIGURE_FLAGS = \
--enable-debug \
+ --enable-gtk-doc \
--enable-distcheck
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = gsignond.pc
-SUBDIRS = src test
+dist_sysconf_DATA = gsignond.conf
+
+SUBDIRS = src test docs
EXTRA_DIST = dists tools
valgrind:
cd test; make valgrind
+
+dist-hook:
+ @echo
+ @echo "==== Run 'make update-online-doc' to update online documentation ===="
+ @echo
+
+update-online-doc:
+ @tar zxf $(PACKAGE)-$(VERSION).tar.gz && \
+ pushd . > /dev/null && \
+ cd .. && \
+ git clone https://code.google.com/p/accounts-sso.gsignon-docs/ ; \
+ cd accounts-sso.gsignon-docs && \
+ git pull ; \
+ mkdir -p $(PACKAGE) && \
+ rm -rf $(PACKAGE)/* && \
+ popd > /dev/null && \
+ cp -rf $(PACKAGE)-$(VERSION)/docs/html/* ../accounts-sso.gsignon-docs/$(PACKAGE)/ && \
+ pushd . > /dev/null && \
+ cd ../accounts-sso.gsignon-docs && \
+ git add $(PACKAGE)/* && \
+ git commit -m "Updated documentation for $(PACKAGE) to version $(VERSION)" && \
+ git push ; \
+ popd > /dev/null && \
+ rm -rf $(PACKAGE)-$(VERSION)