summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..c536d84
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,30 @@
+extensionsdir = $(EXTENSIONSDIR)
+pluginsdir = $(PLUGINSDIR)
+
+plugins_LTLIBRARIES = liboauth.la
+NULL=
+
+liboauth_la_CPPFLAGS = \
+ $(GSIGNON_CFLAGS) \
+ $(LIBSOUP_CFLAGS) \
+ $(NULL)
+
+liboauth_la_LIBADD = \
+ $(GSIGNON_LIBS) \
+ $(LIBSOUP_LIBS) \
+ $(NULL)
+
+liboauth_la_SOURCES = \
+ gsignond-oauth-plugin.c \
+ gsignond-oauth-plugin.h \
+ gsignond-oauth-plugin-oauth2.c \
+ gsignond-oauth-plugin-oauth2.h \
+ gsignond-oauth-plugin-oauth1.c \
+ gsignond-oauth-plugin-oauth1.h \
+ gsignond-oauth-plugin-utils.c \
+ gsignond-oauth-plugin-utils.h \
+ $(NULL)
+
+liboauth_la_LDFLAGS = -avoid-version
+
+CLEANFILES =