summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..262ec91
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,16 @@
+SUBDIRS = gtest
+
+AM_CFLAGS = $(LIBGUPNP_CFLAGS) -I$(top_srcdir)
+
+noinst_PROGRAMS = test-search-criteria-parser
+test_search_criteria_parser_SOURCES = test-search-criteria-parser.c
+test_search_criteria_parser_LDADD = \
+ $(top_builddir)/libgupnp-av/libgupnp-av-1.0.la \
+ $(LIBGUPNP_LIBS)
+
+check_PROGRAMS = check-search
+check_search_SOURCES = check-search.c
+check_search_LDADD = $(top_builddir)/libgupnp-av/libgupnp-av-1.0.la \
+ $(LIBGUPNP_LIBS)
+
+TESTS = $(check_PROGRAMS)