summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@open.eurogiciel.org>2014-11-17 13:11:55 +0100
committerManuel Bachmann <manuel.bachmann@open.eurogiciel.org>2014-11-17 13:11:55 +0100
commit0e6dd7341730320a5e5f93f6829b396c9a3bf779 (patch)
treeab8afcaf54f61c45660e3563b10793d0a8443875 /src/Makefile.am
parentb8043731fa1a64e9abba5edb685295b1dae1ee14 (diff)
downloadweston-common-80e738d3cc7ce892c2579d11672c258cd0c883fd.tar.gz
weston-common-80e738d3cc7ce892c2579d11672c258cd0c883fd.tar.bz2
weston-common-80e738d3cc7ce892c2579d11672c258cd0c883fd.zip
This commit fixes all the warnings issued during the "tz-launcher" compilation process. It also enforces coding style consistency, and fixes one memory leak of a cairo context. Change-Id: Ide7a7d8ada146c54c8bc493277d384854793709f Signed-off-by: Manuel Bachmann <manuel.bachmann@open.eurogiciel.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c1ecd64..ce29423 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -30,7 +30,7 @@ tz_launcher_SOURCES = \
toytoolkit/window.c
wl_pre_LDFLAGS = -export-dynamic
-wl_pre_CFLAGS = $(GCC_CFLAGS) $(CLIENT_CFLAGS)
+wl_pre_CFLAGS = $(GCC_CFLAGS) $(CLIENT_CFLAGS) -Wno-unused-result
wl_pre_LDADD = $(DLOPEN_LIBS) $(CLIENT_LIBS)
wl_pre_SOURCES = wl-pre.c