summaryrefslogtreecommitdiff
path: root/packaging/weston-common.spec
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@open.eurogiciel.org>2014-09-29 18:14:21 +0200
committerStephane Desneux <stephane.desneux@open.eurogiciel.org>2014-10-21 15:46:52 +0200
commitbbd7785dfe9da381b862a86ddb13a6a3d7cb71fd (patch)
tree5830b48e2790125a8c87b1ed065ad0224c51c2ce /packaging/weston-common.spec
parentace16a8ec59ded02a48edf17a67609d11e5df154 (diff)
downloadweston-common-bbd7785dfe9da381b862a86ddb13a6a3d7cb71fd.tar.gz
weston-common-bbd7785dfe9da381b862a86ddb13a6a3d7cb71fd.tar.bz2
weston-common-bbd7785dfe9da381b862a86ddb13a6a3d7cb71fd.zip
Fix weston startup with systemd 212
- %h placeholder *MUST NOT* be used in systemd(system) service files, starting from upstream commit 2cfbd749 - SMACK="<label>" *MUST* be changed to SECLABEL{smack}="<label>" in /etc/udev/rules.d/* Change-Id: I8f59f73f6d7b4ee6fa4faa7d6978135de326a327 Bug-Tizen: TC-660 Signed-off-by: Stephane Desneux <stephane.desneux@open.eurogiciel.org>
Diffstat (limited to 'packaging/weston-common.spec')
-rw-r--r--packaging/weston-common.spec6
1 files changed, 3 insertions, 3 deletions
diff --git a/packaging/weston-common.spec b/packaging/weston-common.spec
index 5b44e3e..b7b45e3 100644
--- a/packaging/weston-common.spec
+++ b/packaging/weston-common.spec
@@ -105,17 +105,17 @@ install -m 0644 weston.ini %{buildroot}%{weston_config_dir}
# open the graphics device
mkdir -p %{buildroot}%{_sysconfdir}/udev/rules.d
cat >%{buildroot}%{_sysconfdir}/udev/rules.d/99-dri.rules <<'EOF'
-SUBSYSTEM=="drm", MODE="0660", GROUP="%{daemon_group}", SMACK="*"
+SUBSYSTEM=="drm", MODE="0660", GROUP="%{daemon_group}", SECLABEL{smack}="*"
EOF
# user 'display' must own /dev/tty7 for weston to start correctly
cat >%{buildroot}%{_sysconfdir}/udev/rules.d/99-tty.rules <<'EOF'
-SUBSYSTEM=="tty", KERNEL=="tty7", OWNER="%{daemon_user}", SMACK="^"
+SUBSYSTEM=="tty", KERNEL=="tty7", OWNER="%{daemon_user}", SECLABEL{smack}="^"
EOF
# user 'display' must also be able to access /dev/input/event*
cat >%{buildroot}%{_sysconfdir}/udev/rules.d/99-input.rules <<'EOF'
-SUBSYSTEM=="input", KERNEL=="event*", MODE="0660", GROUP="input", SMACK="^"
+SUBSYSTEM=="input", KERNEL=="event*", MODE="0660", GROUP="input", SECLABEL{smack}="^"
EOF
# install desktop file