summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSuchang Woo <suchang.woo@samsung.com>2015-12-18 13:25:01 +0900
committerSuchang Woo <suchang.woo@samsung.com>2015-12-18 13:25:01 +0900
commitc422f95670269a00181e4a8152f098dde21ea089 (patch)
tree0c8ec1283fc576d0fbfd1ae5769823ec3676a962 /Makefile.am
downloadsed-c422f95670269a00181e4a8152f098dde21ea089.tar.gz
sed-c422f95670269a00181e4a8152f098dde21ea089.tar.bz2
sed-c422f95670269a00181e4a8152f098dde21ea089.zip
Imported Upstream version 4.1cupstream/4.1cupstream
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..394f729
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,57 @@
+## Process this file with automake to produce Makefile.in
+
+# Automake requirements
+AUTOMAKE_OPTIONS = gnits 1.8
+ACLOCAL_AMFLAGS = -I build-aux
+
+PACKAGE = sed
+
+SUBDIRS = intl lib po sed doc testsuite
+
+noinst_DATA = bootstrap.sh
+noinst_HEADERS = basicdefs.h
+
+EXTRA_DIST = BUGS THANKS COPYING.DOC README.boot \
+ autoboot build-aux/texi2dvi build-aux/help2man
+
+html:
+ cd doc && make html
+
+DISTCHECK_CONFIGURE_FLAGS = XGETTEXT='$(SHELL) -c : dummy' $(EXTRA_DC_FLAGS)
+EXTRA_DC_FLAGS =
+
+dist-hook:
+ cmp bootstrap.sh $(srcdir)/bootstrap.sh > /dev/null 2>&1 || \
+ cp -p bootstrap.sh $(srcdir)/bootstrap.sh
+ cp -p $(srcdir)/bootstrap.sh $(distdir)/bootstrap.sh
+
+full-distcheck:
+ make distcheck EXTRA_DC_FLAGS='--enable-regex-tests'
+ make distcheck EXTRA_DC_FLAGS='--enable-html'
+ make distcheck EXTRA_DC_FLAGS='--disable-i18n'
+ make distcheck EXTRA_DC_FLAGS='--disable-nls'
+ make distcheck EXTRA_DC_FLAGS='--without-included-gettext'
+ @case "$(host)" in \
+ *-linux*|*-gnu*) \
+ echo make distcheck EXTRA_DC_FLAGS=\'--without-included-regex\'; \
+ make distcheck EXTRA_DC_FLAGS='--without-included-regex' \
+ ;; \
+ *) \
+ echo Skipping check --without-included-regex \
+ ;; \
+ esac
+
+## update-regex:
+## HOST=sources.redhat.com && \
+## BASEURL="http://$$HOST/cgi-bin/cvsweb.cgi/~checkout~/libc/posix" && \
+## QUERY='cvsroot=glibc&content-type=text/plain' && \
+## wget -O lib/regcomp.c "$$BASEURL/regcomp.c?$$QUERY" && \
+## wget -O lib/regexec.c "$$BASEURL/regexec.c?$$QUERY" && \
+## wget -O lib/regex.c "$$BASEURL/regex.c?$$QUERY" && \
+## wget -O lib/regex_.h "$$BASEURL/regex.h?$$QUERY" && \
+## wget -O lib/regex_internal.c "$$BASEURL/regex_internal.c?$$QUERY" && \
+## wget -O lib/regex_internal.h "$$BASEURL/regex_internal.h?$$QUERY" && \
+## wget -O testsuite/BOOST.tests "$$BASEURL/BOOST.tests?$$QUERY" && \
+## wget -O testsuite/PCRE.tests "$$BASEURL/PCRE.tests?$$QUERY" && \
+## wget -O testsuite/SPENCER.tests "$$BASEURL/rxspencer/tests?$$QUERY"
+