summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 44cfabea..c6d02443 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -14,6 +14,7 @@ AM_CFLAGS = \
$(NULL)
EXTRA_DIST = \
+ errors_helpers.h \
globals.h \
kw_aes_des.h \
skeleton \
@@ -46,7 +47,6 @@ libxmlsec1_la_SOURCES = \
nodeset.c \
parser.c \
relationship.c \
- soap.c \
strings.c \
templates.c \
transforms.c \
@@ -59,6 +59,10 @@ libxmlsec1_la_SOURCES = \
xslt.c \
$(NULL)
+if XMLSEC_ENABLE_SOAP
+libxmlsec1_la_SOURCES += soap.c
+endif
+
libxmlsec1_la_LIBADD = \
$(LIBXSLT_LIBS) \
$(LIBXML_LIBS) \