summaryrefslogtreecommitdiff
path: root/docs/api/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/api/Makefile.am')
-rw-r--r--docs/api/Makefile.am27
1 files changed, 8 insertions, 19 deletions
diff --git a/docs/api/Makefile.am b/docs/api/Makefile.am
index 63c3e009..e6741388 100644
--- a/docs/api/Makefile.am
+++ b/docs/api/Makefile.am
@@ -1,5 +1,11 @@
#
+# To remove "bad" chars, run the following command
#
+# for i in `grep -l $'\xA0' *` ; do \
+# echo $i ; \
+# sed 's/\xA0/ /g' $i > $i.tmp ; \
+# mv $i.tmp $i ; \
+# done
#
NULL=
TOP=../..
@@ -32,9 +38,9 @@ all:
docs: sgml html clean-sources
-# need to cleanup "bad" chars
html: sgml xmlsec.sgml xmlsec-index
gtkdoc-mkhtml xmlsec xmlsec.sgml
+
#
# Prepeare sgml files from sources for each library. We are also
@@ -59,12 +65,6 @@ sgml: templates
--output-dir=sgml/gnutls \
--source-dir=$(DOC_SOURCE_DIR)/src/gnutls \
--source-dir=$(DOC_SOURCE_DIR)/include/xmlsec/gnutls
- -@gtkdoc-mkdb --module=xmlsec-gcrypt \
- --main-sgml-file=xmlsec-gcrypt.sgml \
- --tmpl-dir=tmpl/gcrypt \
- --output-dir=sgml/gcrypt \
- --source-dir=$(DOC_SOURCE_DIR)/src/gcrypt \
- --source-dir=$(DOC_SOURCE_DIR)/include/xmlsec/gcrypt
-@gtkdoc-mkdb --module=xmlsec-nss \
--main-sgml-file=xmlsec-nss.sgml \
--tmpl-dir=tmpl/nss \
@@ -92,8 +92,6 @@ templates: scan
--output-dir=tmpl/openssl
-@gtkdoc-mktmpl --module=xmlsec-gnutls \
--output-dir=tmpl/gnutls
- -@gtkdoc-mktmpl --module=xmlsec-gcrypt \
- --output-dir=tmpl/gcrypt
-@gtkdoc-mktmpl --module=xmlsec-nss \
--output-dir=tmpl/nss
-@gtkdoc-mktmpl --module=xmlsec-mscrypto \
@@ -101,27 +99,18 @@ templates: scan
scan: doc_sources example_sources
-@gtkdoc-scan --module=xmlsec \
- --rebuild-sections \
--source-dir=$(DOC_SOURCE_DIR)/src/base \
--source-dir=$(DOC_SOURCE_DIR)/include/xmlsec/base
-@gtkdoc-scan --module=xmlsec-openssl \
- --rebuild-sections \
--source-dir=$(DOC_SOURCE_DIR)/src/openssl \
--source-dir=$(DOC_SOURCE_DIR)/include/xmlsec/openssl
-@gtkdoc-scan --module=xmlsec-gnutls \
- --rebuild-sections \
--source-dir=$(DOC_SOURCE_DIR)/src/gnutls \
--source-dir=$(DOC_SOURCE_DIR)/include/xmlsec/gnutls
- -@gtkdoc-scan --module=xmlsec-gcrypt \
- --rebuild-sections \
- --source-dir=$(DOC_SOURCE_DIR)/src/gcrypt \
- --source-dir=$(DOC_SOURCE_DIR)/include/xmlsec/gcrypt
-@gtkdoc-scan --module=xmlsec-nss \
- --rebuild-sections \
--source-dir=$(DOC_SOURCE_DIR)/src/nss \
--source-dir=$(DOC_SOURCE_DIR)/include/xmlsec/nss
-@gtkdoc-scan --module=xmlsec-mscrypto \
- --rebuild-sections \
--source-dir=$(DOC_SOURCE_DIR)/src/mscrypto \
--source-dir=$(DOC_SOURCE_DIR)/include/xmlsec/mscrypto
@@ -153,7 +142,7 @@ doc_sources: $(DOC_SOURCE_FILES)
#
# Create index for all functions. For macros and defines need to add -CAPS suffix
#
-xmlsec-index: scan
+xmlsec-index: scan
@grep -h '<NAME>.*</NAME>' xmlsec-*decl.txt | \
grep -v '<NAME>extern</NAME>' | \
sort -u | \