summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAleksey Sanin <aleksey@src.gnome.org>2002-08-01 06:41:02 +0000
committerAleksey Sanin <aleksey@src.gnome.org>2002-08-01 06:41:02 +0000
commitfb947e62b727b83391d44f9af1b59067cb71d316 (patch)
treead002fcd3b608f8d5d727548e77665cb959ab7a1 /configure.in
parent39e542239b60b8c0ce37debc48768b1ced3f7194 (diff)
downloadxmlsec1-fb947e62b727b83391d44f9af1b59067cb71d316.tar.gz
xmlsec1-fb947e62b727b83391d44f9af1b59067cb71d316.tar.bz2
xmlsec1-fb947e62b727b83391d44f9af1b59067cb71d316.zip
added "enable-profiling" config option starting XPath and enveloped
* Makefile.am configure.in: added "enable-profiling" config option * docs/download.html docs/index.html src/c14n.c: starting XPath and enveloped transforms performance improvements * tests/Makefile.am tests/merlin-c14n-three/* tests/testDSig.sh: added one more Merlin's test suite for exc-c14n
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b156d654..7e557bc9 100644
--- a/configure.in
+++ b/configure.in
@@ -440,6 +440,18 @@ else
AC_MSG_RESULT(no)
fi
+dnl ==========================================================================
+dnl Profiling
+dnl ==========================================================================
+AC_MSG_CHECKING(for profiling)
+AC_ARG_ENABLE(profiling, [ --enable-profiling enable profiling compilation flags (no)])
+if test "$enable_profiling" = "yes" ; then
+ CFLAGS="$CFLAGS -pg"
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+
dnl ==========================================================================
dnl Final steps: xmlsec config