summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAleksey Sanin <aleksey@src.gnome.org>2002-08-13 20:41:05 +0000
committerAleksey Sanin <aleksey@src.gnome.org>2002-08-13 20:41:05 +0000
commitfa724e7aa51f7c3ee0877fd5b32722a71169c046 (patch)
treea00afdeb39ee6c78df2970b2689eaa0efbc9dc4c /configure.in
parent62f5484c268cf616a919edfa196cce2f8e57f472 (diff)
downloadxmlsec1-fa724e7aa51f7c3ee0877fd5b32722a71169c046.tar.gz
xmlsec1-fa724e7aa51f7c3ee0877fd5b32722a71169c046.tar.bz2
xmlsec1-fa724e7aa51f7c3ee0877fd5b32722a71169c046.zip
changed error reporting system and updated all files accordingly
* include/xmlsec/errors.h src/*.c configure.in: changed error reporting system and updated all files accordingly
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 2 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index a2eaf0d6..7a3e757e 100644
--- a/configure.in
+++ b/configure.in
@@ -396,28 +396,14 @@ else
AC_MSG_RESULT(yes)
fi
-
-
-dnl ==========================================================================
-dnl See do we need debug
-dnl ==========================================================================
-AC_MSG_CHECKING(for debug log messages)
-AC_ARG_ENABLE(debug, [ --enable-debug enable debug log message (yes)])
-if test "$enable_debug" = "no" ; then
- AC_MSG_RESULT(no)
-else
- XMLSEC_DEFINES="-DXMLSEC_DEBUG=1 $XMLSEC_DEFINES"
- AC_MSG_RESULT(yes)
-fi
-
dnl ==========================================================================
dnl Pedantic compile
dnl ==========================================================================
AC_MSG_CHECKING(for pedantic compilation)
AC_ARG_ENABLE(pedantic, [ --enable-pedantic enable pedantic compilation flags (no)])
if test "$enable_pedantic" = "yes" ; then
-dnl XMLSEC_PEDANTIC="-pedantic -W -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat -Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls"
- XMLSEC_PEDANTIC="-pedantic -W -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat -Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls"
+ XMLSEC_PEDANTIC="-pedantic -W -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat -Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls"
+ dnl XMLSEC_PEDANTIC="-pedantic -W -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat -Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls"
CFLAGS="$CFLAGS $XMLSEC_PEDANTIC"
AC_MSG_RESULT(yes)
else