summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAleksey Sanin <aleksey@src.gnome.org>2002-08-13 21:03:04 +0000
committerAleksey Sanin <aleksey@src.gnome.org>2002-08-13 21:03:04 +0000
commit57c2303fdac76afdf1bc7af958c123eccf85f1b5 (patch)
tree7280a62cb72db254b6277ea4acd831ed69b37211 /configure.in
parentfa724e7aa51f7c3ee0877fd5b32722a71169c046 (diff)
downloadxmlsec1-57c2303fdac76afdf1bc7af958c123eccf85f1b5.tar.gz
xmlsec1-57c2303fdac76afdf1bc7af958c123eccf85f1b5.tar.bz2
xmlsec1-57c2303fdac76afdf1bc7af958c123eccf85f1b5.zip
replaced XMLSEC_OPENSSL097 define with XMLSEC_OPENSSL096 define updated
* apps/xmlsec.c configure.in src/ciphers.c src/des.c src/dsa.c src/hmac.c src/rsa.c: replaced XMLSEC_OPENSSL097 define with XMLSEC_OPENSSL096 define * docs/api/*: updated docs with new errors reporting functions
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 7a3e757e..5dc81876 100644
--- a/configure.in
+++ b/configure.in
@@ -202,9 +202,9 @@ else
#endif
],[
OPENSSL_VERSION="0.9.7"
- XMLSEC_DEFINES="$XMLSEC_DEFINES -DXMLSEC_OPENSSL097=1"
],[
- XMLSEC_SOMETHING="1"
+ OPENSSL_VERSION="0.9.6"
+ XMLSEC_DEFINES="$XMLSEC_DEFINES -DXMLSEC_OPENSSL096=1"
])
CPPFLAGS=$OLD_CPPFLAGS
AC_MSG_RESULT(yes ('$OPENSSL_VERSION' ))
@@ -402,8 +402,8 @@ dnl ==========================================================================
AC_MSG_CHECKING(for pedantic compilation)
AC_ARG_ENABLE(pedantic, [ --enable-pedantic enable pedantic compilation flags (no)])
if test "$enable_pedantic" = "yes" ; then
- XMLSEC_PEDANTIC="-pedantic -W -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat -Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls"
- dnl XMLSEC_PEDANTIC="-pedantic -W -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat -Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls"
+ dnl XMLSEC_PEDANTIC="-pedantic -W -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat -Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls"
+ XMLSEC_PEDANTIC="-pedantic -W -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat -Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls"
CFLAGS="$CFLAGS $XMLSEC_PEDANTIC"
AC_MSG_RESULT(yes)
else