summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAleksey Sanin <aleksey@src.gnome.org>2003-04-24 15:24:44 +0000
committerAleksey Sanin <aleksey@src.gnome.org>2003-04-24 15:24:44 +0000
commit22414625d204acc7b1b964df9a04db75c1fa34d3 (patch)
tree27958e624dd173f2c52a0af9ba7c2e0e24c2f4b1 /configure.in
parent80b533681f4b0d5d75d56265a438b7604cf5bb22 (diff)
downloadxmlsec1-22414625d204acc7b1b964df9a04db75c1fa34d3.tar.gz
xmlsec1-22414625d204acc7b1b964df9a04db75c1fa34d3.tar.bz2
xmlsec1-22414625d204acc7b1b964df9a04db75c1fa34d3.zip
use '#define' instead of 'typedef' for the new xmlSecSize and xmlSecByte
* config.h.in configure.in include/xmlsec/xmlsec.h: use '#define' instead of 'typedef' for the new xmlSecSize and xmlSecByte types in order to keep ABI
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f6612277..634630a3 100644
--- a/configure.in
+++ b/configure.in
@@ -56,7 +56,6 @@ AC_CHECK_FUNCS(printf sprintf fprintf snprintf vfprintf vsprintf vsnprintf sscan
-
XMLSEC_DEFINES=""
@@ -79,6 +78,17 @@ else
fi
AC_SUBST(XMLSEC_STATIC_BINARIES)
+
+dnl ==========================================================================
+dnl check do we have size_t and its size,
+dnl TODO: will need to replace this and the xmlSecSize define with
+dnl typedef on next ABI refresh
+dnl ==========================================================================
+AC_CHECK_SIZEOF(size_t)
+if test "$ac_cv_sizeof_size_t" -ne "4" ; then
+ XMLSEC_DEFINES="$XMLSEC_DEFINES -DXMLSEC_NO_SIZE_T"
+fi
+
dnl ==========================================================================
dnl find libxml
dnl ==========================================================================