summaryrefslogtreecommitdiff
path: root/packaging/xkeyboard-config.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/xkeyboard-config.spec')
-rw-r--r--packaging/xkeyboard-config.spec7
1 files changed, 3 insertions, 4 deletions
diff --git a/packaging/xkeyboard-config.spec b/packaging/xkeyboard-config.spec
index d445f9bd..594d1678 100644
--- a/packaging/xkeyboard-config.spec
+++ b/packaging/xkeyboard-config.spec
@@ -80,10 +80,10 @@ ln -sf tizen %{buildroot}/%{TZ_SYS_RO_SHARE}/X11/xkb/rules/evdev
export LOCAL_KEYMAP_PATH=%{buildroot}/%{TZ_SYS_RO_SHARE}/X11/xkb
export RULE_FILE_PATH=%{TZ_SYS_RO_SHARE}/X11/xkb/xkb.rule
export KEYMAP_FILE_PATH="%{KEYMAP_FILE_PATH}"
+./remove_unused_files.sh
install -m 0700 make_symbols.sh %{buildroot}%{_bindir}/
install -m 0700 make_keycodes.sh %{buildroot}%{_bindir}/
-install -m 0700 remove_unused_files.sh %{buildroot}%{_bindir}/
install -m 0700 remove_symbols.sh %{buildroot}%{_bindir}/
# DO the optimization at RPM install, not at build
@@ -101,13 +101,13 @@ export KEYMAP_FILE_PATH=%{KEYMAP_FILE_PATH}
pushd %{TZ_SYS_RO_SHARE}/X11/xkb
%{_bindir}/make_keycodes.sh
%{_bindir}/make_symbols.sh
+%{_bindir}/remove_symbols.sh
rm -f %{_bindir}/make_keycodes.sh
rm -f %{_bindir}/make_symbols.sh
+rm -f %{_bindir}/remove_symbols.sh
popd
pushd /tmp/xkeyboard-config-install
ln -sf %{_bindir}/remove_symbols.sh remove_symbols.sh
-%{_bindir}/remove_unused_files.sh
-rm -f %{_bindir}/remove_unused_files.sh
rm -f %{_bindir}/remove_symbols.sh
rm remove_symbols.sh
%{_bindir}/cache
@@ -128,5 +128,4 @@ popd
%{_bindir}/cache
%{_bindir}/make_keycodes.sh
%{_bindir}/make_symbols.sh
-%{_bindir}/remove_unused_files.sh
%{_bindir}/remove_symbols.sh