summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChangyeon Lee <cyeon.lee@samsung.com>2014-04-17 14:39:58 +0900
committerChangyeon Lee <cyeon.lee@samsung.com>2014-04-17 14:46:42 +0900
commitb94d0d98ecc1d1c54ea28807971e1e06031f1fd5 (patch)
tree69e70a677b936b3a86c9f73b01be30463943bfca /configure.ac
parent8af8be009664eb1fb5179833b8b22b8dea5ce4c8 (diff)
parentd4ae73a746b08170c8337b997f6d87d051876b7d (diff)
downloadxkbutils-b94d0d98ecc1d1c54ea28807971e1e06031f1fd5.tar.gz
xkbutils-b94d0d98ecc1d1c54ea28807971e1e06031f1fd5.tar.bz2
xkbutils-b94d0d98ecc1d1c54ea28807971e1e06031f1fd5.zip
Change-Id: I3f420dbf5face7fb158162acde8bf37fe377875c Signed-off-by: Changyeon Lee <cyeon.lee@samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 15 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 4e7ee76..2908135 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,11 +21,17 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
+# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([xkbutils], [1.0.3],
+AC_INIT([xkbutils], [1.0.4],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xkbutils])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
+AM_PROG_CC_C_O
# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
@@ -33,17 +39,18 @@ m4_ifndef([XORG_MACROS_VERSION],
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
-AM_CONFIG_HEADER(config.h)
-
-AM_PROG_CC_C_O
+AC_CHECK_FUNCS([strcasecmp])
# xkbvleds checks
-PKG_CHECK_MODULES(XKBVLEDS, xproto xaw7 xt x11)
+PKG_CHECK_MODULES(XKBVLEDS, [xproto >= 7.0.17 xaw7 xt x11])
# xkbbell checks
-PKG_CHECK_MODULES(XKBBELL, xproto inputproto x11)
+PKG_CHECK_MODULES(XKBBELL, [xproto inputproto x11])
# xkbwatch checks
-PKG_CHECK_MODULES(XKBWATCH, xproto xaw7 xt x11)
+PKG_CHECK_MODULES(XKBWATCH, [xproto >= 7.0.17 xaw7 xt x11])
-AC_OUTPUT([Makefile])
+AC_CONFIG_FILES([
+ Makefile
+ man/Makefile])
+AC_OUTPUT