summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-12-29 21:28:52 -0800
committerAnas Nashif <anas.nashif@intel.com>2012-12-29 21:28:52 -0800
commitf6b5f84ec2ea1b551194013776a03adf4c101f89 (patch)
treeff50d50384180f7ef55f850ddf6e45da815fb955 /configure.ac
downloadxhost-f6b5f84ec2ea1b551194013776a03adf4c101f89.tar.gz
xhost-f6b5f84ec2ea1b551194013776a03adf4c101f89.tar.bz2
xhost-f6b5f84ec2ea1b551194013776a03adf4c101f89.zip
Imported Upstream version 1.0.5upstream/1.0.5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..1b069e8
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,37 @@
+dnl Process this file with autoconf to create configure.
+
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT([xhost], [1.0.5],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xhost])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
+
+AC_TYPE_SIGNAL
+
+# Checks for pkg-config packages
+# - Both CFLAGS & LIBS needed:
+PKG_CHECK_MODULES(XHOST, x11 xmuu)
+# - Only CFLAGS needed, not libs:
+PKG_CHECK_MODULES(XAU, xau)
+
+# Transport selection macro from xtrans.m4
+XTRANS_CONNECTION_FLAGS
+
+# Secure RPC detection macro from xtrans.m4
+XTRANS_SECURE_RPC_FLAGS
+
+AC_CONFIG_FILES([
+ Makefile
+ man/Makefile])
+AC_OUTPUT