summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChangyeon Lee <cyeon.lee@samsung.com>2014-04-17 14:39:53 +0900
committerChangyeon Lee <cyeon.lee@samsung.com>2014-04-17 14:46:26 +0900
commit0d14ae7c1368e74b6244b07580b90d268dba0a64 (patch)
tree77f3112e170f4d94828a86b8124df1ff46458111 /configure.ac
parente073443cb207e4b064206802c2acd46d21e47c02 (diff)
parent83e84e4894946a89a852bd73ca342369c5e5faf8 (diff)
downloadxhost-devel/x11.tar.gz
xhost-devel/x11.tar.bz2
xhost-devel/x11.zip
Change-Id: I76179e1cad0e77297b84687a1de40db8f1690fc7 Signed-off-by: Changyeon Lee <cyeon.lee@samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1b069e8..0d6f506 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to create configure.
# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([xhost], [1.0.5],
+AC_INIT([xhost], [1.0.6],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xhost])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
@@ -17,11 +17,9 @@ m4_ifndef([XORG_MACROS_VERSION],
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
-AC_TYPE_SIGNAL
-
# Checks for pkg-config packages
# - Both CFLAGS & LIBS needed:
-PKG_CHECK_MODULES(XHOST, x11 xmuu)
+PKG_CHECK_MODULES(XHOST, [xproto >= 7.0.22 x11 xmuu])
# - Only CFLAGS needed, not libs:
PKG_CHECK_MODULES(XAU, xau)
@@ -31,6 +29,15 @@ XTRANS_CONNECTION_FLAGS
# Secure RPC detection macro from xtrans.m4
XTRANS_SECURE_RPC_FLAGS
+# Link with winsock if mingw target
+case $host_os in
+ *mingw*)
+ AC_CHECK_LIB([ws2_32],[main])
+ ;;
+ *)
+ ;;
+esac
+
AC_CONFIG_FILES([
Makefile
man/Makefile])