summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Hellstrom <thellstrom@vmware.com>2011-06-16 21:21:25 +0200
committerThomas Hellstrom <thellstrom@vmware.com>2011-06-16 21:31:44 +0200
commitd28613e557fcdc4fc69f9a138a8c5fc909a719f5 (patch)
tree1b4971d9c34a8eed7a6861071ae5167e1df5bd0e /configure.ac
parent84166d4b457244bcc2f5ace63702d594d602d0c2 (diff)
downloadxf86-video-vmware-d28613e557fcdc4fc69f9a138a8c5fc909a719f5.tar.gz
xf86-video-vmware-d28613e557fcdc4fc69f9a138a8c5fc909a719f5.tar.bz2
xf86-video-vmware-d28613e557fcdc4fc69f9a138a8c5fc909a719f5.zip
vmwgfx: Fix up driver build process for Xserver >= 1.7.
Signed-off-by: Thomas Hellstrom <thellstrom@vmware.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 21 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index bbb530a..d4580ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,7 +91,8 @@ PKG_CHECK_EXISTS([xorg-server >= 1.4.99],
PKG_CHECK_EXISTS([xorg-server >= 1.7.0],
[AC_DEFINE([HAVE_XORG_SERVER_1_7_0], 1,
- [Has version 1.7.0 or greater of the Xserver])])
+ [Has version 1.7.0 or greater of the Xserver])
+ BUILD_VMWGFX=yes],[BUILD_VMWGFX=yes])
# Obtain compiler/linker options for the vmwarectrl client tool
PKG_CHECK_MODULES(X11, x11 xext)
@@ -113,15 +114,32 @@ AM_CONDITIONAL(XSERVER_LIBPCIACCESS, test "x$XSERVER_LIBPCIACCESS" = xyes)
AC_SUBST([moduledir])
+if test x$BUILD_VMWGFX = xyes; then
+ PKG_CHECK_MODULES([XATRACKER], [xatracker >= 0.1.0],[],[BUILD_VMWGFX=no])
+fi
+
DRIVER_NAME=vmware
AC_SUBST([DRIVER_NAME])
+
+VMWGFX_DIRS=
+if test x$BUILD_VMWGFX = xyes; then
+ VMWGFX_DIRS="vmwgfx saa"
+ AC_CONFIG_FILES([
+ saa/Makefile
+ vmwgfx/Makefile
+ ])
+ echo "Will build the vmwgfx driver."
+else
+ echo "Will not build the vmwgfx driver."
+fi
+
+AC_SUBST([VMWGFX_DIRS])
AC_CONFIG_FILES([
Makefile
src/Makefile
vmwarectrl/Makefile
man/Makefile
- saa/Makefile
- vmwgfx/Makefile
])
+
AC_OUTPUT